summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
-rw-r--r--glew_fix.patch11
-rw-r--r--openal_fix.patch14
4 files changed, 34 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c49a8001fad..b76c69048b3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = openframeworks
pkgdesc = An open source C++ toolkit for creative coding.
- pkgver = 0.10.1
- pkgrel = 3
+ pkgver = 0.11.0
+ pkgrel = 1
url = http://openframeworks.cc/
install = openframeworks.install
arch = x86_64
license = MIT
depends = make
- depends = pkg-config
+ depends = pkgconf
depends = gcc
+ depends = poco
depends = openal
depends = python-lxml
depends = glew
@@ -32,12 +33,12 @@ pkgbase = openframeworks
optdepends = qtcreator
optdepends = xterm
options = !strip
- source = glew_fix.patch
+ source = openal_fix.patch
source = of-make-workspace
- source = https://openframeworks.cc/versions/v0.10.1/of_v0.10.1_linux64gcc6_release.tar.gz
- sha256sums = 1c36ee2b8d931c4450e7113324a58a63222465f9469e6732419616de803cddcc
+ source = https://openframeworks.cc/versions/v0.11.0/of_v0.11.0_linux64gcc6_release.tar.gz
+ sha256sums = 3e04a8ff4da53e813c0d20b87d5f2231a10767b3a0960af46b0902812b616734
sha256sums = b4fc38288595df566f770018d871970fb13fb2ad4af7e9e5cddc60288f338806
- sha256sums = 9cc5133028b84d5031dbd054719238095e46a5aed507f3b32265fa2906f37905
+ sha256sums = 513cee3ce081e79fdc1a942af09869145fff3d7addeee0a76cef26fbc3ae69b1
pkgname = openframeworks
diff --git a/PKGBUILD b/PKGBUILD
index a2b3c1c8627f..758ef53599ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,38 @@
-# Maintainer: Marco Pompili <aur (at) mg.odd.red>
+# Maintainer: Marco Pompili <aur@mg.odd.red>
DLAGENTS=("https::/usr/bin/curl -k -o %o %u")
pkgname=openframeworks
-pkgver=0.10.1
-pkgrel=3
+pkgver=0.11.0
+pkgrel=1
pkgdesc="An open source C++ toolkit for creative coding."
url="http://openframeworks.cc/"
arch=('x86_64')
license=('MIT')
-depends=('make' 'pkg-config' 'gcc' 'openal' 'python-lxml' 'glew' 'glfw-x11' 'pugixml' 'freeglut' 'freeimage' 'gstreamer' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly' 'gst-libav' 'opencv' 'libxcursor' 'assimp' 'boost' 'mpg123' 'rtaudio' 'uriparser')
+depends=('make' 'pkgconf' 'gcc' 'poco' 'openal' 'python-lxml' 'glew' 'glfw-x11' 'pugixml' 'freeglut' 'freeimage' 'gstreamer' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly' 'gst-libav' 'opencv' 'libxcursor' 'assimp' 'boost' 'mpg123' 'rtaudio' 'uriparser')
optdepends=('qtcreator' 'xterm')
options=(!strip)
install=openframeworks.install
source=(
- "glew_fix.patch"
+ "openal_fix.patch"
"of-make-workspace"
"https://openframeworks.cc/versions/v${pkgver}/of_v${pkgver}_linux64gcc6_release.tar.gz")
-sha256sums=('1c36ee2b8d931c4450e7113324a58a63222465f9469e6732419616de803cddcc'
+sha256sums=('3e04a8ff4da53e813c0d20b87d5f2231a10767b3a0960af46b0902812b616734'
'b4fc38288595df566f770018d871970fb13fb2ad4af7e9e5cddc60288f338806'
- '9cc5133028b84d5031dbd054719238095e46a5aed507f3b32265fa2906f37905')
+ '513cee3ce081e79fdc1a942af09869145fff3d7addeee0a76cef26fbc3ae69b1')
_name="of_v${pkgver}_linux64gcc6_release"
prepare() {
cd ${srcdir}
- msg2 "Applying fix for glew redeclaration"
+ msg2 "Applying patch for openAL..."
# copy patch
- cp glew_fix.patch ${_name}
-
+ cp openal_fix.patch ${_name}
+
# apply patch
cd ${_name}
- patch -p0 < glew_fix.patch
-
-
+ patch -p0 < openal_fix.patch
export OF_ROOT=${srcdir}/${_name}
export LC_ALL=C
@@ -72,7 +70,7 @@ build() {
make -j$cores Debug
msg2 "Building openFrameworks Release version"
- make -j$cores Release
+ make -j$cores_JOBS Release
cd ${srcdir}/${_name}
diff --git a/glew_fix.patch b/glew_fix.patch
deleted file mode 100644
index 16585a335ed7..000000000000
--- a/glew_fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/openFrameworks/utils/ofConstants.back 2018-12-20 17:00:10.600334546 +0100
-+++ libs/openFrameworks/utils/ofConstants.h 2018-12-20 17:00:28.527301800 +0100
-@@ -209,7 +209,7 @@
- #define GL_GLEXT_PROTOTYPES
- #include <GL/glew.h>
- #include <GL/gl.h>
-- #include <GL/glext.h>
-+ // #include <GL/glext.h>
- #endif
-
- // for some reason, this isn't defined at compile time,
diff --git a/openal_fix.patch b/openal_fix.patch
new file mode 100644
index 000000000000..23d92f4802de
--- /dev/null
+++ b/openal_fix.patch
@@ -0,0 +1,14 @@
+--- libs/openFrameworks/sound/ofOpenALSoundPlayer.bck 2020-01-01 13:36:59.501973818 +0100
++++ libs/openFrameworks/sound/ofOpenALSoundPlayer.h 2020-01-01 13:37:52.486103430 +0100
+@@ -10,9 +10,9 @@
+
+ typedef unsigned int ALuint;
+ /** Opaque device handle */
+-typedef struct ALCdevice_struct ALCdevice;
++struct ALCdevice;
+ /** Opaque context handle */
+-typedef struct ALCcontext_struct ALCcontext;
++struct ALCcontext;
+
+
+