summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
-rwxr-xr-xof-make-workspace14
-rw-r--r--openframeworks.install8
4 files changed, 30 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f48586f1420..feb914407f58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jun 27 08:10:29 UTC 2016
+# Wed Aug 10 16:27:52 UTC 2016
pkgbase = openframeworks
- pkgdesc = openFrameworks is an open source C++ toolkit for creative coding.
+ pkgdesc = An open source C++ toolkit for creative coding.
pkgver = 0.9.3
- pkgrel = 2
+ pkgrel = 3
url = http://openframeworks.cc/
install = openframeworks.install
arch = x86_64
@@ -32,12 +32,14 @@ pkgbase = openframeworks
optdepends = qtcreator
optdepends = xterm
options = !strip
- source = http://openframeworks.cc/versions/v0.9.3/of_v0.9.3_linux64_release.tar.gz
source = rtAudio.patch
source = of-make-workspace
- md5sums = 95c5f436a66489ed1ca460bf593bdbe1
md5sums = 31600cdc597a275295fa35cf178f83c0
- md5sums = 594d0a3c82e0451f7b7fb353e3b658c6
+ md5sums = 924d38c4371b0d706a0f0c73accc75a0
+ source_x86_64 = http://www.openframeworks.cc/versions/v0.9.3/of_v0.9.3_linux64_release.tar.gz
+ md5sums_x86_64 = 95c5f436a66489ed1ca460bf593bdbe1
+ source_i686 = http://www.openframeworks.cc/versions/v0.9.3/of_v0.9.3_linux_release.tar.gz
+ md5sums_i686 = 5b9a6cf3e8ba372eba59a13cb403ea00
pkgname = openframeworks
diff --git a/PKGBUILD b/PKGBUILD
index b2e70e86f6a3..2bc03a9140cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=openframeworks
pkgver=0.9.3
-pkgrel=2
-pkgdesc="openFrameworks is an open source C++ toolkit for creative coding."
+pkgrel=3
+pkgdesc="An open source C++ toolkit for creative coding."
url="http://openframeworks.cc/"
arch=('x86_64' 'i686')
license=('MIT')
@@ -11,21 +11,22 @@ depends=('make' 'pkg-config' 'gcc' 'openal' 'python-lxml' 'glew' 'freeglut'
'freeimage' 'gstreamer' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad'
'gst-plugins-ugly' 'gst-libav' 'opencv' 'libxcursor' 'assimp' 'boost' 'mpg123' 'rtaudio')
optdepends=('qtcreator' 'xterm')
-makedepends=()
options=(!strip)
install=openframeworks.install
[[ "$CARCH" == "i686" ]] && _arch="linux" || _arch="linux64"
_name="of_v${pkgver}_${_arch}_release"
-source=("http://openframeworks.cc/versions/v${pkgver}/${_name}.tar.gz"
- "rtAudio.patch"
+source=("rtAudio.patch"
"of-make-workspace")
-[[ "$CARCH" == "i686" ]] && md5sums=("5b9a6cf3e8ba372eba59a13cb403ea00") || md5sums=("95c5f436a66489ed1ca460bf593bdbe1")
+source_i686=("http://www.openframeworks.cc/versions/v${pkgver}/of_v${pkgver}_linux_release.tar.gz")
+source_x86_64=("http://www.openframeworks.cc/versions/v${pkgver}/of_v${pkgver}_linux64_release.tar.gz")
-md5sums+=("31600cdc597a275295fa35cf178f83c0"
- "594d0a3c82e0451f7b7fb353e3b658c6")
+md5sums=('31600cdc597a275295fa35cf178f83c0'
+ '924d38c4371b0d706a0f0c73accc75a0')
+md5sums_x86_64=('95c5f436a66489ed1ca460bf593bdbe1')
+md5sums_i686=('5b9a6cf3e8ba372eba59a13cb403ea00')
prepare() {
export OF_ROOT=${srcdir}/${_name}
@@ -94,7 +95,7 @@ package() {
cp -R "${srcdir}/${_name}" "${pkgdir}/opt/openFrameworks"
- install -Dm775 "${srcdir}/of-make-workspace" "${pkgdir}/usr/bin/of-make-workspace"
+ install -Dm775 "${srcdir}/of-make-workspace" "${pkgdir}/opt/openFrameworks/scripts/of-make-workspace"
msg2 "Fixing emptyExample project files permissions..."
diff --git a/of-make-workspace b/of-make-workspace
index adf3ffeeb19f..c69ac8397806 100755
--- a/of-make-workspace
+++ b/of-make-workspace
@@ -2,7 +2,7 @@
echo -e "Initializing local workspace for openFrameworks..."
-WS=~/of-workspace
+WS=${1:-~/of-workspace}
mkdir -p $WS
cd $WS
@@ -12,18 +12,18 @@ cp -R /opt/openFrameworks/addons .
OFPATH="/opt/openFrameworks/"
if [ -d "${OFPATH}/projectGenerator-linux64" ]; then
- PJ="projectGenerator-linux64"
+ PG="projectGenerator-linux64"
PLATFORM="linux64"
elif [ -d "${OFPATH}/projectGenerator" ]; then
- PJ="projectGenerator"
+ PG="projectGenerator"
PLATFORM="linux"
fi
OFWSPATH=`pwd`
-cp -R $OFPATH/$PJ .
+cp -R $OFPATH/$PG .
-touch $PJ/resources/app/settings.json
+touch $PG/resources/app/settings.json
echo -e "{\n\t\"advancedMode\": false,\n\t \
\"defaultOfPath\": \"$OFWSPATH\",\n\t \
@@ -32,7 +32,7 @@ echo -e "{\n\t\"advancedMode\": false,\n\t \
\"showConsole\": false,\n\t \
\"showDeveloperTools\": false, \n\t \
\"useDictionaryNameGenerator\": true,\n\t \
-\"verboseOutput\": false\n}" > $PJ/resources/app/settings.json
+\"verboseOutput\": false\n}" > $PG/resources/app/settings.json
mkdir -p apps/myApps
@@ -52,3 +52,5 @@ ln -s /opt/openFrameworks/LICENSE.md
ln -s /opt/openFrameworks/other
ln -s /opt/openFrameworks/README.md
ln -s /opt/openFrameworks/scripts
+
+ln -s scripts/$PG/projectGenerator
diff --git a/openframeworks.install b/openframeworks.install
index c061cdf4a3b3..c01009aa7dde 100644
--- a/openframeworks.install
+++ b/openframeworks.install
@@ -1,10 +1,10 @@
post_install() {
echo "The Project Generator is in /opt/openFrameworks/apps/projectGenerator/projectGeneratorSimple."
- echo -e "To initialize the workspace needed for openFrameworks launch the command: \033[0;32mof-make-workspace\033[0m"
- echo "this command will initialize a workspace folder in your home directory."
+ echo -e "To initialize the workspace needed for openFrameworks launch the command: \033[0;32m/opt/openFrameworks/scripts/of-make-workspace [path]\033[0m"
+ echo "this command will initialize a workspace folder, with no path given the default folder is: ~/of-workspace."
}
post_update() {
- echo -e "Remeber to regenerate your local workspace using: \033[0;32mof-make-workspace\033[0m."
- echo -e "If you already have a local workspace in your home, \033[1;31mBACKUP YOUR PROJECTS BEFORE\033[0m generating a new local workspace."
+ echo -e "Remeber to regenerate your local workspace using: \033[0;32m/opt/openFrameworks/scripts/of-make-workspace [path]\033[0m."
+ echo -e "If you already have a local workspace, \033[1;31mBACKUP YOUR PROJECTS BEFORE\033[0m generating a new local workspace."
}