summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0735470050f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = opengothic
+ pkgdesc = Open source remake of Gothic 2: Night of the raven
+ pkgver = 0.35
+ pkgrel = 1
+ url = https://github.com/Try/OpenGothic
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ makedepends = vulkan-headers
+ depends = alsa-lib
+ depends = gcc-libs
+ depends = libx11
+ depends = vulkan-icd-loader
+ conflicts = bullet
+ options = !emptydirs
+ source = git+https://github.com/Try/OpenGothic#tag=v0.35
+ sha512sums = SKIP
+
+pkgname = opengothic
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc41b1940ef1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Christopher Reimer <mail at c-reimer dot de>
+
+pkgname=opengothic
+pkgver=0.35
+pkgrel=1
+pkgdesc="Open source remake of Gothic 2: Night of the raven"
+arch=('x86_64')
+url='https://github.com/Try/OpenGothic'
+license=('MIT')
+depends=('alsa-lib' 'gcc-libs' 'libx11' 'vulkan-icd-loader')
+makedepends=('cmake' 'git' 'vulkan-headers')
+conflicts=('bullet')
+source=("git+https://github.com/Try/OpenGothic#tag=v${pkgver}")
+sha512sums=('SKIP')
+options=('!emptydirs')
+
+prepare() {
+ cd "OpenGothic"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "OpenGothic"
+ cmake -B build -DBUILD_SHARED_LIBS=ON -DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/usr
+ make -C build
+}
+
+package() {
+ cd "OpenGothic"
+ DESTDIR="${pkgdir}" make -C build install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+