summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD19
2 files changed, 19 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3d0b3d2e724..c7b5c86bfa0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,13 +6,14 @@ pkgbase = oidn
arch = x86_64
license = Apache
makedepends = git
+ makedepends = git-lfs
makedepends = cmake
makedepends = ispc>=1.14
depends = intel-tbb
depends = python
source = oidn::git+https://github.com/OpenImageDenoise/oidn.git#tag=v1.2.3
source = git+https://github.com/OpenImageDenoise/mkl-dnn.git
- source = git+https://github.com/OpenImageDenoise/oidn-weights.git
+ source = git-lfs+https://github.com/OpenImageDenoise/oidn-weights.git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 72a2d68d9c05..a11640acbaca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,19 @@
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
+
+function download_git-lfs {
+ local url dir
+ url=${1#git-lfs+}
+ download_git "$url"
+ dir="$SRCDEST/$(get_filename "$url")"
+ git -C "$dir" lfs install
+ git -C "$dir" lfs fetch
+}
+
+function extract_git-lfs {
+ url=${1/git-lfs/https}
+ extract_git "$url"
+}
+
pkgname=oidn
pkgver=1.2.3
_fragment="#tag=v${pkgver}"
@@ -8,10 +23,10 @@ arch=('x86_64')
url="http://www.openimagedenoise.org/"
license=('Apache')
depends=(intel-tbb python)
-makedepends=(git cmake 'ispc>=1.14')
+makedepends=(git git-lfs cmake 'ispc>=1.14')
source=("${pkgname}::git+https://github.com/OpenImageDenoise/oidn.git${_fragment}"
"git+https://github.com/OpenImageDenoise/mkl-dnn.git"
- "git+https://github.com/OpenImageDenoise/oidn-weights.git"
+ "git-lfs+https://github.com/OpenImageDenoise/oidn-weights.git"
)
md5sums=('SKIP'
'SKIP'