summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO50
-rw-r--r--PKGBUILD72
-rw-r--r--dbus.patch11
-rw-r--r--openlp.install11
-rw-r--r--openlp.sh4
5 files changed, 148 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a59aada8d8ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,50 @@
+# Generated by mksrcinfo v8
+# Wed Nov 27 21:33:51 UTC 2019
+pkgbase = openlp-git
+ pkgdesc = Church presentation software.
+ pkgver = r16543.f5ffc6d57
+ pkgrel = 1
+ url = http://openlp.org/
+ install = openlp.install
+ arch = any
+ license = GPLv2
+ makedepends = qt5-tools
+ makedepends = git
+ depends = python>=3.8
+ depends = python<3.9
+ depends = python-pyqt5
+ depends = phonon-qt5
+ depends = python-chardet
+ depends = python-lxml
+ depends = python-six
+ depends = python-beautifulsoup4
+ depends = python-pyenchant
+ depends = python-dbus
+ depends = python-alembic
+ depends = mediainfo
+ depends = qt5-multimedia
+ depends = python-zeroconf
+ depends = qt5-webkit
+ depends = qt5-svg
+ depends = python-webob
+ depends = python-requests
+ depends = vlc
+ depends = python-waitress
+ depends = python-websockets
+ depends = python-qtawesome
+ depends = python-vlc
+ optdepends = libreoffice-fresh: display impress presentations
+ optdepends = mupdf: display pdfs
+ optdepends = python-mysql-connector: Use a mysql/mariadb database
+ optdepends = python-psycopg2: Use a postgresql database
+ provides = openlp
+ conflicts = openlp
+ source = git+https://gitlab.com/openlp/openlp.git
+ source = openlp.sh
+ source = dbus.patch
+ sha256sums = SKIP
+ sha256sums = 19c2f3c622585bf308efc259013fb5518feaf8cf14b51613e1e71778fcc2e8cf
+ sha256sums = e8aabadd8037179b15cb0093bb0dbd0ad1aa069e2990e13cec677b07eee1b1b6
+
+pkgname = openlp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88dc4c1e2bc0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Maintainer: Simon <thelinuxguy @ freenode>
+# Contributor: Garrett <floft.net/contact>
+
+pkgname=openlp-git
+_pkgbase=openlp
+pkgver=r16543.f5ffc6d57
+pkgrel=1
+pkgdesc="Church presentation software."
+arch=('any')
+url='http://openlp.org/'
+license=('GPLv2')
+provides=('openlp')
+conflicts=('openlp')
+makedepends=('qt5-tools' 'git')
+depends=('python>=3.8' 'python<3.9' 'python-pyqt5' 'phonon-qt5'
+ 'python-chardet' 'python-lxml' 'python-six'
+ 'python-beautifulsoup4' 'python-pyenchant' 'python-dbus'
+ 'python-alembic' 'mediainfo' 'qt5-multimedia' 'python-zeroconf'
+ 'qt5-webkit' 'qt5-svg' 'python-webob' 'python-requests' 'vlc'
+ 'python-waitress' 'python-websockets' 'python-qtawesome' 'python-vlc'
+ )
+optdepends=('libreoffice-fresh: display impress presentations'
+ 'mupdf: display pdfs'
+ 'python-mysql-connector: Use a mysql/mariadb database'
+ 'python-psycopg2: Use a postgresql database')
+install=openlp.install
+source=('git+https://gitlab.com/openlp/openlp.git' 'openlp.sh' 'dbus.patch')
+sha256sums=('SKIP'
+ '19c2f3c622585bf308efc259013fb5518feaf8cf14b51613e1e71778fcc2e8cf'
+ 'e8aabadd8037179b15cb0093bb0dbd0ad1aa069e2990e13cec677b07eee1b1b6')
+
+prepare() {
+ cd "$_pkgbase"
+ patch --forward --strip=1 --input="${srcdir}/dbus.patch"
+}
+
+
+pkgver() {
+ cd "$_pkgbase"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+#check() {
+# cd "$srcdir/trunk"
+# nosetests -v tests
+#}
+
+
+package() {
+ cd "${srcdir}/${_pkgbase}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ TAG=$(git describe --tags --abbrev=0)
+ VERSION="${TAG}.$(git rev-list $TAG.. --count)-$(git rev-parse --short HEAD)"
+ echo "$VERSION" > "$pkgdir/usr/lib/python3.8/site-packages/openlp/.version"
+
+ install -Dm0755 "$srcdir/openlp.sh" "$pkgdir/etc/profile.d/openlp.sh"
+ install -Dm0644 "resources/openlp.desktop" "$pkgdir/usr/share/applications/openlp.desktop"
+ install -Dm0644 "resources/images/openlp-logo.svg" "$pkgdir/usr/share/pixmaps/openlp.svg"
+ install -Dm0644 "resources/images/openlp-logo-48x48.png" "$pkgdir/usr/share/pixmaps/openlp.png"
+
+ #translations
+ tsrcdir="$srcdir/openlp/resources/i18n"
+ tdestdir="$pkgdir/usr/share/$pkgname/i18n"
+ mkdir -p "$tdestdir"
+ cd "$tsrcdir"
+
+ for file in *.ts; do
+ lconvert -i "$file" -o "$tdestdir/${file%%ts}qm"
+ done
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/dbus.patch b/dbus.patch
new file mode 100644
index 000000000000..4dd0d1c09934
--- /dev/null
+++ b/dbus.patch
@@ -0,0 +1,11 @@
+diff --unified --text openlp/setup.py openlp.new/setup.py
+--- openlp/setup.py 2019-11-27 22:22:05.477556034 +0100
++++ openlp.new/setup.py 2019-11-27 22:23:13.180384336 +0100
+@@ -100,7 +100,6 @@
+ 'appdirs',
+ 'beautifulsoup4',
+ 'chardet',
+- 'dbus-python; platform_system=="Linux"',
+ 'lxml',
+ 'Mako',
+ 'pymediainfo >= 2.2',
diff --git a/openlp.install b/openlp.install
new file mode 100644
index 000000000000..f6b57714e145
--- /dev/null
+++ b/openlp.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "Please logout and back in or source /etc/profile.d/openlp.sh"
+ echo "if you're going to be using impress presentations in openlp."
+ update-desktop-database -q
+}
+post_upgrade() {
+ post_install
+}
+post_remove() {
+ update-desktop-database -q
+}
diff --git a/openlp.sh b/openlp.sh
new file mode 100644
index 000000000000..cd43490e9571
--- /dev/null
+++ b/openlp.sh
@@ -0,0 +1,4 @@
+if [ -e "/usr/lib/libreoffice/program/uno.py" ]; then
+ export PYTHONPATH="$PYTHONPATH:/usr/lib/libreoffice/program/"
+ export URE_BOOTSTRAP="file:///usr/lib/libreoffice/program/fundamentalrc"
+fi