summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rwxr-xr-xPKGBUILD7
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a011bb6135d..71bd278a63ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,6 +16,7 @@ pkgbase = openmc-git
depends = python-pandas
depends = python-matplotlib
depends = python-uncertainties
+ depends = python-h5py-openmpi
depends = embree
depends = libxrender
depends = libxcursor
diff --git a/PKGBUILD b/PKGBUILD
index b2b1b66ada3a..f6c5947e4837 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,6 +23,7 @@ depends=(
python-pandas
python-matplotlib
python-uncertainties
+ python-h5py-openmpi
embree
libxrender
libxcursor
@@ -64,15 +65,13 @@ build() {
python \
-m build \
--wheel \
- --no-isolation
+ --no-isolation ../
}
package() {
cd $srcdir/${pkgname}/build
make DESTDIR="$pkgdir/" install
-
- #install python layer
- python -m installer --destdir="$pkgdir" dist/*.whl
+ python -m installer --destdir="$pkgdir" ../dist/*.whl
# make repository available in install location
cp -r $srcdir/${pkgname} $pkgdir/opt/openmc