summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xPKGBUILD9
-rw-r--r--post.install2
2 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a81d42403d5c..b2b1b66ada3a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -59,12 +59,21 @@ build() {
_ccores=$1
fi
make -j ${_ccores}
+
+ # build python layer
+ python \
+ -m build \
+ --wheel \
+ --no-isolation
}
package() {
cd $srcdir/${pkgname}/build
make DESTDIR="$pkgdir/" install
+ #install python layer
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
# make repository available in install location
cp -r $srcdir/${pkgname} $pkgdir/opt/openmc
diff --git a/post.install b/post.install
index bb8b6ab9cf6e..eb69cc2208e2 100644
--- a/post.install
+++ b/post.install
@@ -2,7 +2,7 @@ post_install() {
# installed to opt, inform user how to set paths
_path_msg="\nINFO: OpenMC and its dependencies were installed to the non-standard location /opt. Run the following command \
before attempting to use openmc:\n\n \
- source /etc/profile \n"
+ source /etc/profile \n"
echo -e $_path_msg
}