summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.curlrc1
-rw-r--r--PKGBUILD41
-rw-r--r--openmusic.install11
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f68e73ebef3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = openmusic
+ pkgdesc = A visual programming language designed for music composition. (32 bit)
+ pkgver = 6.9.1_beta_0
+ pkgrel = 3
+ url = http://repmus.ircam.fr/openmusic/linux
+ install = openmusic.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ options = !strip
+ source = .curlrc
+ source = http://forge.ircam.fr/p/OM/downloads/get/OM_6.9.1_beta_0.tar.bz2
+ md5sums = b0dc7498bade5c4fa60da87503a16ef2
+ md5sums = 6ba97ee9b63e4e8b3e9487ef8e758992
+
+pkgname = openmusic
+
diff --git a/.curlrc b/.curlrc
new file mode 100644
index 000000000000..a94e3f5eb4d8
--- /dev/null
+++ b/.curlrc
@@ -0,0 +1 @@
+--insecure
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06e4651fa39b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Daniel Appelt <daniel.appelt@gmail.com>
+pkgname=openmusic
+pkgver=6.9.1_beta_0
+pkgrel=3
+pkgdesc="A visual programming language designed for music composition. (32 bit)"
+arch=('i686' 'x86_64')
+url="http://repmus.ircam.fr/openmusic/linux"
+license=('GPL')
+case "$CARCH" in
+i686)
+ depends=('desktop-file-utils' 'gdk-pixbuf2' 'jack' 'portmidi' 'libsndfile'
+ 'libsdif')
+ optdepends=('libsamplerate: speed up audio-waveform drawing')
+ ;;
+x86_64)
+ depends=('desktop-file-utils' 'lib32-gdk-pixbuf2>=2.31.3-2' 'lib32-jack'
+ 'lib32-portmidi' 'lib32-libsndfile' 'lib32-libsdif')
+ optdepends=('lib32-libsamplerate: speed up audio-waveform drawing')
+ ;;
+esac
+# Note that the openmusic executable may not be compressed/stripped.
+# (http://www.lispworks.com/kb/a15fc2ea99b4f8f5802571fe0057705a.html)
+options=(!strip)
+install="$pkgname.install"
+# ircam.fr uses a self-signed SSL certificate which may lead to download problems.
+# The following environment variable, and source file .curlrc add option --insecure
+# to curl for the duration of this build process. By default, curl is configured as
+# download agent in makepkg.conf. If the download still does not work, check section
+# DLAGENTS in /etc/makepkgconf and add an option to allow insecure downloads to the
+# respective agent configuration.
+export CURL_HOME="$startdir"
+source=('.curlrc'
+ "http://forge.ircam.fr/p/OM/downloads/get/OM_${pkgver}.tar.bz2")
+md5sums=('b0dc7498bade5c4fa60da87503a16ef2'
+ '6ba97ee9b63e4e8b3e9487ef8e758992')
+
+package() {
+ cd "$srcdir/OM_${pkgver}"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+}
+
diff --git a/openmusic.install b/openmusic.install
new file mode 100644
index 000000000000..e111ef946053
--- /dev/null
+++ b/openmusic.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}