summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--fast.patch25
-rw-r--r--flann.patch13
-rw-r--r--lemon.patch13
-rw-r--r--libopenMVG_sfm_link_error.patch12
6 files changed, 80 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7528845e6a79..0fe66407a8f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openmvg-git
pkgdesc = open Multiple View Geometry library. Basis for 3D computer vision and Structure from Motion.
- pkgver = 1.0.r0.g944254c
- pkgrel = 4
+ pkgver = 1.3.r55.g01cb080b
+ pkgrel = 5
url = http://imagine.enpc.fr/~moulonp/openMVG/
arch = i686
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = openmvg-git
makedepends = cmake
makedepends = doxygen
makedepends = eigen
+ depends = lz4
depends = libpng
depends = libjpeg
depends = libtiff
@@ -19,21 +20,26 @@ pkgbase = openmvg-git
depends = graphviz
depends = libgl
depends = ceres-solver
+ depends = gflags
depends = flann
depends = coin-or-coinutils
depends = coin-or-clp
depends = coin-or-osi
depends = coin-or-lemon
- source = git+https://github.com/openMVG/openMVG.git
+ source = git+https://github.com/openMVG/openMVG.git#branch=develop
source = git+https://github.com/elmindreda/glfw.git
source = git+https://github.com/openMVG-thirdparty/osi_clp.git
source = git+https://github.com/openMVG-thirdparty/cereal.git
- source = libopenMVG_sfm_link_error.patch
+ source = fast.patch
+ source = lemon.patch
+ source = flann.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = 8e1dd6742b2ed87b1086829e75d69cee
+ md5sums = c2fff3b04a2444a635eab1709be6b4f2
+ md5sums = 11aa728e50e52b10d79dd83dfaa6c1c6
+ md5sums = 91e8cb2e3b2449de83dd49c83359b8ab
pkgname = openmvg-git
diff --git a/PKGBUILD b/PKGBUILD
index 6fbfa6a2490a..a8ac075c84c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,31 @@
# Maintainer: Kyle Brooks <brookskd@gmail.com>
+# update: bartus <aur\at/bartus.33mail.com>
pkgname=openmvg-git
-pkgver=1.0.r0.g944254c
-pkgrel=4
+_gitname='openMVG'
+_fragment="#branch=develop"
+pkgver=1.3.r55.g01cb080b
+pkgrel=5
pkgdesc='open Multiple View Geometry library. Basis for 3D computer vision and Structure from Motion.'
arch=('i686' 'x86_64')
url='http://imagine.enpc.fr/~moulonp/openMVG/'
license=('MPL')
-depends=('libpng' 'libjpeg' 'libtiff' 'libxrandr' 'libxxf86vm' 'libxi' 'graphviz' 'libgl' 'ceres-solver' 'flann' 'coin-or-coinutils' 'coin-or-clp' 'coin-or-osi' 'coin-or-lemon')
+depends=('lz4' 'libpng' 'libjpeg' 'libtiff' 'libxrandr' 'libxxf86vm' 'libxi' 'graphviz' 'libgl' 'ceres-solver' 'gflags' 'flann' 'coin-or-coinutils' 'coin-or-clp' 'coin-or-osi' 'coin-or-lemon')
makedepends=('git' 'cmake' 'doxygen' 'eigen')
-_gitname='openMVG'
-source=("git+https://github.com/openMVG/${_gitname}.git"
+source=("git+https://github.com/${_gitname}/${_gitname}.git${_fragment}"
'git+https://github.com/elmindreda/glfw.git'
'git+https://github.com/openMVG-thirdparty/osi_clp.git'
'git+https://github.com/openMVG-thirdparty/cereal.git'
- 'libopenMVG_sfm_link_error.patch'
+ 'fast.patch'
+ 'lemon.patch'
+ 'flann.patch'
)
md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '8e1dd6742b2ed87b1086829e75d69cee'
- )
+ 'c2fff3b04a2444a635eab1709be6b4f2'
+ '11aa728e50e52b10d79dd83dfaa6c1c6'
+ '91e8cb2e3b2449de83dd49c83359b8ab')
pkgver() {
cd "${srcdir}/${_gitname}"
@@ -34,14 +39,17 @@ prepare() {
git config 'submodule.src/dependencies/osi_clp.url' "${srcdir}/osi_clp"
git config 'submodule.src/dependencies/cereal.url' "${srcdir}/cereal"
git submodule update
- git apply ../libopenMVG_sfm_link_error.patch
+ git apply ${srcdir}/lemon.patch
+ git apply ${srcdir}/fast.patch
+ git apply ${srcdir}/flann.patch
+ cp src/third_party/flann/cmake/FindFlann.cmake src/cmakeFindModules/
}
build() {
cd "${srcdir}"
mkdir -p openmvg_build
cd openmvg_build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RELEASE -DOpenMVG_BUILD_SHARED=ON -DOpenMVG_BUILD_EXAMPLES=ON -DOpenMVG_BUILD_DOC=ON -DOpenMVG_BUILD_OPENGL_EXAMPLES=ON -DOpenMVG_USE_OPENMP=ON -DFLANN_INCLUDE_DIR_HINTS=/usr/include -DCOINUTILS_INCLUDE_DIR_HINTS=/usr/include/coin -DCLP_INCLUDE_DIR_HINTS=/usr/include/coin -DOSI_INCLUDE_DIR_HINTS=/usr/include/coin -DLEMON_INCLUDE_DIR_HINTS=/usr/include -DCERES_DIR_HINTS=/usr/share/Ceres -DEIGEN_INCLUDE_DIR_HINTS=/usr/include/eigen3 ../openMVG/src/
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RELEASE -DOpenMVG_BUILD_SHARED=ON -DOpenMVG_BUILD_EXAMPLES=ON -DOpenMVG_BUILD_OPENGL_EXAMPLES=ON -DOpenMVG_USE_OPENMP=ON -DFLANN_INCLUDE_DIR_HINTS=/usr/include -DCOINUTILS_INCLUDE_DIR_HINTS=/usr/include/coin -DCLP_INCLUDE_DIR_HINTS=/usr/include/coin -DOSI_INCLUDE_DIR_HINTS=/usr/include/coin -DLEMON_INCLUDE_DIR_HINTS=/usr/include/lemon -DCERES_DIR_HINTS=/usr/include/ceres -DEIGEN_INCLUDE_DIR_HINTS=/usr/include/eigen3 ../openMVG/src/
make
}
diff --git a/fast.patch b/fast.patch
new file mode 100644
index 000000000000..344ba71f1b7d
--- /dev/null
+++ b/fast.patch
@@ -0,0 +1,25 @@
+diff --git a/src/software/VO/AlternativeVO/CMakeLists.txt b/src/software/VO/AlternativeVO/CMakeLists.txt
+index c8bdafb2..d431fca4 100644
+--- a/src/software/VO/AlternativeVO/CMakeLists.txt
++++ b/src/software/VO/AlternativeVO/CMakeLists.txt
+@@ -21,7 +21,7 @@ if ( OpenMVG_BUILD_GUI_SOFTWARES )
+ endif( WIN32 )
+ endif( APPLE )
+
+- target_link_libraries( openMVG_main_AlternativeVO Qt5::Widgets openMVG_image openMVG_features stlplus )
++ target_link_libraries( openMVG_main_AlternativeVO Qt5::Widgets openMVG_image openMVG_features stlplus fast )
+
+ if ( OpenMVG_USE_OPENCV )
+ target_link_libraries( openMVG_main_AlternativeVO ${OpenCV_LIBS} )
+diff --git a/src/software/VO/CMakeLists.txt b/src/software/VO/CMakeLists.txt
+index ac5f0aea..ac715d7e 100644
+--- a/src/software/VO/CMakeLists.txt
++++ b/src/software/VO/CMakeLists.txt
+@@ -37,6 +37,7 @@ if (OpenMVG_BUILD_OPENGL_EXAMPLES)
+ target_link_libraries(openMVG_main_VO
+ ${OPENGL_gl_LIBRARY}
+ glfw
++ fast
+ ${GLFW_LIBRARIES}
+ ${OpenMVG_LIBRARIES}
+ )
diff --git a/flann.patch b/flann.patch
new file mode 100644
index 000000000000..529b190ecc2a
--- /dev/null
+++ b/flann.patch
@@ -0,0 +1,13 @@
+diff --git a/src/openMVG/matching/CMakeLists.txt b/src/openMVG/matching/CMakeLists.txt
+index 33cc6dd8..0d0660b8 100644
+--- a/src/openMVG/matching/CMakeLists.txt
++++ b/src/openMVG/matching/CMakeLists.txt
+@@ -39,7 +39,7 @@ target_link_libraries(openMVG_matching
+ if (NOT DEFINED OpenMVG_USE_INTERNAL_FLANN)
+ target_link_libraries(openMVG_matching
+ PUBLIC
+- ${FLANN_LIBRARIES}
++ ${PC_FLANN_LIBRARIES}
+ )
+ endif()
+ set_target_properties(openMVG_matching PROPERTIES SOVERSION ${OPENMVG_VERSION_MAJOR} VERSION "${OPENMVG_VERSION_MAJOR}.${OPENMVG_VERSION_MINOR}")
diff --git a/lemon.patch b/lemon.patch
new file mode 100644
index 000000000000..3336e3fef660
--- /dev/null
+++ b/lemon.patch
@@ -0,0 +1,13 @@
+diff --git a/src/software/colorHarmonize/CMakeLists.txt b/src/software/colorHarmonize/CMakeLists.txt
+index ceddd98c..10997693 100644
+--- a/src/software/colorHarmonize/CMakeLists.txt
++++ b/src/software/colorHarmonize/CMakeLists.txt
+@@ -2,7 +2,7 @@
+ add_executable(openMVG_main_ColHarmonize main_ColHarmonize.cpp
+ colorHarmonizeEngineGlobal.cpp)
+ target_link_libraries(openMVG_main_ColHarmonize
+- lemon
++ emon
+ openMVG_features
+ openMVG_image
+ openMVG_kvld
diff --git a/libopenMVG_sfm_link_error.patch b/libopenMVG_sfm_link_error.patch
deleted file mode 100644
index 16a3533393f6..000000000000
--- a/libopenMVG_sfm_link_error.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/openMVG/sfm/CMakeLists.txt b/src/openMVG/sfm/CMakeLists.txt
-index 8b02153..e91c80a 100644
---- a/src/openMVG/sfm/CMakeLists.txt
-+++ b/src/openMVG/sfm/CMakeLists.txt
-@@ -25,6 +25,7 @@ target_link_libraries(
- openMVG_lInftyComputerVision
- openMVG_system
- openMVG_matching
-+ openMVG_features
- )
- set_target_properties(openMVG_sfm PROPERTIES SOVERSION ${OPENMVG_VERSION_MAJOR} VERSION "${OPENMVG_VERSION_MAJOR}.${OPENMVG_VERSION_MINOR}")
-