summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee6eff18aa11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 4.2.1
+# Thu May 7 21:01:11 UTC 2015
+pkgbase = opennic-git
+ pkgdesc = opennic DNS service
+ pkgver = 20150507
+ pkgrel = 2
+ url = https://github.com/mar77i/opennic
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = curl
+ provides = opennic
+ conflicts = opennic
+ source = git://github.com/mar77i/opennic
+ sha1sums = SKIP
+
+pkgname = opennic-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cc6a24ee26c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: mar77i <mar77i at mar77i dot ch>
+pkgname="opennic-git"
+pkgver=20150507
+pkgrel=3
+pkgdesc="opennic DNS service"
+arch=(any)
+url="https://github.com/mar77i/opennic"
+license=(MIT)
+depends=(curl)
+makedepends=(git)
+provides=(opennic)
+conflicts=(opennic)
+source=("git://github.com/mar77i/opennic")
+sha1sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ :
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm755 opennic.sh "$pkgdir/usr/bin/opennic"
+ install -Dm644 "opennic.service" "$pkgdir/usr/lib/systemd/system/opennic.service"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: