summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile.patch19
-rwxr-xr-xPKGBUILD11
-rw-r--r--fetch-engine.patch12
4 files changed, 0 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 248c547e23d8..6dd29de55814 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -24,16 +24,10 @@ pkgbase = openra-gen-git
provides = openra-gen
options = !strip
source = git+https://github.com/MustaphaTR/Generals-Alpha.git
- source = local://GeoLite2-Country.mmdb.gz
- source = fetch-engine.patch
- source = Makefile.patch
source = openra-gen
source = openra-gen.appdata.xml
source = openra-gen.desktop
md5sums = SKIP
- md5sums = efb8c043dfa095146f373fec367aef64
- md5sums = 711019044fbb1c1e3aa5edc58b54343d
- md5sums = feae017ba5765215cd151a892362e6b1
md5sums = 8974b3935a56e8fd957ee5dc9404595c
md5sums = d3c7476b79a6b07522e597f05eaa8ae7
md5sums = 40267bdbbcde926b3524e99cce966592
diff --git a/Makefile.patch b/Makefile.patch
deleted file mode 100644
index 8a126fdbd5d8..000000000000
--- a/Makefile.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- Makefile 2020-02-11 10:18:32.479087754 +1000
-+++ Makefile 2020-02-11 10:19:53.128498490 +1000
-@@ -314,8 +314,7 @@
- @ $(CP_R) thirdparty/download/osx/*.dll.config .
-
- geoip-dependencies:
-- @./thirdparty/fetch-geoip-db.sh
-- @ $(CP) thirdparty/download/GeoLite2-Country.mmdb.gz .
-+ @$(CP) ../../GeoLite2-Country.mmdb.gz .
-
- dependencies: $(os-dependencies)
-
-@@ -512,4 +511,4 @@
-
- .SUFFIXES:
-
--.PHONY: core package all mods clean distclean dependencies version $(PROGRAMS) nunit
-+.PHONY: core package all mods clean distclean dependencies version $(PROGRAMS) nunit
-\ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index fd381f86773b..0db87f15a2bd 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,19 +15,10 @@ makedepends=('dos2unix' 'git' 'unzip')
provides=("${_pkgname}")
options=(!strip)
source=("git+${url}.git"
-# The following file needs to be downloaded manually from
-# Maxmind, see https://dev.maxmind.com/geoip/geoip2/geolite2/
-# for details
-"local://GeoLite2-Country.mmdb.gz"
-"fetch-engine.patch"
-"Makefile.patch"
"${_pkgname}"
"${_pkgname}.appdata.xml"
"${_pkgname}.desktop")
md5sums=('SKIP'
- 'efb8c043dfa095146f373fec367aef64'
- '711019044fbb1c1e3aa5edc58b54343d'
- 'feae017ba5765215cd151a892362e6b1'
'8974b3935a56e8fd957ee5dc9404595c'
'd3c7476b79a6b07522e597f05eaa8ae7'
'40267bdbbcde926b3524e99cce966592')
@@ -42,7 +33,6 @@ pkgver() {
prepare() {
cd $srcdir/Generals-Alpha
dos2unix *.md
- patch -Np1 -i $srcdir/fetch-engine.patch
}
build() {
@@ -57,7 +47,6 @@ package() {
cd $srcdir/Generals-Alpha
mkdir -p $pkgdir/usr/{lib/${_pkgname}/mods,bin,share/pixmaps,share/doc/packages/${_pkgname},share/applications,share/appdata}
install -dm775 $pkgdir/var/games/${_pkgname}
- cp $srcdir/GeoLite2-Country.mmdb.gz $pkgdir/usr/lib/${_pkgname}
cp -r generals-alpha-engine/{glsl,lua,AUTHORS,COPYING,*.dll*,'global mix database.dat',launch-dedicated.sh,launch-game.sh,*.exe,VERSION} $pkgdir/usr/lib/${_pkgname}
cp -r mods/gen $pkgdir/usr/lib/${_pkgname}/mods
cp -r generals-alpha-engine/mods/{common,modcontent} $pkgdir/usr/lib/${_pkgname}/mods
diff --git a/fetch-engine.patch b/fetch-engine.patch
deleted file mode 100644
index 4f192bc82c42..000000000000
--- a/fetch-engine.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/fetch-engine.sh b/fetch-engine.sh
-index 1eab9b4..b4dfc0e 100755
---- a/fetch-engine.sh
-+++ b/fetch-engine.sh
-@@ -72,6 +72,7 @@ if [ "${AUTOMATIC_ENGINE_MANAGEMENT}" = "True" ]; then
-
- echo "Compiling engine..."
- cd "${ENGINE_DIRECTORY}" || exit 1
-+ patch Makefile < ../../Makefile.patch
- make version VERSION="${ENGINE_VERSION}"
- exit 0
- fi \ No newline at end of file