summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--fails_and_fix.patch100
-rw-r--r--xpath.patch35
4 files changed, 10 insertions, 151 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4caaaa94ae9..3db3a32a943b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openscap
pkgdesc = Open Source Security Compliance Solution
- pkgver = 1.2.9
+ pkgver = 1.2.10
pkgrel = 1
url = www.open-scap.org
arch = x86_64
@@ -21,12 +21,8 @@ pkgbase = openscap
depends = perl
depends = perl-xml-parser
depends = perl-xml-xpath
- source = https://github.com/OpenSCAP/openscap/releases/download/1.2.9/openscap-1.2.9.tar.gz
- source = fails_and_fix.patch
- source = xpath.patch
- md5sums = 6a07b94d2d92dfec2818556ca117147a
- md5sums = 7882c8b0010db0920d1cabbd2aabcc07
- md5sums = 6dc765fcfba0e5c4ee277635d58584e2
+ source = https://github.com/OpenSCAP/openscap/releases/download/1.2.10/openscap-1.2.10.tar.gz
+ md5sums = e9a6c329d97dd687c1ec52070aabb4d0
pkgname = openscap
diff --git a/PKGBUILD b/PKGBUILD
index b52adb838cf6..c637f7633eaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Quey-Liang Kao <s101062801@m101.nthu.edu.tw>
pkgname=openscap
-pkgver=1.2.9
+pkgver=1.2.10
pkgrel=1
pkgdesc="Open Source Security Compliance Solution"
@@ -18,20 +18,18 @@ depends=('swig' 'python' 'acl' 'libcap' 'curl' 'libgcrypt' 'libxml2' 'libxslt'
'libldap' 'pcre' 'bzip2' 'procps-ng' 'gconf' 'perl' 'perl-xml-parser' 'perl-xml-xpath')
optdepends=()
-source=("https://github.com/OpenSCAP/openscap/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
- "fails_and_fix.patch"
- "xpath.patch")
-md5sums=('6a07b94d2d92dfec2818556ca117147a'
- '7882c8b0010db0920d1cabbd2aabcc07'
- '6dc765fcfba0e5c4ee277635d58584e2')
+source=("https://github.com/OpenSCAP/openscap/releases/download/$pkgver/$pkgname-$pkgver.tar.gz")
+md5sums=('e9a6c329d97dd687c1ec52070aabb4d0')
prepare() {
cd "$pkgname-$pkgver"
# This is for Red Hat/Fedora family, we don't need it.
sed -e "s/^.*default_cpe.*$/\\\/" -i $srcdir/$pkgname-$pkgver/tests/API/XCCDF/Makefile.am
- patch -f -p1 -i "$srcdir/fails_and_fix.patch"
- patch -f -p2 -i "$srcdir/xpath.patch"
+
+ # The upstream has fixed some of the issues, but more check needed
+ # patch -f -p1 -i "$srcdir/fails_and_fix.patch"
+ # patch -f -p2 -i "$srcdir/xpath.patch"
}
build() {
diff --git a/fails_and_fix.patch b/fails_and_fix.patch
deleted file mode 100644
index 17be9d8d32ff..000000000000
--- a/fails_and_fix.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-diff -aur openscap-1.2.8/tests/API/OVAL/unittests/all.sh openscap-1.2.8-patch/tests/API/OVAL/unittests/all.sh
---- openscap-1.2.8/tests/API/OVAL/unittests/all.sh 2016-01-18 17:22:49.094523797 +0800
-+++ openscap-1.2.8-patch/tests/API/OVAL/unittests/all.sh 2016-04-06 17:04:11.290429850 +0800
-@@ -11,7 +11,7 @@
- test_run "applicability_check element" $srcdir/test_applicability_check.sh
- test_run "count function" $srcdir/test_count_function.sh
- test_run "partial matches" $srcdir/test_item_not_exist.sh
--test_run "empty variable evaluation" $srcdir/test_oval_empty_variable_evaluation.sh
-+#test_run "empty variable evaluation" $srcdir/test_oval_empty_variable_evaluation.sh
- test_run "export of xsi:nil on pid entity of env.var.58_object" $srcdir/test_xsinil_envv58_pid.sh
- test_run "Import content without proper namespaces" $srcdir/test_xmlns_missing.sh
- test_run "int comparison - intmax_t" $srcdir/test_int_comparison.sh
-diff -aur openscap-1.2.8/tests/API/XCCDF/unittests/all.sh openscap-1.2.8-patch/tests/API/XCCDF/unittests/all.sh
---- openscap-1.2.8/tests/API/XCCDF/unittests/all.sh 2016-01-18 17:22:49.093523769 +0800
-+++ openscap-1.2.8-patch/tests/API/XCCDF/unittests/all.sh 2016-04-06 16:52:00.991482169 +0800
-@@ -80,10 +80,10 @@
- #
- # Tests for 'oscap xccdf remediate'
- #
--test_run "XCCDF Remediate" $srcdir/test_remediate_simple.sh
--test_run "XCCDF Remediate + python fix" $srcdir/test_remediate_python.sh
--test_run "XCCDF Remediate + python fix + xhtml:object" $srcdir/test_remediate_python_subs.sh
--test_run "XCCDF Remediate + perl fix" $srcdir/test_remediate_perl.sh
-+#test_run "XCCDF Remediate" $srcdir/test_remediate_simple.sh
-+#test_run "XCCDF Remediate + python fix" $srcdir/test_remediate_python.sh
-+#test_run "XCCDF Remediate + python fix + xhtml:object" $srcdir/test_remediate_python_subs.sh
-+#test_run "XCCDF Remediate + perl fix" $srcdir/test_remediate_perl.sh
-
- #
- # Tests for XCCDF report
-diff -aur openscap-1.2.8/tests/mitre/test_mitre.sh openscap-1.2.8-patch/tests/mitre/test_mitre.sh
---- openscap-1.2.8/tests/mitre/test_mitre.sh 2016-01-18 17:18:42.303429988 +0800
-+++ openscap-1.2.8-patch/tests/mitre/test_mitre.sh 2016-04-06 16:52:50.136542323 +0800
-@@ -97,16 +97,16 @@
- #test_run "unix-def_file_test.xml" test_mitre unix-def_file_test.xml "true"
-
- test_run "linux-def_partition_test.xml" test_mitre linux-def_partition_test.xml "true"
--test_run "linux-def_rpminfo_test.xml" test_mitre linux-def_rpminfo_test.xml "true"
--test_run "linux-def_rpmverify_test.xml" test_mitre linux-def_rpmverify_test.xml "true"
-+#test_run "linux-def_rpminfo_test.xml" test_mitre linux-def_rpminfo_test.xml "true"
-+#test_run "linux-def_rpmverify_test.xml" test_mitre linux-def_rpmverify_test.xml "true"
- # Fedora 18 and RHEL-7 - no allow_console_login
- if [[ ( ${DISTRO#Fedora} != "$DISTRO" && $DISTRO_RELEASE -lt 18 ) || \
- ( ${DISTRO#Red Hat} != "$DISTRO" && $DISTRO_RELEASE -lt 7 ) ]]; then
- test_run "linux-def_selinuxboolean_test.xml" test_mitre linux-def_selinuxboolean_test.xml "true"
- fi
-
--test_run "linux-def_selinuxsecuritycontext_test.xml" test_mitre linux-def_selinuxsecuritycontext_test.xml "true"
--test_run "linux-def_inetlisteningservers_test.xml" test_mitre linux-def_inetlisteningservers_test.xml "true"
-+#test_run "linux-def_selinuxsecuritycontext_test.xml" test_mitre linux-def_selinuxsecuritycontext_test.xml "true"
-+#test_run "linux-def_inetlisteningservers_test.xml" test_mitre linux-def_inetlisteningservers_test.xml "true"
-
- test_run "oval_binary_datatype.xml" test_mitre oval_binary_datatype.xml "true"
- test_run "oval_boolean_datatype.xml" test_mitre oval_boolean_datatype.xml "true"
---- openscap-1.2.8/tests/probes/Makefile.am 2016-01-18 17:18:42.304430017 +0800
-+++ openscap-1.2.8-patch/tests/probes/Makefile.am 2016-04-06 16:35:21.606042932 +0800
-@@ -29,9 +29,9 @@
- if probe_file_enabled
- UNIX_SUBDIRS += file
- endif
--if probe_uname_enabled
--UNIX_SUBDIRS += uname
--endif
-+#if probe_uname_enabled
-+#UNIX_SUBDIRS += uname
-+#endif
- if probe_shadow_enabled
- UNIX_SUBDIRS += shadow
- endif
-@@ -77,12 +77,12 @@
- if probe_selinuxboolean_enabled
- LINUX_SUBDIRS += selinuxboolean
- endif
--if probe_systemdunitproperty_enabled
--LINUX_SUBDIRS += systemdunitproperty
--endif
--if probe_systemdunitdependency_enabled
--LINUX_SUBDIRS += systemdunitdependency
--endif
-+#if probe_systemdunitproperty_enabled
-+#LINUX_SUBDIRS += systemdunitproperty
-+#endif
-+#if probe_systemdunitdependency_enabled
-+#LINUX_SUBDIRS += systemdunitdependency
-+#endif
- endif
-
- if WANT_PROBES_SOLARIS
---- openscap-1.2.8/tests/test_common.sh.in 2016-04-06 17:10:12.439743753 +0800
-+++ openscap-1.2.8-patch/tests/test_common.sh.in 2016-04-06 17:03:00.834628286 +0800
-@@ -67,7 +64,8 @@
- echo -e "RESULT: SKIPPED\n" >&2
- return 0;
- else
-- result=$[$result + $ret_val]
-+# It's quite weird that a warning halts the whole tests.
-+# result=$[$result + $ret_val]
- echo "[ WARN ]";
- echo -e "RESULT: WARNING (unknown exist status $ret_val)\n" >&2
- return 1;
diff --git a/xpath.patch b/xpath.patch
deleted file mode 100644
index 6c57b93c6429..000000000000
--- a/xpath.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff -aur src/openscap-1.2.8/tests/test_common.sh.in src/openscap-1.2.8-patch/tests/test_common.sh.in
---- src/openscap-1.2.8/tests/test_common.sh.in 2016-01-18 10:18:42.000000000 +0100
-+++ src/openscap-1.2.8-patch/tests/test_common.sh.in 2016-04-13 22:15:31.866559193 +0200
-@@ -26,11 +26,7 @@
-
- export XMLDIFF="@abs_top_srcdir@/tests/xmldiff.pl"
-
--if ! XPATH=`command -v xpath 2>&1`; then
-- echo "I require xpath tool but it's not installed. Aborting." >&2
-- exit 1
--fi
--export XPATH
-+export XPATH=xpath_wrapper
-
- # Overall test result.
- result=0
-@@ -163,3 +160,18 @@
- fi
- }
- export -f assert_exists
-+
-+xpath_wrapper() {
-+XPATH_BIN="/usr/bin/vendor_perl/xpath"
-+if [ "$#" -eq 1 ];
-+then
-+ # read file from stdin
-+ xpath_expr="$1"
-+ $XPATH_BIN -e "$xpath_expr"
-+else
-+ file="$1"
-+ xpath_expr="$2"
-+ $XPATH_BIN -e "$xpath_expr" "$file"
-+fi
-+}
-+export -f xpath_wrapper