summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD49
-rw-r--r--ffmpeg.patch39
-rw-r--r--findffmpeg.patch42
-rw-r--r--findgdal.patch25
-rw-r--r--findgiflib.patch25
-rw-r--r--video_out_rgb.patch16
7 files changed, 237 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..606d668093d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+# Generated by mksrcinfo v8
+# Sat Jan 9 21:33:05 UTC 2016
+pkgbase = openscenegraph-2.8
+ pkgdesc = An Open Source, high performance real-time graphics toolkit
+ pkgver = 2.8.5
+ pkgrel = 2
+ url = http://www.openscenegraph.org
+ arch = i686
+ arch = x86_64
+ license = custom:OSGPL
+ makedepends = cmake
+ makedepends = libvncserver
+ depends = giflib
+ depends = jasper
+ depends = librsvg
+ depends = xine-lib
+ depends = curl
+ depends = pth
+ optdepends = libvncserver
+ optdepends = gdal
+ optdepends = openexr
+ optdepends = poppler-glib
+ provides = openthreads
+ provides = openscenegraph=2.8.5
+ conflicts = openthreads
+ conflicts = openscenegraph
+ source = http://www.openscenegraph.org/downloads/stable_releases/OpenSceneGraph-2.8.5/source/OpenSceneGraph-2.8.5.zip
+ source = ffmpeg.patch
+ source = findffmpeg.patch
+ source = findgdal.patch
+ source = findgiflib.patch
+ source = video_out_rgb.patch
+ md5sums = SKIP
+ md5sums = 65790bc6dbdedecf6bd3ee01ad22212a
+ md5sums = a6cce978f18522176247e4ac5e72e3b0
+ md5sums = 9301eebbac03c56bab82e571a47b15d2
+ md5sums = 445cb50fd391b31beca4a95fa7a7ffcc
+ md5sums = 97a3a602f45a3869e5f2e19781dd6934
+
+pkgname = openscenegraph-2.8
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..984260297601
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+# Contributor: Jakub Luzny <limoto94@gmail.com>
+pkgname=openscenegraph-2.8
+pkgver=2.8.5
+pkgrel=2
+pkgdesc="An Open Source, high performance real-time graphics toolkit"
+arch=('i686' 'x86_64')
+license=('custom:OSGPL')
+url="http://www.openscenegraph.org"
+depends=('giflib' 'jasper' 'librsvg' 'xine-lib' 'curl' 'pth')
+makedepends=('cmake' 'libvncserver')
+optdepends=('libvncserver' 'gdal' 'openexr' 'poppler-glib')
+conflicts=('openthreads' 'openscenegraph')
+provides=('openthreads' "openscenegraph=$pkgver")
+source=(http://www.openscenegraph.org/downloads/stable_releases/OpenSceneGraph-$pkgver/source/OpenSceneGraph-$pkgver.zip
+ ffmpeg.patch findffmpeg.patch findgdal.patch findgiflib.patch video_out_rgb.patch)
+md5sums=('SKIP'
+ '65790bc6dbdedecf6bd3ee01ad22212a'
+ 'a6cce978f18522176247e4ac5e72e3b0'
+ '9301eebbac03c56bab82e571a47b15d2'
+ '445cb50fd391b31beca4a95fa7a7ffcc'
+ '97a3a602f45a3869e5f2e19781dd6934')
+
+
+build() {
+ cd OpenSceneGraph-$pkgver
+
+ patch -Np1 -i "$srcdir/ffmpeg.patch"
+ cd CMakeModules
+ patch -Np0 -i "$srcdir/findffmpeg.patch"
+ patch -Np0 -i "$srcdir/findgdal.patch"
+ patch -Np0 -i "$srcdir/findgiflib.patch"
+ cd ${srcdir}/OpenSceneGraph-${pkgver}/src/osgPlugins/xine
+ patch -Np0 -i "$srcdir/video_out_rgb.patch"
+ cd ${srcdir}/OpenSceneGraph-${pkgver}
+
+ [ $NOEXTRACT -eq 1 ] || cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ sed -i 's|#include <curl/types.h>|//#include <curl/types.h>|' src/osgPlugins/curl/ReaderWriterCURL.cpp
+ make
+}
+
+package() {
+ cd OpenSceneGraph-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ [ -d "$pkgdir/usr/lib64" ] && mv "$pkgdir/usr/lib64" "$pkgdir/usr/lib" || true
+}
+
+#category: lib
diff --git a/ffmpeg.patch b/ffmpeg.patch
new file mode 100644
index 000000000000..9ec8774e77d3
--- /dev/null
+++ b/ffmpeg.patch
@@ -0,0 +1,39 @@
+--- OpenSceneGraph-2.8.5/src/osgPlugins/ffmpeg/FFmpegDecoder.cpp 2010-03-19 16:56:12.000000000 +0100
++++ OpenSceneGraph-2.8.5-new/src/osgPlugins/ffmpeg/FFmpegDecoder.cpp 2011-11-22 18:01:13.000000000 +0100
+@@ -84,13 +84,12 @@
+ switch (error)
+ {
+ //case AVERROR_UNKNOWN: error_str = "AVERROR_UNKNOWN"; break; // same value as AVERROR_INVALIDDATA
+- case AVERROR_IO: error_str = "AVERROR_IO"; break;
+- case AVERROR_NUMEXPECTED: error_str = "AVERROR_NUMEXPECTED"; break;
++ case AVERROR(EIO): error_str = "AVERROR_IO"; break;
++ case AVERROR(EINVAL): error_str = "AVERROR_NUMEXPECTED"; break;
+ case AVERROR_INVALIDDATA: error_str = "AVERROR_INVALIDDATA"; break;
+- case AVERROR_NOMEM: error_str = "AVERROR_NOMEM"; break;
+- case AVERROR_NOFMT: error_str = "AVERROR_NOFMT"; break;
+- case AVERROR_NOTSUPP: error_str = "AVERROR_NOTSUPP"; break;
+- case AVERROR_NOENT: error_str = "AVERROR_NOENT"; break;
++ case AVERROR(ENOMEM): error_str = "AVERROR_NOMEM"; break;
++ case AVERROR(ENOSYS): error_str = "AVERROR_NOTSUPP"; break;
++ case AVERROR(ENOENT): error_str = "AVERROR_NOENT"; break;
+ case AVERROR_PATCHWELCOME: error_str = "AVERROR_PATCHWELCOME"; break;
+ default: error_str = "Unknown error"; break;
+ }
+@@ -217,7 +216,7 @@
+ {
+ for (unsigned int i = 0; i < m_format_context->nb_streams; ++i)
+ {
+- if (m_format_context->streams[i]->codec->codec_type == CODEC_TYPE_AUDIO)
++ if (m_format_context->streams[i]->codec->codec_type == AVMEDIA_TYPE_AUDIO)
+ {
+ m_audio_stream = m_format_context->streams[i];
+ m_audio_index = i;
+@@ -235,7 +234,7 @@
+ {
+ for (unsigned int i = 0; i < m_format_context->nb_streams; ++i)
+ {
+- if (m_format_context->streams[i]->codec->codec_type == CODEC_TYPE_VIDEO)
++ if (m_format_context->streams[i]->codec->codec_type == AVMEDIA_TYPE_VIDEO)
+ {
+ m_video_stream = m_format_context->streams[i];
+ m_video_index = i;
diff --git a/findffmpeg.patch b/findffmpeg.patch
new file mode 100644
index 000000000000..25473793f222
--- /dev/null
+++ b/findffmpeg.patch
@@ -0,0 +1,42 @@
+--- FindFFmpeg.cmake.orig 2010-03-19 16:56:12.000000000 +0100
++++ FindFFmpeg.cmake 2016-01-03 13:51:28.000000000 +0100
+@@ -29,6 +29,7 @@
+
+ FIND_PATH(FFMPEG_${varname}_INCLUDE_DIRS lib${shortname}/${headername}
+ PATHS
++ /usr/include/ffmpeg-compat
+ ${FFMPEG_ROOT}/include
+ $ENV{FFMPEG_DIR}/include
+ ~/Library/Frameworks
+@@ -40,12 +41,13 @@
+ /opt/csw/include # Blastwave
+ /opt/include
+ /usr/freeware/include
+- PATH_SUFFIXES ffmpeg
++ PATH_SUFFIXES ffmpeg-compat
+ DOC "Location of FFMPEG Headers"
+ )
+
+ FIND_PATH(FFMPEG_${varname}_INCLUDE_DIRS ${headername}
+ PATHS
++ /usr/include/ffmpeg-compat
+ ${FFMPEG_ROOT}/include
+ $ENV{FFMPEG_DIR}/include
+ ~/Library/Frameworks
+@@ -57,13 +59,15 @@
+ /opt/csw/include # Blastwave
+ /opt/include
+ /usr/freeware/include
+- PATH_SUFFIXES ffmpeg
++ PATH_SUFFIXES ffmpeg-compat
+ DOC "Location of FFMPEG Headers"
+ )
+
+ FIND_LIBRARY(FFMPEG_${varname}_LIBRARIES
+ NAMES ${shortname}
++ NO_DEFAULT_PATH
+ PATHS
++ /usr/lib/ffmpeg-compat
+ ${FFMPEG_ROOT}/lib
+ $ENV{FFMPEG_DIR}/lib
+ ~/Library/Frameworks
diff --git a/findgdal.patch b/findgdal.patch
new file mode 100644
index 000000000000..e503633cefd4
--- /dev/null
+++ b/findgdal.patch
@@ -0,0 +1,25 @@
+--- FindGDAL.cmake.orig 2008-11-26 13:07:03.000000000 +0100
++++ FindGDAL.cmake 2016-01-03 12:33:31.000000000 +0100
+@@ -28,6 +28,7 @@
+
+ FIND_PATH(GDAL_INCLUDE_DIR gdal.h
+ PATHS ${CMAKE_PREFIX_PATH} # Unofficial: We are proposing this.
++ /usr/include/gdal1
+ NO_DEFAULT_PATH
+ PATH_SUFFIXES include
+ )
+@@ -66,12 +67,14 @@
+ FIND_LIBRARY(GDAL_LIBRARY
+ NAMES gdal gdal_i gdal1.5.0 gdal1.4.0 gdal1.3.2 GDAL
+ PATHS ${CMAKE_PREFIX_PATH} # Unofficial: We are proposing this.
++ /usr/lib/gdal1
+ NO_DEFAULT_PATH
+ PATH_SUFFIXES lib64 lib
+ )
+ FIND_LIBRARY(GDAL_LIBRARY
+ NAMES gdal gdal_i gdal1.5.0 gdal1.4.0 gdal1.3.2 GDAL
+ PATHS
++ /usr/lib/gdal1
+ ~/Library/Frameworks
+ /Library/Frameworks
+ /usr/local
diff --git a/findgiflib.patch b/findgiflib.patch
new file mode 100644
index 000000000000..0d1731a764d8
--- /dev/null
+++ b/findgiflib.patch
@@ -0,0 +1,25 @@
+--- FindGIFLIB.cmake.orig 2008-01-04 21:00:18.000000000 +0100
++++ FindGIFLIB.cmake 2016-01-02 23:49:16.000000000 +0100
+@@ -17,12 +17,14 @@
+
+ FIND_PATH(GIFLIB_INCLUDE_DIR gif_lib.h
+ PATHS ${CMAKE_PREFIX_PATH} # Unofficial: We are proposing this.
++ /usr/include/giflib4
+ NO_DEFAULT_PATH
+ PATH_SUFFIXES include
+ )
+
+ FIND_PATH(GIFLIB_INCLUDE_DIR gif_lib.h
+ PATHS
++ /usr/include/giflib4
+ ~/Library/Frameworks
+ /Library/Frameworks
+ /usr/local/include
+@@ -38,6 +40,7 @@
+ FIND_LIBRARY(GIFLIB_LIBRARY
+ NAMES gif ungif libgif libungif
+ PATHS
++ /usr/lib/giflib4
+ $ENV{GIFLIB_DIR}
+ NO_DEFAULT_PATH
+ PATH_SUFFIXES lib64 lib
diff --git a/video_out_rgb.patch b/video_out_rgb.patch
new file mode 100644
index 000000000000..56be51a780a7
--- /dev/null
+++ b/video_out_rgb.patch
@@ -0,0 +1,16 @@
+--- video_out_rgb.c.orig 2016-01-03 13:56:19.000000000 +0100
++++ video_out_rgb.c 2016-01-03 12:54:03.093352299 +0100
+@@ -2767,8 +2767,13 @@
+ clear(rgb_class, sizeof(rgbout_class_t));
+
+ rgb_class->driver_class.open_plugin = open_plugin;
++ #if XINE_MAJOR_VERSION < 1 || (XINE_MAJOR_VERSION == 1 && XINE_MINOR_VERSION < 2)
+ rgb_class->driver_class.get_identifier = get_identifier;
+ rgb_class->driver_class.get_description = get_description;
++ #else
++ rgb_class->driver_class.identifier = get_identifier(NULL);
++ rgb_class->driver_class.description = get_description(NULL);
++ #endif
+ rgb_class->driver_class.dispose = dispose_class;
+
+ return(rgb_class);