summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b59f289bedc..7b2c40011770 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = opensmtpd-filter-replace-from_reply
pkgdesc = This is a simple OpenSMTPD filter for overwriting the email address in the MAIL FROM command, in the header in all sent messages, as well as for substituting the original MAIL FROM address in the Reply-To field
- pkgver = 1.0.2
+ pkgver = 1.0.3
pkgrel = 1
arch = i686
arch = x86_64
license = MIT
makedepends = go
depends = glibc
- source = https://github.com/Genues/opensmtpd-filter-replace-from_reply/archive/main.zip
- sha512sums = SKIP
+ source = https://github.com/Genues/opensmtpd-filter-replace-from_reply/archive/1.0.3.zip
+ md5sums = d4ca82486a20fbbc319bd2379e25e68b
pkgname = opensmtpd-filter-replace-from_reply
diff --git a/PKGBUILD b/PKGBUILD
index f13c3ecb190d..664789753666 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Evgeniy <genues@gmail.com>
pkgname=opensmtpd-filter-replace-from_reply
-pkgver=1.0.2
+pkgver=1.0.3
pkgrel=1
pkgdesc='This is a simple OpenSMTPD filter for overwriting the email address in the MAIL FROM command, in the header in all sent messages, as well as for substituting the original MAIL FROM address in the Reply-To field'
license=("MIT")
arch=(i686 x86_64)
depends=(glibc)
makedepends=(go)
-source=('https://github.com/Genues/opensmtpd-filter-replace-from_reply/archive/main.zip')
-sha512sums=('SKIP')
+source=("https://github.com/Genues/opensmtpd-filter-replace-from_reply/archive/$pkgver.zip")
+md5sums=('d4ca82486a20fbbc319bd2379e25e68b')
build() {
-cd "$pkgname"-main
+cd "$pkgname-$pkgver"
go build -buildmode pie -ldflags "-extldflags $LDFLAGS" -trimpath "$pkgname.go"
}
package() {
-cd "$pkgname"-main
+cd "$pkgname-$pkgver"
install -D "$pkgname" -t "$pkgdir"/usr/lib/smtpd/opensmtpd
install -Dm644 README.md -t "$pkgdir"/usr/share/doc/$pkgname