summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d4f72bc2d8d..5ccc40d27fa1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Apr 15 15:28:34 UTC 2017
+# Sat Jun 10 06:32:38 UTC 2017
pkgbase = openssh-hpn-git
pkgdesc = A Secure SHell server/client fork with High Performance patches included
pkgver = 7.5.P1.r71.gecb50afb
- pkgrel = 1
+ pkgrel = 2
url = http://www.psc.edu/networking/projects/hpn-ssh/
install = openssh-hpn-git.install
arch = i686
@@ -14,7 +14,7 @@ pkgbase = openssh-hpn-git
depends = krb5
depends = ldns
depends = libedit
- depends = openssl
+ depends = openssl-1.0
depends = pam
optdepends = xorg-xauth: X11 forwarding
optdepends = x11-ssh-askpass: input passphrase in X
diff --git a/PKGBUILD b/PKGBUILD
index d3baafb903f1..49176fc333a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,12 +38,12 @@
pkgname=openssh-hpn-git
pkgver=7.5.P1.r71.gecb50afb
-pkgrel=1
+pkgrel=2
pkgdesc='A Secure SHell server/client fork with High Performance patches included'
url='http://www.psc.edu/networking/projects/hpn-ssh/'
license=('custom:BSD')
arch=('i686' 'x86_64' 'armv7h')
-depends=('krb5' 'ldns' 'libedit' 'openssl' 'pam')
+depends=('krb5' 'ldns' 'libedit' 'openssl-1.0' 'pam')
makedepends=('git')
optdepends=('xorg-xauth: X11 forwarding'
'x11-ssh-askpass: input passphrase in X')
@@ -72,6 +72,22 @@ sha256sums=('SKIP'
install=$pkgname.install
+prepare() {
+
+ if ! [ -e openssl-1.0 ] ; then
+ mkdir openssl-1.0
+ fi
+
+ if ! [ -e openssl-1.0/include ] ; then
+ ln -s /usr/include/openssl-1.0 openssl-1.0/include
+ fi
+
+ if ! [ -e openssl-1.0/lib ] ; then
+ ln -s /usr/lib/openssl-1.0 openssl-1.0/lib
+ fi
+
+}
+
pkgver() {
cd openssh-portable/
@@ -106,6 +122,7 @@ build() {
--with-mantype=man \
--with-md5-passwords \
--with-pid-dir=/run \
+ --with-ssl-dir=../openssl-1.0 \
make
}