summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rwxr-xr-xPKGBUILD43
-rwxr-xr-xpatch_desktop.patch13
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7bd46c11a3dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = openstudio
+ pkgdesc = Supports whole building energy modeling using EnergyPlus
+ pkgver = 1.7
+ pkgrel = 0
+ url = https://www.openstudio.net
+ arch = x86_64
+ license = LGPL
+ depends = ruby
+ source = https://openstudio-builds.s3.amazonaws.com/1.7.0/OpenStudio-1.7.0.c5bad04b2c-Linux.deb
+ source = patch_desktop.patch
+ md5sums = 1827d5f76e01c624348cb2419cc780dd
+ md5sums = 7851218f71a0c2a67b1fd4d7c8ef46cd
+
+pkgname = openstudio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..1b66eb7f50ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: xpt <user.xpt@gmail.com>
+pkgname=openstudio
+pkgver=1.7
+pkgrel=0
+pkgdesc="Supports whole building energy modeling using EnergyPlus"
+arch=('x86_64')
+url="https://www.openstudio.net"
+depends=('ruby')
+# optdep=('energyplus')
+license=('LGPL')
+source=("https://openstudio-builds.s3.amazonaws.com/$pkgver.$pkgrel/OpenStudio-$pkgver.$pkgrel.c5bad04b2c-Linux.deb" 'patch_desktop.patch')
+md5sums=('1827d5f76e01c624348cb2419cc780dd' '7851218f71a0c2a67b1fd4d7c8ef46cd')
+
+package() {
+cd "${srcdir}/"
+tar Jxvf data.tar.xz -C .
+cp -r usr ${pkgdir}
+
+# install -d $pkgdir/usr/share
+# cp -r $srcdir/$pkgname $pkgdir/usr/share/
+# cd $pkgdir/usr/share/$pkgname/
+# install -Dm755 ./scripts/$pkgname $pkgdir/usr/bin/$pkgname
+# install -Dm755 ./scripts/fehwrap $pkgdir/usr/bin/fehwrap
+# install -Dm644 ./library/config/readme_etc_$pkgname \
+# $pkgdir/etc/$pkgname/readme_etc_$pkgname
+# install -Dm644 ./library/manpage/$pkgname.1.gz \
+# $pkgdir/usr/share/man/man1/$pkgname.1.gz
+
+patch -uNp1 ${pkgdir}/usr/share/applications/OpenStudio.desktop ${srcdir}/patch_desktop.patch
+
+# diff -Naur OpenStudio0.desktop OpenStudio.desktop >patch_desktop.patch
+# Exec=LD_LIBRARY_PATH=/usr/local/lib/links:$LD_LIBRARY_PATH /usr/local/bin/OpenStudio %f
+
+#chmod 755 ${srcdir}/usr/local/lib/links
+}
+#libruby-2.0.so.2.0
+#libboost_filesystem.so.1.55.0
+#libboost_regex.so.1.55.0
+#libboost_program_options.so.1.55.0
+#libboost_system.so.1.55.0
+#libboost_thread.so.1.55.0
+#libboost_date_time.so.1.55.0
+#libboost_log.so.1.55.0 \ No newline at end of file
diff --git a/patch_desktop.patch b/patch_desktop.patch
new file mode 100755
index 000000000000..ef44d00482bb
--- /dev/null
+++ b/patch_desktop.patch
@@ -0,0 +1,13 @@
+--- OpenStudio.desktop 2015-05-07 02:53:05.000000000 -0300
++++ OpenStudio2.desktop 2015-05-07 03:19:13.460308587 -0300
+@@ -1,8 +1,8 @@
+ [Desktop Entry]
+-Version=1.0
++Version=1.7
+ Name=OpenStudio
+ Comment=Supports whole building energy modeling using EnergyPlus
+-Exec=LD_LIBRARY_PATH= /usr/local/share/openstudio-1.7.0/lib/:$LD_LIBRARY_PATH /usr/local/bin/OpenStudio %f
++Exec=Exec=LD_LIBRARY_PATH= /usr/local/share/openstudio-1.7.0/lib/:$LD_LIBRARY_PATH /usr/local/bin/OpenStudio %f
+ Terminal=false
+ Type=Application
+ Icon=OpenStudio