summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--010-ade-disable-werror.patch11
-rw-r--r--010-openvino-disable-werror.patch (renamed from 015-openvino-disable-werror.patch)2
-rw-r--r--020-openvino-use-protobuf-shared-libs.patch2
-rw-r--r--PKGBUILD43
5 files changed, 32 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca2f4ebf829b..c150985bdd29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openvino
pkgdesc = A toolkit for developing artificial inteligence and deep learning applications
- pkgver = 2023.3.0
- pkgrel = 2
+ pkgver = 2024.1.0
+ pkgrel = 3
url = https://docs.openvinotoolkit.org/
arch = x86_64
license = Apache-2.0
@@ -23,6 +23,7 @@ pkgbase = openvino
depends = onetbb
optdepends = intel-compute-runtime: for Intel GPU plugin
optdepends = ocl-icd: for Intel GPU plugin
+ optdepends = level-zero-loader: for Intel NPU plugin
optdepends = snappy: for tensorflow frontend
optdepends = protobuf: for tensorflow, paddle and onnx frontends
optdepends = python: for Python API
@@ -32,13 +33,11 @@ pkgbase = openvino
conflicts = intel-openvino
replaces = intel-openvino
options = !emptydirs
- source = git+https://github.com/openvinotoolkit/openvino.git#tag=2023.3.0
- source = https://storage.openvinotoolkit.org/dependencies/gna/gna_03.05.00.2116.zip
+ source = git+https://github.com/openvinotoolkit/openvino.git#tag=2024.1.0
source = oneDNN-openvinotoolkit::git+https://github.com/openvinotoolkit/oneDNN.git
source = git+https://github.com/herumi/xbyak.git
source = git+https://github.com/madler/zlib.git
source = git+https://github.com/zeux/pugixml.git
- source = git+https://github.com/opencv/ade.git
source = git+https://github.com/gflags/gflags.git
source = googletest-openvinotoolkit::git+https://github.com/openvinotoolkit/googletest.git
source = git+https://github.com/KhronosGroup/OpenCL-ICD-Loader.git
@@ -56,13 +55,16 @@ pkgbase = openvino
source = git+https://github.com/google/snappy.git
source = git+https://github.com/ARM-software/ComputeLibrary.git
source = git+https://github.com/openvinotoolkit/mlas.git
+ source = git+https://github.com/oneapi-src/level-zero.git
+ source = git+https://github.com/intel/level-zero-npu-extensions.git
+ source = git+https://github.com/openvinotoolkit/telemetry.git
source = openvino.conf
source = setupvars.sh
- source = 010-ade-disable-werror.patch
- source = 015-openvino-disable-werror.patch
+ source = 010-openvino-disable-werror.patch
source = 020-openvino-use-protobuf-shared-libs.patch
+ sha256sums = edf2a719de99981396784da9e42483a16c8a2e24453780693cc69d452b4b45b3
+ sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 960350567702bda17276ac4c060d7524fb7ce7ced785004bd861c81ff2bfe2c5
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -87,8 +89,7 @@ pkgbase = openvino
sha256sums = SKIP
sha256sums = 335a55533ab26bd1f63683921baf33b8e8e3f2732a94554916d202ee500f90af
sha256sums = e5024ad3382f285fe63dc58faca379f11a669bbe9f5d90682c59ad588aab434c
- sha256sums = 502fcbb3fcbb66aa5149ad2cc5f1fa297b51ed12c5c9396a16b5795a03860ed0
- sha256sums = 1b420e3cc2afca11154c672123f001cf03cd2b96be3baafd229f6ee7d752419e
- sha256sums = 9e0f517320c4351489db5840658ffcf537716b23e88a02ee69380734a40ced21
+ sha256sums = 0bbf46bef304dea08b318d1ffd564735b19e1afb6c0f41c98d216824cc630132
+ sha256sums = 2329bb09c80ce44ae622da9d318d246b237e3a4d259d12f6b8920a249ec994bb
pkgname = openvino
diff --git a/010-ade-disable-werror.patch b/010-ade-disable-werror.patch
deleted file mode 100644
index bc242009c94c..000000000000
--- a/010-ade-disable-werror.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/sources/ade/CMakeLists.txt
-+++ b/sources/ade/CMakeLists.txt
-@@ -11,7 +11,7 @@ file( GLOB_RECURSE sources source/*.cpp )
- file( GLOB_RECURSE include *.hpp )
-
- if (CMAKE_CXX_COMPILER_ID STREQUAL GNU)
-- set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Wall -Wextra -Wconversion -Wshadow -Wno-error=cpp -Wformat -Wformat-security" )
-+ set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wconversion -Wshadow -Wno-error=cpp -Wformat -Wformat-security" )
- endif()
-
- add_library( ${PROJECT_NAME} STATIC ${include} ${sources} )
diff --git a/015-openvino-disable-werror.patch b/010-openvino-disable-werror.patch
index d62e0e81b504..2a168ec344d8 100644
--- a/015-openvino-disable-werror.patch
+++ b/010-openvino-disable-werror.patch
@@ -1,6 +1,6 @@
--- a/src/plugins/intel_gpu/CMakeLists.txt
+++ b/src/plugins/intel_gpu/CMakeLists.txt
-@@ -37,10 +37,6 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include")
+@@ -46,10 +46,6 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include")
add_subdirectory(thirdparty)
include(thirdparty/cmake/rapidjson.cmake)
diff --git a/020-openvino-use-protobuf-shared-libs.patch b/020-openvino-use-protobuf-shared-libs.patch
index 6ab7c08d8daf..b72bd88db4ff 100644
--- a/020-openvino-use-protobuf-shared-libs.patch
+++ b/020-openvino-use-protobuf-shared-libs.patch
@@ -1,6 +1,6 @@
--- a/thirdparty/dependencies.cmake
+++ b/thirdparty/dependencies.cmake
-@@ -347,7 +347,7 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND
+@@ -318,7 +318,7 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND
# Note: Debian / Ubuntu / RHEL libprotobuf.a can only be used with -DBUILD_SHARED_LIBS=OFF
# because they are compiled without -fPIC
if(NOT DEFINED Protobuf_USE_STATIC_LIBS)
diff --git a/PKGBUILD b/PKGBUILD
index 61a4fdaa635b..9f3b1b55cd40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# https://github.com/openvinotoolkit/openvino/issues/452#issuecomment-722941119
pkgname=openvino
-pkgver=2023.3.0
-pkgrel=2
+pkgver=2024.1.0
+pkgrel=3
pkgdesc='A toolkit for developing artificial inteligence and deep learning applications'
arch=('x86_64')
url='https://docs.openvinotoolkit.org/'
@@ -13,6 +13,7 @@ license=('Apache-2.0')
depends=('pugixml' 'onetbb')
optdepends=('intel-compute-runtime: for Intel GPU plugin'
'ocl-icd: for Intel GPU plugin'
+ 'level-zero-loader: for Intel NPU plugin'
'snappy: for tensorflow frontend'
'protobuf: for tensorflow, paddle and onnx frontends'
'python: for Python API'
@@ -25,14 +26,11 @@ provides=('intel-openvino')
conflicts=('intel-openvino')
replaces=('intel-openvino')
options=('!emptydirs')
-_gnaver=03.05.00.2116 # GNA_VERSION in cmake/dependencies.cmake
source=("git+https://github.com/openvinotoolkit/openvino.git#tag=${pkgver}"
- "https://storage.openvinotoolkit.org/dependencies/gna/gna_${_gnaver}.zip"
'oneDNN-openvinotoolkit'::'git+https://github.com/openvinotoolkit/oneDNN.git'
'git+https://github.com/herumi/xbyak.git'
'git+https://github.com/madler/zlib.git'
'git+https://github.com/zeux/pugixml.git'
- 'git+https://github.com/opencv/ade.git'
'git+https://github.com/gflags/gflags.git'
'googletest-openvinotoolkit'::'git+https://github.com/openvinotoolkit/googletest.git'
'git+https://github.com/KhronosGroup/OpenCL-ICD-Loader.git'
@@ -50,13 +48,16 @@ source=("git+https://github.com/openvinotoolkit/openvino.git#tag=${pkgver}"
'git+https://github.com/google/snappy.git'
'git+https://github.com/ARM-software/ComputeLibrary.git'
'git+https://github.com/openvinotoolkit/mlas.git'
+ 'git+https://github.com/oneapi-src/level-zero.git'
+ 'git+https://github.com/intel/level-zero-npu-extensions.git'
+ 'git+https://github.com/openvinotoolkit/telemetry.git'
'openvino.conf'
'setupvars.sh'
- '010-ade-disable-werror.patch'
- '015-openvino-disable-werror.patch'
+ '010-openvino-disable-werror.patch'
'020-openvino-use-protobuf-shared-libs.patch')
-sha256sums=('SKIP'
- '960350567702bda17276ac4c060d7524fb7ce7ced785004bd861c81ff2bfe2c5'
+sha256sums=('edf2a719de99981396784da9e42483a16c8a2e24453780693cc69d452b4b45b3'
+ 'SKIP'
+ 'SKIP'
'SKIP'
'SKIP'
'SKIP'
@@ -81,9 +82,8 @@ sha256sums=('SKIP'
'SKIP'
'335a55533ab26bd1f63683921baf33b8e8e3f2732a94554916d202ee500f90af'
'e5024ad3382f285fe63dc58faca379f11a669bbe9f5d90682c59ad588aab434c'
- '502fcbb3fcbb66aa5149ad2cc5f1fa297b51ed12c5c9396a16b5795a03860ed0'
- '1b420e3cc2afca11154c672123f001cf03cd2b96be3baafd229f6ee7d752419e'
- '9e0f517320c4351489db5840658ffcf537716b23e88a02ee69380734a40ced21')
+ '0bbf46bef304dea08b318d1ffd564735b19e1afb6c0f41c98d216824cc630132'
+ '2329bb09c80ce44ae622da9d318d246b237e3a4d259d12f6b8920a249ec994bb')
export GIT_LFS_SKIP_SMUDGE='1'
@@ -96,7 +96,6 @@ prepare() {
git -C openvino config --local submodule.thirdparty/xbyak.url "${srcdir}/xbyak"
git -C openvino config --local submodule.thirdparty/zlib/zlib.url "${srcdir}/zlib"
git -C openvino config --local submodule.thirdparty/pugixml.url "${srcdir}/pugixml"
- git -C openvino config --local submodule.thirdparty/ade.url "${srcdir}/ade"
git -C openvino config --local submodule.thirdparty/gflags/gflags.url "${srcdir}/gflags"
git -C openvino config --local submodule.thirdparty/gtest/gtest.url "${srcdir}/googletest-openvinotoolkit"
git -C openvino config --local submodule.thirdparty/ocl/icd_loader.url "${srcdir}/OpenCL-ICD-Loader"
@@ -114,30 +113,24 @@ prepare() {
git -C openvino config --local submodule.thirdparty/snappy.url "${srcdir}/snappy"
git -C openvino config --local submodule.ARMComputeLibrary.url "${srcdir}/ComputeLibrary"
git -C openvino config --local submodule.src/plugins/intel_cpu/thirdparty/mlas.url "${srcdir}/mlas"
+ git -C openvino config --local submodule.src/plugins/intel_npu/thirdparty/level-zero.url "${srcdir}/level-zero"
+ git -C openvino config --local submodule.src/plugins/intel_npu/thirdparty/level-zero-ext.url "${srcdir}/level-zero-npu-extensions"
+ git -C openvino config --local submodule.thirdparty/telemetry.url "${srcdir}/telemetry"
git -C openvino -c protocol.file.allow='always' submodule update
- mkdir -p openvino/temp
- cp -af "gna_${_gnaver}" openvino/temp
- printf '%s\n' "${source[1]}" > "openvino/temp/gna_${_gnaver}/ie_dependency.info"
-
- # ade gcc 13 fix
- git -C openvino/thirdparty/ade cherry-pick --no-commit 7cecc9138b89e1946e3e515727bb69b2ab119806
-
- patch -d openvino/thirdparty/ade -Np1 -i "${srcdir}/010-ade-disable-werror.patch"
- patch -d openvino -Np1 -i "${srcdir}/015-openvino-disable-werror.patch"
+ patch -d openvino -Np1 -i "${srcdir}/010-openvino-disable-werror.patch"
patch -d openvino -Np1 -i "${srcdir}/020-openvino-use-protobuf-shared-libs.patch"
}
build() {
- export CFLAGS+=' -march=x86-64-v3'
- export CXXFLAGS+=' -march=x86-64-v3'
-
# note: does not accept 'None' build type
cmake -B build -S openvino \
-G 'Unix Makefiles' \
-DBUILD_TESTING:BOOL='OFF' \
-DCMAKE_BUILD_TYPE:STRING='Release' \
-DCMAKE_INSTALL_PREFIX:PATH='/opt/intel/openvino' \
+ -DENABLE_SSE42:BOOL='OFF' \
+ -DENABLE_AVX2:BOOL='OFF' \
-DENABLE_AVX512F:BOOL='OFF' \
-DENABLE_PYTHON:BOOL='ON' \
-DENABLE_CLANG_FORMAT:BOOL='OFF' \