summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--020-openvino-use-protobuf-shared-libs.patch2
-rw-r--r--030-openvion-fix-opencl-headers.patch12
-rw-r--r--PKGBUILD17
4 files changed, 32 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cf7b952f296..a3fa71c1b1d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openvino-git
pkgdesc = A toolkit for developing artificial inteligence and deep learning applications (git version)
- pkgver = 2022.3.0.r990.ga1cde2e7901
+ pkgver = 2022.3.0.r1415.ge978db3132c
pkgrel = 1
url = https://docs.openvinotoolkit.org/
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = openvino-git
makedepends = cmake
makedepends = intel-compute-runtime
makedepends = libusb
+ makedepends = opencl-clhpp
makedepends = ocl-icd
makedepends = opencv
makedepends = patchelf
@@ -55,10 +56,13 @@ pkgbase = openvino-git
source = git+https://github.com/openvinotoolkit/open_model_zoo.git
source = git+https://github.com/nlohmann/json.git
source = git+https://github.com/google/flatbuffers.git
+ source = git+https://github.com/google/snappy.git
source = openvino.conf
source = setupvars.sh
source = 010-ade-disable-werror.patch
source = 020-openvino-use-protobuf-shared-libs.patch
+ source = 030-openvion-fix-opencl-headers.patch
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -82,6 +86,7 @@ pkgbase = openvino-git
sha256sums = 335a55533ab26bd1f63683921baf33b8e8e3f2732a94554916d202ee500f90af
sha256sums = e5024ad3382f285fe63dc58faca379f11a669bbe9f5d90682c59ad588aab434c
sha256sums = 502fcbb3fcbb66aa5149ad2cc5f1fa297b51ed12c5c9396a16b5795a03860ed0
- sha256sums = 9faccd9dc8088e36560a402b7613e149b773479b5070002d9504bf7bb2a267ed
+ sha256sums = 64284c112215ab6c78a70f04bec72b9bf2b487e4808a61a1581ac37f7c6ce34e
+ sha256sums = 34b54fb39dd080e04fca2a8285030a2b9ec867b1fdf1908aec5d91a06e8ed482
pkgname = openvino-git
diff --git a/020-openvino-use-protobuf-shared-libs.patch b/020-openvino-use-protobuf-shared-libs.patch
index 771708b2b115..5df1c674bb05 100644
--- a/020-openvino-use-protobuf-shared-libs.patch
+++ b/020-openvino-use-protobuf-shared-libs.patch
@@ -1,6 +1,6 @@
--- a/thirdparty/CMakeLists.txt
+++ b/thirdparty/CMakeLists.txt
-@@ -334,7 +334,7 @@ endif()
+@@ -342,7 +342,7 @@ endif()
if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND)
if(ENABLE_SYSTEM_PROTOBUF)
diff --git a/030-openvion-fix-opencl-headers.patch b/030-openvion-fix-opencl-headers.patch
new file mode 100644
index 000000000000..1cd9420e51bd
--- /dev/null
+++ b/030-openvion-fix-opencl-headers.patch
@@ -0,0 +1,12 @@
+--- a/thirdparty/ocl/CMakeLists.txt
++++ b/thirdparty/ocl/CMakeLists.txt
+@@ -44,8 +44,7 @@ add_subdirectory(icd_loader EXCLUDE_FROM
+ target_compile_definitions(OpenCL INTERFACE OV_GPU_USE_OPENCL_HPP
+ OV_GPU_OPENCL_HPP_HAS_UUID)
+ target_include_directories(OpenCL INTERFACE
+- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/cl_headers>
+- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/clhpp_headers/include>)
++ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/cl_headers>)
+
+ # The following variables are needed to make find_package(OpenCL) work
+
diff --git a/PKGBUILD b/PKGBUILD
index 3834ad5c1cdd..2cc86d7cbeda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=openvino-git
-pkgver=2022.3.0.r990.ga1cde2e7901
+pkgver=2022.3.0.r1415.ge978db3132c
pkgrel=1
pkgdesc='A toolkit for developing artificial inteligence and deep learning applications (git version)'
arch=('x86_64')
@@ -17,8 +17,9 @@ optdepends=('intel-compute-runtime: for GPU (clDNN) plugin'
'python: for Python API'
'python-numpy: for Python API'
'cython: for Python API')
-makedepends=('git' 'git-lfs' 'cmake' 'intel-compute-runtime' 'libusb' 'ocl-icd' 'opencv'
- 'patchelf' 'python' 'cython' 'shellcheck' 'aria2' 'wget' 'tbb')
+makedepends=('git' 'git-lfs' 'cmake' 'intel-compute-runtime' 'libusb' 'opencl-clhpp'
+ 'ocl-icd' 'opencv' 'patchelf' 'python' 'cython' 'shellcheck' 'aria2' 'wget'
+ 'tbb')
provides=('openvino' 'intel-openvino-git')
conflicts=('openvino' 'intel-openvino-git')
replaces=('intel-openvino-git')
@@ -43,10 +44,12 @@ source=('git+https://github.com/openvinotoolkit/openvino.git'
'git+https://github.com/openvinotoolkit/open_model_zoo.git'
'git+https://github.com/nlohmann/json.git'
'git+https://github.com/google/flatbuffers.git'
+ 'git+https://github.com/google/snappy.git'
'openvino.conf'
'setupvars.sh'
'010-ade-disable-werror.patch'
- '020-openvino-use-protobuf-shared-libs.patch')
+ '020-openvino-use-protobuf-shared-libs.patch'
+ '030-openvion-fix-opencl-headers.patch')
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -67,10 +70,12 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'335a55533ab26bd1f63683921baf33b8e8e3f2732a94554916d202ee500f90af'
'e5024ad3382f285fe63dc58faca379f11a669bbe9f5d90682c59ad588aab434c'
'502fcbb3fcbb66aa5149ad2cc5f1fa297b51ed12c5c9396a16b5795a03860ed0'
- '9faccd9dc8088e36560a402b7613e149b773479b5070002d9504bf7bb2a267ed')
+ '64284c112215ab6c78a70f04bec72b9bf2b487e4808a61a1581ac37f7c6ce34e'
+ '34b54fb39dd080e04fca2a8285030a2b9ec867b1fdf1908aec5d91a06e8ed482')
export GIT_LFS_SKIP_SMUDGE='1'
@@ -98,10 +103,12 @@ prepare() {
git -C openvino config --local submodule.tools/pot/thirdparty/open_model_zoo.url "${srcdir}/open_model_zoo"
git -C openvino config --local submodule.thirdparty/json/nlohmann_json.url "${srcdir}/json"
git -C openvino config --local submodule.thirdparty/flatbuffers/flatbuffers.url "${srcdir}/flatbuffers"
+ git -C openvino config --local submodule.thirdparty/snappy.url "${srcdir}/snappy"
git -C openvino -c protocol.file.allow='always' submodule update
patch -d openvino/thirdparty/ade -Np1 -i "${srcdir}/010-ade-disable-werror.patch"
patch -d openvino -Np1 -i "${srcdir}/020-openvino-use-protobuf-shared-libs.patch"
+ patch -d openvino -Np1 -i "${srcdir}/030-openvion-fix-opencl-headers.patch"
}
pkgver() {