summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--010-ade-disable-werror.patch11
-rw-r--r--010-openvino-disable-werror.patch (renamed from 015-openvino-disable-werror.patch)2
-rw-r--r--020-openvino-use-protobuf-shared-libs.patch2
-rw-r--r--PKGBUILD24
5 files changed, 16 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e4e6fa1642d..8f72633b1013 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = openvino-git
pkgdesc = A toolkit for developing artificial inteligence and deep learning applications (git version)
- pkgver = 2023.1.0.r339.g10dc2d8b9ba
+ pkgver = 2023.3.0.r875.g17bf1f6d841
pkgrel = 1
url = https://docs.openvinotoolkit.org/
arch = x86_64
- license = Apache
+ license = Apache-2.0
makedepends = git
makedepends = git-lfs
makedepends = cmake
@@ -39,7 +39,6 @@ pkgbase = openvino-git
source = git+https://github.com/herumi/xbyak.git
source = git+https://github.com/madler/zlib.git
source = git+https://github.com/zeux/pugixml.git
- source = git+https://github.com/opencv/ade.git
source = git+https://github.com/gflags/gflags.git
source = googletest-openvinotoolkit::git+https://github.com/openvinotoolkit/googletest.git
source = git+https://github.com/KhronosGroup/OpenCL-ICD-Loader.git
@@ -59,8 +58,7 @@ pkgbase = openvino-git
source = git+https://github.com/openvinotoolkit/mlas.git
source = openvino.conf
source = setupvars.sh
- source = 010-ade-disable-werror.patch
- source = 015-openvino-disable-werror.patch
+ source = 010-openvino-disable-werror.patch
source = 020-openvino-use-protobuf-shared-libs.patch
sha256sums = SKIP
sha256sums = SKIP
@@ -84,11 +82,9 @@ pkgbase = openvino-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
sha256sums = 335a55533ab26bd1f63683921baf33b8e8e3f2732a94554916d202ee500f90af
sha256sums = e5024ad3382f285fe63dc58faca379f11a669bbe9f5d90682c59ad588aab434c
- sha256sums = 502fcbb3fcbb66aa5149ad2cc5f1fa297b51ed12c5c9396a16b5795a03860ed0
- sha256sums = 1b420e3cc2afca11154c672123f001cf03cd2b96be3baafd229f6ee7d752419e
- sha256sums = fd22227bfbec18ee4f4fc4010deba387f6b8ae1c602938d36c8b86b128342647
+ sha256sums = edb5f6a15e3bf8e46f8ee0dc8aa81e78e3d75d1776478664c7179bb8a79f735f
+ sha256sums = 17417f7193e94c7df32242c71d650d8beda2dadea8b05db131a7731a56e9c84a
pkgname = openvino-git
diff --git a/010-ade-disable-werror.patch b/010-ade-disable-werror.patch
deleted file mode 100644
index bc242009c94c..000000000000
--- a/010-ade-disable-werror.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/sources/ade/CMakeLists.txt
-+++ b/sources/ade/CMakeLists.txt
-@@ -11,7 +11,7 @@ file( GLOB_RECURSE sources source/*.cpp )
- file( GLOB_RECURSE include *.hpp )
-
- if (CMAKE_CXX_COMPILER_ID STREQUAL GNU)
-- set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Wall -Wextra -Wconversion -Wshadow -Wno-error=cpp -Wformat -Wformat-security" )
-+ set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wconversion -Wshadow -Wno-error=cpp -Wformat -Wformat-security" )
- endif()
-
- add_library( ${PROJECT_NAME} STATIC ${include} ${sources} )
diff --git a/015-openvino-disable-werror.patch b/010-openvino-disable-werror.patch
index d62e0e81b504..9adf433a6297 100644
--- a/015-openvino-disable-werror.patch
+++ b/010-openvino-disable-werror.patch
@@ -1,6 +1,6 @@
--- a/src/plugins/intel_gpu/CMakeLists.txt
+++ b/src/plugins/intel_gpu/CMakeLists.txt
-@@ -37,10 +37,6 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include")
+@@ -41,10 +41,6 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include")
add_subdirectory(thirdparty)
include(thirdparty/cmake/rapidjson.cmake)
diff --git a/020-openvino-use-protobuf-shared-libs.patch b/020-openvino-use-protobuf-shared-libs.patch
index e5bbff35e5b5..eb6341f2870f 100644
--- a/020-openvino-use-protobuf-shared-libs.patch
+++ b/020-openvino-use-protobuf-shared-libs.patch
@@ -1,6 +1,6 @@
--- a/thirdparty/dependencies.cmake
+++ b/thirdparty/dependencies.cmake
-@@ -410,7 +410,7 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND
+@@ -307,7 +307,7 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND
# Note: Debian / Ubuntu / RHEL libprotobuf.a can only be used with -DBUILD_SHARED_LIBS=OFF
# because they are compiled without -fPIC
if(NOT DEFINED Protobuf_USE_STATIC_LIBS)
diff --git a/PKGBUILD b/PKGBUILD
index a0e4a6256050..c621a95572bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
# https://github.com/openvinotoolkit/openvino/issues/452#issuecomment-722941119
pkgname=openvino-git
-pkgver=2023.1.0.r339.g10dc2d8b9ba
+pkgver=2023.3.0.r875.g17bf1f6d841
pkgrel=1
pkgdesc='A toolkit for developing artificial inteligence and deep learning applications (git version)'
arch=('x86_64')
url='https://docs.openvinotoolkit.org/'
-license=('Apache')
+license=('Apache-2.0')
depends=('pugixml' 'onetbb')
optdepends=('intel-compute-runtime: for Intel GPU plugin'
'ocl-icd: for Intel GPU plugin'
@@ -30,7 +30,6 @@ source=('git+https://github.com/openvinotoolkit/openvino.git'
'git+https://github.com/herumi/xbyak.git'
'git+https://github.com/madler/zlib.git'
'git+https://github.com/zeux/pugixml.git'
- 'git+https://github.com/opencv/ade.git'
'git+https://github.com/gflags/gflags.git'
'googletest-openvinotoolkit'::'git+https://github.com/openvinotoolkit/googletest.git'
'git+https://github.com/KhronosGroup/OpenCL-ICD-Loader.git'
@@ -50,8 +49,7 @@ source=('git+https://github.com/openvinotoolkit/openvino.git'
'git+https://github.com/openvinotoolkit/mlas.git'
'openvino.conf'
'setupvars.sh'
- '010-ade-disable-werror.patch'
- '015-openvino-disable-werror.patch'
+ '010-openvino-disable-werror.patch'
'020-openvino-use-protobuf-shared-libs.patch')
sha256sums=('SKIP'
'SKIP'
@@ -75,12 +73,10 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'335a55533ab26bd1f63683921baf33b8e8e3f2732a94554916d202ee500f90af'
'e5024ad3382f285fe63dc58faca379f11a669bbe9f5d90682c59ad588aab434c'
- '502fcbb3fcbb66aa5149ad2cc5f1fa297b51ed12c5c9396a16b5795a03860ed0'
- '1b420e3cc2afca11154c672123f001cf03cd2b96be3baafd229f6ee7d752419e'
- 'fd22227bfbec18ee4f4fc4010deba387f6b8ae1c602938d36c8b86b128342647')
+ 'edb5f6a15e3bf8e46f8ee0dc8aa81e78e3d75d1776478664c7179bb8a79f735f'
+ '17417f7193e94c7df32242c71d650d8beda2dadea8b05db131a7731a56e9c84a')
export GIT_LFS_SKIP_SMUDGE='1'
@@ -93,7 +89,6 @@ prepare() {
git -C openvino config --local submodule.thirdparty/xbyak.url "${srcdir}/xbyak"
git -C openvino config --local submodule.thirdparty/zlib/zlib.url "${srcdir}/zlib"
git -C openvino config --local submodule.thirdparty/pugixml.url "${srcdir}/pugixml"
- git -C openvino config --local submodule.thirdparty/ade.url "${srcdir}/ade"
git -C openvino config --local submodule.thirdparty/gflags/gflags.url "${srcdir}/gflags"
git -C openvino config --local submodule.thirdparty/gtest/gtest.url "${srcdir}/googletest-openvinotoolkit"
git -C openvino config --local submodule.thirdparty/ocl/icd_loader.url "${srcdir}/OpenCL-ICD-Loader"
@@ -113,11 +108,7 @@ prepare() {
git -C openvino config --local submodule.src/plugins/intel_cpu/thirdparty/mlas.url "${srcdir}/mlas"
git -C openvino -c protocol.file.allow='always' submodule update
- # ade gcc 13 fix
- git -C openvino/thirdparty/ade cherry-pick --no-commit 7cecc9138b89e1946e3e515727bb69b2ab119806
-
- patch -d openvino/thirdparty/ade -Np1 -i "${srcdir}/010-ade-disable-werror.patch"
- patch -d openvino -Np1 -i "${srcdir}/015-openvino-disable-werror.patch"
+ patch -d openvino -Np1 -i "${srcdir}/010-openvino-disable-werror.patch"
patch -d openvino -Np1 -i "${srcdir}/020-openvino-use-protobuf-shared-libs.patch"
}
@@ -130,6 +121,9 @@ pkgver() {
}
build() {
+ export CFLAGS+=' -march=x86-64-v3'
+ export CXXFLAGS+=' -march=x86-64-v3'
+
# note: does not accept 'None' build type
cmake -B build -S openvino \
-G 'Unix Makefiles' \