summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD31
2 files changed, 27 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c219249cc7c..dbcf8aac096e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,24 @@
+# Generated by mksrcinfo v8
+# Fri Nov 18 14:15:15 UTC 2016
pkgbase = openvpn-git
pkgdesc = An easy-to-use, robust, and highly configurable VPN (Virtual Private Network) - git checkout
- pkgver = 2.3.beta1.r324.g4ad2b65
+ pkgver = 2.4.beta1.r1.g237fd7f
pkgrel = 1
url = http://openvpn.net/index.php/open-source.html
arch = i686
arch = x86_64
license = custom
+ makedepends = git
+ makedepends = systemd
depends = openssl
depends = lzo
depends = snappy
depends = lz4
depends = iproute2
- optdepends = easy-rsa: for easy key management
- provides = openvpn=2.3.0
+ depends = libsystemd
+ depends = pkcs11-helper
+ optdepends = easy-rsa: easy CA and certificate handling
+ provides = openvpn=2.4.0
provides = openvpn-dev
conflicts = openvpn
conflicts = openvpn-dev
diff --git a/PKGBUILD b/PKGBUILD
index b63585a877cf..921d17830f04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Christian Hesse <mail@eworm.de>
-# Contributor: Thomas Bächler <thomas@archlinux.org> ([core] package)
pkgname=openvpn-git
-pkgver=2.3.beta1.r324.g4ad2b65
+pkgver=2.4.beta1.r1.g237fd7f
pkgrel=1
pkgdesc="An easy-to-use, robust, and highly configurable VPN (Virtual Private Network) - git checkout"
arch=(i686 x86_64)
url="http://openvpn.net/index.php/open-source.html"
-depends=('openssl' 'lzo' 'snappy' 'lz4' 'iproute2')
-optdepends=('easy-rsa: for easy key management')
+depends=('openssl' 'lzo' 'snappy' 'lz4' 'iproute2' 'libsystemd' 'pkcs11-helper')
+optdepends=('easy-rsa: easy CA and certificate handling')
+makedepends=('git' 'systemd')
conflicts=('openvpn' 'openvpn-dev')
-provides=('openvpn=2.3.0' 'openvpn-dev')
+provides=('openvpn=2.4.0' 'openvpn-dev')
license=('custom')
# for 2.3.x release branch use: git://git.code.sf.net/p/openvpn/openvpn#branch=release/2.3
source=('git://git.code.sf.net/p/openvpn/openvpn')
@@ -20,9 +20,14 @@ pkgver() {
cd openvpn/
if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ printf '%s.r%s.g%s' \
+ "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
+ "$(git rev-list --count ${GITTAG}..)" \
+ "$(git log -1 --format='%h')"
else
- echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ printf '0.r%s.g%s' \
+ "$(git rev-list --count master)" \
+ "$(git log -1 --format='%h')"
fi
}
@@ -33,11 +38,13 @@ build() {
autoreconf -vi
CFLAGS="${CFLAGS} -DPLUGIN_LIBDIR=\\\"/usr/lib/openvpn\\\"" ./configure \
--prefix=/usr \
- --enable-iproute2 \
+ --sbindir=/usr/bin \
--enable-password-save \
- --enable-systemd \
--mandir=/usr/share/man \
- --sbindir=/usr/bin
+ --enable-iproute2 \
+ --enable-systemd \
+ --enable-pkcs11 \
+ --enable-x509-alt-username
make
}
@@ -51,8 +58,6 @@ package() {
# Install examples
install -d -m0755 ${pkgdir}/usr/share/openvpn
cp -r sample/sample-config-files ${pkgdir}/usr/share/openvpn/examples
- find ${pkgdir}/usr/share/openvpn -type f -exec chmod 644 {} \;
- find ${pkgdir}/usr/share/openvpn -type d -exec chmod 755 {} \;
# Install license
install -d -m0755 ${pkgdir}/usr/share/licenses/openvpn
@@ -62,7 +67,7 @@ package() {
install -d -m0755 ${pkgdir}/usr/share/openvpn/contrib
cp -r contrib ${pkgdir}/usr/share/openvpn
- # Install systemd unit files
+ # Install systemd services
install -D -m0644 distro/systemd/openvpn-client@.service ${pkgdir}/usr/lib/systemd/system/openvpn-client@.service
install -D -m0644 distro/systemd/openvpn-server@.service ${pkgdir}/usr/lib/systemd/system/openvpn-server@.service
}