summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0001-plugin.patch46
-rw-r--r--PKGBUILD11
3 files changed, 5 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4531b04485d6..73ed3b8b7159 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Jan 25 19:01:32 UTC 2017
+# Wed Jan 25 21:22:38 UTC 2017
pkgbase = openvpn-git
pkgdesc = An easy-to-use, robust and highly configurable VPN (Virtual Private Network) - git checkout
- pkgver = 2.4.rc2.r25.g76096c60
+ pkgver = 2.4.rc2.r26.g4590c383
pkgrel = 1
url = http://openvpn.net/index.php/open-source.html
arch = i686
@@ -21,9 +21,7 @@ pkgbase = openvpn-git
conflicts = openvpn
conflicts = openvpn-dev
source = git://github.com/OpenVPN/openvpn.git
- source = 0001-plugin.patch
sha256sums = SKIP
- sha256sums = b8254067b4ef5d157d87267a76938d86f101972303c7ff20131cc9f28659a30c
pkgname = openvpn-git
diff --git a/0001-plugin.patch b/0001-plugin.patch
deleted file mode 100644
index 803c7c5510b1..000000000000
--- a/0001-plugin.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index f4073d0..5fe652e 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -301,13 +301,12 @@ AC_ARG_WITH(
- [with_crypto_library="openssl"]
- )
-
--AC_ARG_WITH(
-- [plugindir],
-- [AS_HELP_STRING([--with-plugindir], [plugin directory @<:@default=LIBDIR/openvpn@:>@])],
-- ,
-- [with_plugindir="\$(libdir)/openvpn/plugins"]
--)
--
-+AC_ARG_VAR([PLUGINDIR], [Path of plug-in directory @<:@default=LIBDIR/openvpn/plugins@:>@])
-+if test -n "${PLUGINDIR}"; then
-+ plugindir="${PLUGINDIR}"
-+else
-+ plugindir="\${libdir}/openvpn/plugins"
-+fi
-
- AC_DEFINE_UNQUOTED([TARGET_ALIAS], ["${host}"], [A string representing our host])
- case "$host" in
-@@ -1245,7 +1244,6 @@ AM_CONDITIONAL([ENABLE_PLUGIN_AUTH_PAM], [test "${enable_plugin_auth_pam}" = "ye
- AM_CONDITIONAL([ENABLE_PLUGIN_DOWN_ROOT], [test "${enable_plugin_down_root}" = "yes"])
- AM_CONDITIONAL([ENABLE_CRYPTO], [test "${enable_crypto}" = "yes"])
-
--plugindir="${with_plugindir}"
- sampledir="\$(docdir)/sample"
- AC_SUBST([plugindir])
- AC_SUBST([sampledir])
-diff --git a/src/openvpn/Makefile.am b/src/openvpn/Makefile.am
-index 4c18449..188834a 100644
---- a/src/openvpn/Makefile.am
-+++ b/src/openvpn/Makefile.am
-@@ -27,7 +27,8 @@ AM_CFLAGS = \
- $(OPTIONAL_CRYPTO_CFLAGS) \
- $(OPTIONAL_LZO_CFLAGS) \
- $(OPTIONAL_LZ4_CFLAGS) \
-- $(OPTIONAL_PKCS11_HELPER_CFLAGS)
-+ $(OPTIONAL_PKCS11_HELPER_CFLAGS) \
-+ -DPLUGIN_LIBDIR=\"${plugindir}\"
- if WIN32
- # we want unicode entry point but not the macro
- AM_CFLAGS += -municode -UUNICODE
diff --git a/PKGBUILD b/PKGBUILD
index ff907609c6d3..dddaa0bb8593 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christian Hesse <mail@eworm.de>
pkgname=openvpn-git
-pkgver=2.4.rc2.r25.g76096c60
+pkgver=2.4.rc2.r26.g4590c383
pkgrel=1
pkgdesc='An easy-to-use, robust and highly configurable VPN (Virtual Private Network) - git checkout'
arch=('i686' 'x86_64')
@@ -13,10 +13,8 @@ conflicts=('openvpn' 'openvpn-dev')
provides=('openvpn=2.4.0' 'openvpn-dev')
license=('custom')
# for 2.4.x release branch append: #branch=release/2.4
-source=('git://github.com/OpenVPN/openvpn.git'
- '0001-plugin.patch')
-sha256sums=('SKIP'
- 'b8254067b4ef5d157d87267a76938d86f101972303c7ff20131cc9f28659a30c')
+source=('git://github.com/OpenVPN/openvpn.git')
+sha256sums=('SKIP')
pkgver() {
cd openvpn/
@@ -36,9 +34,6 @@ pkgver() {
prepare() {
cd openvpn/
- # plugin path
- patch -Np1 < "${srcdir}"/0001-plugin.patch
-
# regenerate configure script
autoreconf -vi
}