summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
-rw-r--r--opera-adblock-complete.install13
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1363cc8ef156
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = opera-adblock-complete
+ pkgdesc = Fanboy's AdBlock Filterset for Opera including Stat/Tracking Filters
+ pkgver = 11.05.2013
+ pkgrel = 1
+ url = http://www.fanboy.co.nz/adblock/opera/
+ install = opera-adblock-complete.install
+ arch = any
+ license = cc-by-3.0
+ depends = opera
+ source = http://www.fanboy.co.nz/adblock/opera/urlfilter.ini
+ sha512sums = 47ef0c7e195f6fcfad1ca7fa7dd8149a2fd3de98680a6da38c45925f4e1a6d5a6dc448d5a6a866e0517a8be95d49d708f9583a5bbb102fa88956f7e519f254dd
+
+pkgname = opera-adblock-complete
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f5f617ecaa0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+#! /bin/bash
+# Maintainer: Jorge Barroso <jorge.barroso.11 at gmail dot com>
+# Contributor: Jeremy Sands <cto@jeremysands.com>
+
+pkgname=opera-adblock-complete
+pkgver=11.05.2013
+pkgrel=1
+pkgdesc="Fanboy's AdBlock Filterset for Opera including Stat/Tracking Filters"
+arch=('any')
+url="http://www.fanboy.co.nz/adblock/opera/"
+license=('cc-by-3.0')
+depends=('opera')
+source=(http://www.fanboy.co.nz/adblock/opera/urlfilter.ini)
+install=${pkgname}.install
+sha512sums=('47ef0c7e195f6fcfad1ca7fa7dd8149a2fd3de98680a6da38c45925f4e1a6d5a6dc448d5a6a866e0517a8be95d49d708f9583a5bbb102fa88956f7e519f254dd')
+
+
+package() {
+ cd $srcdir
+ install -D -m644 urlfilter.ini $pkgdir/usr/share/$pkgname/urlfilter.ini
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file
diff --git a/opera-adblock-complete.install b/opera-adblock-complete.install
new file mode 100644
index 000000000000..8ec26a220d5c
--- /dev/null
+++ b/opera-adblock-complete.install
@@ -0,0 +1,13 @@
+pkgname=opera-adblock-complete
+
+post_install() {
+ cat << _EOF
+
+==> IMPORTANT!!!
+==> This provides a urlfilter.ini file in /usr/share/opera-adblock-complete
+==>
+==> To use it, do the following as the users you use opera with:
+==> ln -s /usr/share/opera-adblock-complete/urlfilter.ini ~/.opera/urlfilter.ini
+
+_EOF
+}