summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d537bc18a4d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ophidian-flute-git
+ pkgdesc = A rectilinear Steiner minimal tree and wirelength algorithm described in the ICCAD 04 and ISPD 05 papers.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://gitlab.com/eclufsc/Flute
+ arch = x86_64
+ groups = ophidian
+ license = custom
+ makedepends = make
+ makedepends = bison
+ makedepends = flex
+ source = git+https://gitlab.com/eclufsc/Flute.git#branch=master
+ md5sums = SKIP
+
+pkgname = ophidian-flute-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf614933b32b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Bernardo Ferrari Mendonca <bernardo.mferrari@gmail.com>
+pkgname=ophidian-flute-git
+pkgver=1.0
+pkgrel=1
+groups=('ophidian')
+pkgdesc="A rectilinear Steiner minimal tree and wirelength algorithm described in the ICCAD 04 and ISPD 05 papers."
+arch=('x86_64')
+url="https://gitlab.com/eclufsc/Flute"
+license=('custom')
+makedepends=('make' 'bison' 'flex')
+source=('git+https://gitlab.com/eclufsc/Flute.git#branch=master')
+md5sums=('SKIP')
+
+
+build() {
+ cd $srcdir/Flute
+ mkdir build && cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+}
+
+package() {
+ install -d $pkgdir/usr/share/Flute
+ install -D -m 644 $srcdir/Flute/license.txt $pkgdir/usr/share/Flute/copyright
+
+ cd $srcdir/Flute/build
+ make DESTDIR="$pkgdir/" install
+}