summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--patch-orthanc-force-version-lib-digest.patch12
-rw-r--r--patch-orthanc-force-version-lib.patch10
4 files changed, 33 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a881e526139..2d77849093e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = orthanc-plugin-web-viewer
pkgdesc = Web viewer of medical images plugin for Orthanc
- pkgver = 2.7
+ pkgver = 2.8
pkgrel = 2
url = https://book.orthanc-server.com/plugins/webviewer.html
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = orthanc-plugin-web-viewer
makedepends = gtest
makedepends = make
depends = orthanc
- source = https://www.orthanc-server.com/downloads/get.php?path=/plugin-webviewer/OrthancWebViewer-2.7.tar.gz
- sha512sums = 86b08652a0216e802f2ccc93f2298b42437d3dfcf9d260d7da6920119901a61b4065fe29451a3660d64ec84a8fcd9eb18269d7b41fe1ce365b50892ea485aae2
+ source = https://www.orthanc-server.com/downloads/get.php?path=/plugin-webviewer/OrthancWebViewer-2.8.tar.gz
+ sha512sums = 943e61bcf086ea15da992880b7d40f98a6a5a5b98c772113e5b7071002cb163958a428988e3136b04a2fd6b334124924977ad5205cbe7ee3cb2102dd5f454616
pkgname = orthanc-plugin-web-viewer
diff --git a/PKGBUILD b/PKGBUILD
index e02afa766bad..565d9ecdaacc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: William Gathoye <william + aur at gathoye dot be>
pkgname=orthanc-plugin-web-viewer
-pkgver=2.7
+pkgver=2.8
pkgrel=2
pkgdesc='Web viewer of medical images plugin for Orthanc'
arch=('x86_64' 'i686')
@@ -18,9 +18,15 @@ source=(
"https://www.orthanc-server.com/downloads/get.php?path=/plugin-webviewer/OrthancWebViewer-${pkgver}.tar.gz"
)
sha512sums=(
- '86b08652a0216e802f2ccc93f2298b42437d3dfcf9d260d7da6920119901a61b4065fe29451a3660d64ec84a8fcd9eb18269d7b41fe1ce365b50892ea485aae2'
+ '943e61bcf086ea15da992880b7d40f98a6a5a5b98c772113e5b7071002cb163958a428988e3136b04a2fd6b334124924977ad5205cbe7ee3cb2102dd5f454616'
)
+prepare() {
+ cd OrthancWebViewer-"${pkgver}"/
+ patch -p2 < "../../patch-orthanc-force-version-lib.patch"
+ patch -p2 < "../../patch-orthanc-force-version-lib-digest.patch"
+}
+
build() {
cd OrthancWebViewer-"${pkgver}"/
cmake \
diff --git a/patch-orthanc-force-version-lib-digest.patch b/patch-orthanc-force-version-lib-digest.patch
new file mode 100644
index 000000000000..a621aacc5a93
--- /dev/null
+++ b/patch-orthanc-force-version-lib-digest.patch
@@ -0,0 +1,12 @@
+--- b/OrthancWebViewer-2.8/Resources/Orthanc/CMake/DownloadOrthancFramework.cmake 2022-02-22 08:33:59.000000000 +0100
++++ a/OrthancWebViewer-2.8/Resources/Orthanc/CMake/DownloadOrthancFramework.cmake 2022-03-02 11:56:46.279043636 +0100
+@@ -142,6 +142,9 @@
+ set(ORTHANC_FRAMEWORK_MD5 "4b5d05683d747c29b2860ad79d11e62e")
+ elseif (ORTHANC_FRAMEWORK_VERSION STREQUAL "1.9.7")
+ set(ORTHANC_FRAMEWORK_MD5 "c912bbb860d640d3ae3003b5c9698205")
++ elseif (ORTHANC_FRAMEWORK_VERSION STREQUAL "1.10.0")
++ set(ORTHANC_FRAMEWORK_MD5 "8610c82d9153f22e929f2110f8f60279")
++
+
+ # Below this point are development snapshots that were used to
+ # release some plugin, before an official release of the Orthanc
diff --git a/patch-orthanc-force-version-lib.patch b/patch-orthanc-force-version-lib.patch
new file mode 100644
index 000000000000..f213b5c31aea
--- /dev/null
+++ b/patch-orthanc-force-version-lib.patch
@@ -0,0 +1,10 @@
+--- a/OrthancWebViewer-2.8/CMakeLists.txt 2022-02-22 08:33:59.000000000 +0100
++++ b/OrthancWebViewer-2.8/CMakeLists.txt 2022-03-02 11:53:12.425007158 +0100
+@@ -28,7 +28,7 @@
+ set(ORTHANC_FRAMEWORK_DEFAULT_VERSION "mainline")
+ set(ORTHANC_FRAMEWORK_DEFAULT_SOURCE "hg")
+ else()
+- set(ORTHANC_FRAMEWORK_DEFAULT_VERSION "1.9.7")
++ set(ORTHANC_FRAMEWORK_DEFAULT_VERSION "1.10.0")
+ set(ORTHANC_FRAMEWORK_DEFAULT_SOURCE "web")
+ endif()