summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rwxr-xr-xPKGBUILD33
-rwxr-xr-xorthorobot.desktop2
3 files changed, 25 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3770f9333bea..83381016181c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Wed Mar 22 09:36:17 UTC 2017
pkgbase = orthorobot
- pkgdesc = Perspective based puzzle game, where you flatten the view to move across gaps
+ pkgdesc = Perspective based puzzle game, where you flatten the view to move across gaps.
pkgver = 1.0
- pkgrel = 4
+ pkgrel = 5
url = http://stabyourself.net/orthorobot/
arch = i686
arch = x86_64
@@ -9,13 +11,13 @@ pkgbase = orthorobot
makedepends = unzip
depends = love07
source = http://stabyourself.net/dl.php?file=orthorobot/orthorobot-linux.zip
- source = https://bitbucket.org/rude/love/raw/0.7.0/platform/unix/app.svg
+ source = http://stabyourself.net/images/site/banner-orthorobot.png
source = orthorobot.sh
source = orthorobot.desktop
md5sums = 3ba42cd5058660d6750cdbcb3cf477df
- md5sums = a1e19f91420cc519a683af360f5b1120
+ md5sums = 357045580e02e973b0c9ae10399657d5
md5sums = 4b43b2f28fe7af330b78152131fc8772
- md5sums = 4d5757d30b2b07c9062d3fe02ce65a57
+ md5sums = d9d6a95c1382beb2ec3e75d85206eadb
pkgname = orthorobot
diff --git a/PKGBUILD b/PKGBUILD
index e85058020b61..3a78f3a6b8e6 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,37 @@
-# Maintainer: archtux <antonio dot arias99999 at gmail dot com>
+# Contributor: archtux <antonio dot arias99999 at gmail dot com>
+# Maintainer: SanskritFritz (gmail)
pkgname=orthorobot
pkgver=1.0
-pkgrel=4
-pkgdesc='Perspective based puzzle game, where you flatten the view to move across gaps'
+pkgrel=5
+pkgdesc='Perspective based puzzle game, where you flatten the view to move across gaps.'
arch=('i686' 'x86_64')
url="http://stabyourself.net/orthorobot/"
license=('GPL')
depends=('love07')
makedepends=('unzip')
_gamepkg=${pkgname}-linux.zip
-source=(http://stabyourself.net/dl.php?file=orthorobot/orthorobot-linux.zip
- https://bitbucket.org/rude/love/raw/0.7.0/platform/unix/app.svg
- $pkgname.sh
- $pkgname.desktop)
+source=("http://stabyourself.net/dl.php?file=orthorobot/orthorobot-linux.zip"
+ "http://stabyourself.net/images/site/banner-orthorobot.png"
+ "$pkgname.sh"
+ "$pkgname.desktop")
md5sums=('3ba42cd5058660d6750cdbcb3cf477df'
- 'a1e19f91420cc519a683af360f5b1120'
+ '357045580e02e973b0c9ae10399657d5'
'4b43b2f28fe7af330b78152131fc8772'
- '4d5757d30b2b07c9062d3fe02ce65a57')
+ 'd9d6a95c1382beb2ec3e75d85206eadb')
package() {
- cd $srcdir
+ cd "$srcdir"
- unzip -o $srcdir/$_gamepkg -d $srcdir/$pkgname
+ unzip -o "$srcdir/$_gamepkg" -d "$srcdir/$pkgname"
# Start file
- install -Dm755 $pkgname.sh $pkgdir/usr/bin/$pkgname
+ install -Dm755 "$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
# Executable
- install -Dm644 $pkgname/Ortho\ Robot.love $pkgdir/usr/share/games/$pkgname/$pkgname.love
+ install -Dm644 "$pkgname/Ortho Robot.love" "$pkgdir/usr/share/games/$pkgname/$pkgname.love"
# Desktop icon
- install -Dm644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
- install -Dm644 app.svg $pkgdir/usr/share/pixmaps/$pkgname.svg
-} \ No newline at end of file
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "banner-orthorobot.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+}
diff --git a/orthorobot.desktop b/orthorobot.desktop
index 2273ea473251..c416e8cda42e 100755
--- a/orthorobot.desktop
+++ b/orthorobot.desktop
@@ -2,7 +2,7 @@
[Desktop Entry]
Version=1.0
Type=Application
-Icon=/usr/share/pixmaps/orthorobot.svg
+Icon=/usr/share/pixmaps/orthorobot.png
Exec=orthorobot
Terminal=false
StartupNotify=false