summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--0001-Add-sb2install-support-to-osc.patch33
-rw-r--r--0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch18
-rw-r--r--0003-Support-synchronous-copyproj.patch14
-rw-r--r--0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch12
-rw-r--r--0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch8
-rw-r--r--0006-Add-architecture-and-scheduler-maps.patch4
-rw-r--r--0007-Trap-any-kind-of-exception-during-plugin-parsing-eg-.patch23
-rw-r--r--0008-Fix-hdrmd5-check-of-downloaded-packages-from-DoD-rep.patch33
-rw-r--r--PKGBUILD16
10 files changed, 61 insertions, 116 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 539bc24d4caa..e57338ef93d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -27,17 +27,13 @@ pkgbase = osc
source = 0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch
source = 0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch
source = 0006-Add-architecture-and-scheduler-maps.patch
- source = 0007-Trap-any-kind-of-exception-during-plugin-parsing-eg-.patch
- source = 0008-Fix-hdrmd5-check-of-downloaded-packages-from-DoD-rep.patch
sha256sums = 02bb2166fbda06babbcd60e67437ba83f9032c12c41529325e49d0663cb11aa5
sha256sums = 2b045e03d2fdce12683ceb9792d491a32f00b256045456412e7bc18c8726218a
- sha256sums = 4f9d5a4aa7d84e0237a3ba633004c7472d873450c769a666f6dde3b7929f3f88
- sha256sums = c360ca8425f9c90d94f02914a561b7f7d85887bf935a5cfdcb868ee1a7d10f29
- sha256sums = 7a9dfcec1ee495735188aadd8393e914783a0cc2bca095599e014c9e934954dc
- sha256sums = 1e38593b0447bdaf1fae936d5bb8913f90352aa62ca5a3f3715600b20bba58ed
- sha256sums = b8ae40c4babcbe9361c762df817021ab290d42d76faad822b7d45f8462f75654
- sha256sums = 5564c4cdaed550ddfe05ce74e96448c9232181b4f6fc637c933642eb221461f2
- sha256sums = 59eb84c63d3f847cc54dffa98855ce4737959edb908f84b7fedc559d60df0196
- sha256sums = a4b0aa983eba58e7239f057368cab39b4468da6dd475f3f8e6243f656492289c
+ sha256sums = 7478f2297ac87090979d19fd55d539aa1000792a8858796ba7c7f239b45d9ef6
+ sha256sums = de9cd536d5b294b5ec702d6e57f014928e67f3678c1dd9ea2a7d986c2506469b
+ sha256sums = 0ac6241d05061e85f4b7d38472180c138e266bf968d6c074105d7e528f44e336
+ sha256sums = 1573dd86844d1eebeb93ff092f6345928fad4611f7634dadb17fcc579de4dc32
+ sha256sums = 8ac9d5760333f76428f85ff6ee8cffabc12678be703ba285f708015d95039eb4
+ sha256sums = eae5f978b8385db3acae46df96fc4973f306c4a640389165a8ac54469d370e5b
pkgname = osc
diff --git a/0001-Add-sb2install-support-to-osc.patch b/0001-Add-sb2install-support-to-osc.patch
index 1a20b2e2209d..e0ba1c6a3105 100644
--- a/0001-Add-sb2install-support-to-osc.patch
+++ b/0001-Add-sb2install-support-to-osc.patch
@@ -4,30 +4,39 @@ Date: Fri, 15 May 2020 13:46:20 +0300
Subject: [PATCH] Add sb2install support to osc
---
- osc/build.py | 3 +++
- 1 file changed, 3 insertions(+)
+ osc/build.py | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/osc/build.py b/osc/build.py
-index fab14b138e71b2d6506085ce8f97b43f3d77ce64..3409714a19653df323886de26fe46c88f7194931 100644
+index 7e864b883686bd56755d1f0250df12ec80cecc89..d51b81c9cc66959d74194c48f2a6710649fd117f 100644
--- a/osc/build.py
+++ b/osc/build.py
-@@ -182,6 +182,7 @@ class Buildinfo:
- self.urls[node.get('project')+"/"+node.get('repository')] = baseurl + '/%(arch)s/%(filename)s'
+@@ -190,12 +190,13 @@ class Buildinfo:
+ self.urls[node.get('project') + "/" + node.get('repository')] = baseurl + '/%(arch)s/%(filename)s'
- self.vminstall_list = [ dep.name for dep in self.deps if dep.vminstall ]
+ self.vminstall_list = [dep.name for dep in self.deps if dep.vminstall]
+ self.sb2install_list = [ dep.name for dep in self.deps if dep.sb2install ]
- self.preinstall_list = [ dep.name for dep in self.deps if dep.preinstall ]
- self.runscripts_list = [ dep.name for dep in self.deps if dep.runscripts ]
- self.noinstall_list = [ dep.name for dep in self.deps if dep.noinstall ]
-@@ -219,6 +220,7 @@ class Pac:
+ self.preinstall_list = [dep.name for dep in self.deps if dep.preinstall]
+ self.runscripts_list = [dep.name for dep in self.deps if dep.runscripts]
+ self.noinstall_list = [dep.name for dep in self.deps if dep.noinstall]
+ self.installonly_list = [dep.name for dep in self.deps if dep.installonly]
+
+- if root.find('preinstallimage') is not None:
++ if root.find('preinstallimage') != None:
+ self.preinstallimage = root.find('preinstallimage')
+ else:
+ self.preinstallimage = None
+@@ -227,7 +228,8 @@ class Pac:
'project', 'repository', 'sysroot',
'preinstall', 'vminstall', 'runscripts',
'noinstall', 'installonly', 'notmeta',
+- ]:
+ 'sb2install',
- ]:
++ ]:
self.mp[i] = node.get(i)
-@@ -1364,6 +1366,7 @@ def main(apiurl, opts, argv):
+ self.mp['buildarch'] = buildarch
+@@ -1390,6 +1392,7 @@ def main(apiurl, opts, argv):
rpmlist.append('preinstall: ' + ' '.join(bi.preinstall_list) + '\n')
rpmlist.append('vminstall: ' + ' '.join(bi.vminstall_list) + '\n')
diff --git a/0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch b/0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch
index 8c0b2db449e9..2bba1a5df823 100644
--- a/0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch
+++ b/0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch
@@ -13,13 +13,13 @@ Subject: [PATCH] Support 'osc copyprj' in api by Islam Amer usage: osc copyprj
2 files changed, 80 insertions(+)
diff --git a/osc/commandline.py b/osc/commandline.py
-index e00d6e68ea4eb96e8eefa14e177934a247de9b6e..c18b3cb3ad9369356a9d8c014ce3f7f4c9b92d1c 100644
+index ee68b0e77f0304fea025b9b3c22b370fadccc42a..cae02268cacca43aa7db97ace9683b841afbfe2c 100644
--- a/osc/commandline.py
+++ b/osc/commandline.py
-@@ -3134,6 +3134,58 @@ Please submit there instead, or use --nodevelproject to force direct submission.
- break
- sys.stdout.write(decode_it(buf))
-
+@@ -3408,6 +3408,58 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+ delayed=not opts.no_delay,
+ print_to="stdout",
+ )
+ @cmdln.option('-b', '--with-binaries', action='store_true',
+ help='copy the built binaries over to avoid a rebuild')
+ @cmdln.option('-x', '--with-history', action='store_true',
@@ -76,10 +76,10 @@ index e00d6e68ea4eb96e8eefa14e177934a247de9b6e..c18b3cb3ad9369356a9d8c014ce3f7f4
@cmdln.option('-m', '--message', metavar='TEXT',
help='specify message TEXT')
diff --git a/osc/core.py b/osc/core.py
-index 2ef744296c65e43adfb0ea60cd0a203ac7173e2c..a3c45884eadc729cc785dd7c9cc3e5723c516b92 100644
+index 6a86901b1fdf37e0178caffe9e39d1cceb9145f7..fc6410974f57815ac36abc7232972da7d925b82a 100644
--- a/osc/core.py
+++ b/osc/core.py
-@@ -5549,6 +5549,34 @@ def copy_pac(src_apiurl, src_project, src_package,
+@@ -6002,6 +6002,34 @@ def copy_pac(
raise oscerr.APIError('failed to copy: %s' % ', '.join(todo))
return 'Done.'
@@ -112,5 +112,5 @@ index 2ef744296c65e43adfb0ea60cd0a203ac7173e2c..a3c45884eadc729cc785dd7c9cc3e572
+ f = http_POST(u)
+ return f.read()
- def unlock_package(apiurl, prj, pac, msg):
- query = {'cmd': 'unlock', 'comment': msg}
+ def lock(apiurl: str, project: str, package: str, msg: str = None):
+ url_path = ["source", project]
diff --git a/0003-Support-synchronous-copyproj.patch b/0003-Support-synchronous-copyproj.patch
index d9fd2f63962b..ed881af9e303 100644
--- a/0003-Support-synchronous-copyproj.patch
+++ b/0003-Support-synchronous-copyproj.patch
@@ -9,11 +9,11 @@ Subject: [PATCH] Support synchronous copyproj
2 files changed, 7 insertions(+)
diff --git a/osc/commandline.py b/osc/commandline.py
-index c18b3cb3ad9369356a9d8c014ce3f7f4c9b92d1c..76c9131fe498c8b03e2d8f739091c1930bfb09f4 100644
+index cae02268cacca43aa7db97ace9683b841afbfe2c..481fb1c2090aa76e84aaac6e56bf74ab3f2cf811 100644
--- a/osc/commandline.py
+++ b/osc/commandline.py
-@@ -3136,6 +3136,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
-
+@@ -3410,6 +3410,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+ )
@cmdln.option('-b', '--with-binaries', action='store_true',
help='copy the built binaries over to avoid a rebuild')
+ @cmdln.option('-n', '--now', action='store_true',
@@ -21,7 +21,7 @@ index c18b3cb3ad9369356a9d8c014ce3f7f4c9b92d1c..76c9131fe498c8b03e2d8f739091c193
@cmdln.option('-x', '--with-history', action='store_true',
help='replicate the history of each package.')
@cmdln.option('-o', '--make-older', action='store_true',
-@@ -3153,6 +3155,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -3427,6 +3429,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
The user must be able to create DESTPRJ
@@ -30,7 +30,7 @@ index c18b3cb3ad9369356a9d8c014ce3f7f4c9b92d1c..76c9131fe498c8b03e2d8f739091c193
usage:
osc copyprj SOURCEPRJ DESTPRJ
${cmd_option_list}
-@@ -3182,6 +3186,7 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -3456,6 +3460,7 @@ Please submit there instead, or use --nodevelproject to force direct submission.
withhistory = opts.with_history,
makeolder = opts.make_older,
resign = opts.re_sign,
@@ -39,10 +39,10 @@ index c18b3cb3ad9369356a9d8c014ce3f7f4c9b92d1c..76c9131fe498c8b03e2d8f739091c193
print("done cp")
print(r)
diff --git a/osc/core.py b/osc/core.py
-index a3c45884eadc729cc785dd7c9cc3e5723c516b92..60137a067ead1b040c516b88c102827cdefd1414 100644
+index fc6410974f57815ac36abc7232972da7d925b82a..83123b240217f6b02bae9447b471e424d2bc9266 100644
--- a/osc/core.py
+++ b/osc/core.py
-@@ -5573,6 +5573,8 @@ def copy_prj(src_apiurl, src_project, dst_project,
+@@ -6026,6 +6026,8 @@ def copy_prj(src_apiurl, src_project, dst_project,
query['resign'] = '1'
if comment:
query['comment'] = comment
diff --git a/0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch b/0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch
index 876d7bb6af89..2b73fdad2647 100644
--- a/0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch
+++ b/0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch
@@ -9,10 +9,10 @@ Subject: [PATCH] Add -p to copyprj to enable copying of prjconf
2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/osc/commandline.py b/osc/commandline.py
-index 76c9131fe498c8b03e2d8f739091c1930bfb09f4..c1a64f43c06bfdee5fbef369fab6b1b3860c2af0 100644
+index 481fb1c2090aa76e84aaac6e56bf74ab3f2cf811..ccecdc43acc57f69899fa328672a22a76c547a04 100644
--- a/osc/commandline.py
+++ b/osc/commandline.py
-@@ -3142,6 +3142,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -3416,6 +3416,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
help='replicate the history of each package.')
@cmdln.option('-o', '--make-older', action='store_true',
help='No idea')
@@ -21,7 +21,7 @@ index 76c9131fe498c8b03e2d8f739091c1930bfb09f4..c1a64f43c06bfdee5fbef369fab6b1b3
@cmdln.option('-r', '--re-sign', action='store_true',
help='re-sign the binaries')
@cmdln.option('-m', '--message', metavar='TEXT',
-@@ -3186,7 +3188,7 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -3460,7 +3462,7 @@ Please submit there instead, or use --nodevelproject to force direct submission.
withhistory = opts.with_history,
makeolder = opts.make_older,
resign = opts.re_sign,
@@ -31,10 +31,10 @@ index 76c9131fe498c8b03e2d8f739091c1930bfb09f4..c1a64f43c06bfdee5fbef369fab6b1b3
print("done cp")
print(r)
diff --git a/osc/core.py b/osc/core.py
-index 60137a067ead1b040c516b88c102827cdefd1414..5a04d7a76e3bd9efa73886529738c5b5f0a67638 100644
+index 83123b240217f6b02bae9447b471e424d2bc9266..e94dd8139d39f3d6979f6bfe03f5c58ed3b579ff 100644
--- a/osc/core.py
+++ b/osc/core.py
-@@ -5554,6 +5554,8 @@ def copy_prj(src_apiurl, src_project, dst_project,
+@@ -6007,6 +6007,8 @@ def copy_prj(src_apiurl, src_project, dst_project,
withhistory = False,
makeolder = False,
resign = False,
@@ -43,7 +43,7 @@ index 60137a067ead1b040c516b88c102827cdefd1414..5a04d7a76e3bd9efa73886529738c5b5
comment = None):
"""
Create a copy of a project.
-@@ -5575,6 +5577,9 @@ def copy_prj(src_apiurl, src_project, dst_project,
+@@ -6028,6 +6030,9 @@ def copy_prj(src_apiurl, src_project, dst_project,
query['comment'] = comment
if now:
query['nodelay'] = '1'
diff --git a/0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch b/0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch
index a6e0a0eac24b..61d624827120 100644
--- a/0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch
+++ b/0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch
@@ -14,10 +14,10 @@ Subject: [PATCH] Add support for --rebuild and --chroot-only in build.
2 files changed, 10 insertions(+)
diff --git a/osc/build.py b/osc/build.py
-index 3409714a19653df323886de26fe46c88f7194931..c2a50696bf3d1fc43ee74e6911918f41d72f146f 100644
+index d51b81c9cc66959d74194c48f2a6710649fd117f..cc6386da49aefb25e9cc3b88e6829039ac032953 100644
--- a/osc/build.py
+++ b/osc/build.py
-@@ -670,6 +670,12 @@ def main(apiurl, opts, argv):
+@@ -688,6 +688,12 @@ def main(apiurl, opts, argv):
buildargs.append('--norootforbuild')
if opts.clean:
buildargs.append('--clean')
@@ -31,10 +31,10 @@ index 3409714a19653df323886de26fe46c88f7194931..c2a50696bf3d1fc43ee74e6911918f41
buildargs.append('--no-checks')
if not opts.no_changelog:
diff --git a/osc/commandline.py b/osc/commandline.py
-index c1a64f43c06bfdee5fbef369fab6b1b3860c2af0..2225d5a4237d1f3763a61cd3a1d71afff50cbdb1 100644
+index ccecdc43acc57f69899fa328672a22a76c547a04..81171a3fa6530fd09d8c6e7235751dff8be3bbc7 100644
--- a/osc/commandline.py
+++ b/osc/commandline.py
-@@ -6365,6 +6365,10 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -6536,6 +6536,10 @@ Please submit there instead, or use --nodevelproject to force direct submission.
help='Copy overlay filesystem to buildroot after installing all RPMs .')
@cmdln.option('--noinit', '--no-init', action='store_true',
help='Skip initialization of build root and start with build immediately.')
diff --git a/0006-Add-architecture-and-scheduler-maps.patch b/0006-Add-architecture-and-scheduler-maps.patch
index d818fd4d25a2..e38914d086bb 100644
--- a/0006-Add-architecture-and-scheduler-maps.patch
+++ b/0006-Add-architecture-and-scheduler-maps.patch
@@ -13,10 +13,10 @@ command.
1 file changed, 4 insertions(+)
diff --git a/osc/util/packagequery.py b/osc/util/packagequery.py
-index a70a55686a8203e2eceb42da6a0dd7252d8d9c18..efbc869e0b840dc59a128535c94979f8564a5f3e 100644
+index 39356f5e6840d186f67dd52e10c86913ae8e60a5..df4f92bbe839ee3e954a29697152adfbe1c97ae7 100644
--- a/osc/util/packagequery.py
+++ b/osc/util/packagequery.py
-@@ -17,6 +17,10 @@ class PackageQueries(dict):
+@@ -21,6 +21,10 @@ class PackageQueries(dict):
# map debian and rpm arches to common obs arches
architectureMap = {'i386': ['i586', 'i686'], 'amd64': ['x86_64'], 'ppc64el': ['ppc64le'], 'armv6hl': ['armv6l'], 'armv7hl': ['armv7l']}
diff --git a/0007-Trap-any-kind-of-exception-during-plugin-parsing-eg-.patch b/0007-Trap-any-kind-of-exception-during-plugin-parsing-eg-.patch
deleted file mode 100644
index 9266e7c31dba..000000000000
--- a/0007-Trap-any-kind-of-exception-during-plugin-parsing-eg-.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
-From: Marko Lemmetty <marko.lemmetty@jollamobile.com>
-Date: Fri, 15 May 2020 15:44:22 +0300
-Subject: [PATCH] Trap any kind of exception during plugin parsing (eg IOError
- for a dangling symlink)
-
----
- osc/commandline.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/osc/commandline.py b/osc/commandline.py
-index 2225d5a4237d1f3763a61cd3a1d71afff50cbdb1..65d67066fe927a1e61aa4b0036d1e31e25d576f3 100644
---- a/osc/commandline.py
-+++ b/osc/commandline.py
-@@ -9389,7 +9389,7 @@ Please submit there instead, or use --nodevelproject to force direct submission.
- if (inspect.isfunction(data) and inspect.getmodule(data) == mod
- or inspect.ismodule(data)):
- setattr(self.__class__, name, data)
-- except (SyntaxError, NameError, ImportError) as e:
-+ except (SyntaxError, NameError, ImportError, IOError) as e:
- if (os.environ.get('OSC_PLUGIN_FAIL_IGNORE')):
- print("%s: %s\n" % (os.path.join(plugin_dir, extfile), e), file=sys.stderr)
- else:
diff --git a/0008-Fix-hdrmd5-check-of-downloaded-packages-from-DoD-rep.patch b/0008-Fix-hdrmd5-check-of-downloaded-packages-from-DoD-rep.patch
deleted file mode 100644
index 8a8baa378beb..000000000000
--- a/0008-Fix-hdrmd5-check-of-downloaded-packages-from-DoD-rep.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
-From: Daniel Mach <daniel.mach@suse.com>
-Date: Tue, 29 Mar 2022 09:59:08 +0200
-Subject: [PATCH] Fix hdrmd5 check of downloaded packages from DoD repos
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-(cherry picked from commit 8384a1fdff980590244c211024127542d08a9716)
-
-Re:
-openSUSE/osc#1016
-
-Signed-off-by: Björn Bidar <bjorn.bidar@jolla.com>
----
- osc/fetch.py | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/osc/fetch.py b/osc/fetch.py
-index 8a1c4e3466d26ce5f503dfd93c4049b1693d9d5b..9b34b002e531c01e478a571b7b349dd9657a01a6 100644
---- a/osc/fetch.py
-+++ b/osc/fetch.py
-@@ -256,7 +256,9 @@ class Fetcher:
- # if the checksum of the downloaded package doesn't match,
- # delete it and mark it for downloading from the API
- hdrmd5 = packagequery.PackageQuery.queryhdrmd5(i.fullfilename)
-- if not hdrmd5 or hdrmd5 != i.hdrmd5:
-+ # packages with hdrmd5 == 'd0d...' come from 'download on demand' repos
-+ # and their checksum is not known to the server yet, so we skip their checksum check
-+ if not hdrmd5 or (hdrmd5 != i.hdrmd5 and i.hdrmd5 != 'd0d0d0d0d0d0d0d0d0d0d0d0d0d0d0d0'):
- print('%s/%s: attempting download from api, since the hdrmd5 did not match - %s != %s'
- % (i.project, i.name, hdrmd5, i.hdrmd5))
- os.unlink(i.fullfilename)
diff --git a/PKGBUILD b/PKGBUILD
index 679c701f1db0..c4c17cc7d746 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,19 +32,15 @@ source=("https://github.com/openSUSE/${pkgname}/archive/${pkgver}.tar.gz"
0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch
0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch
0006-Add-architecture-and-scheduler-maps.patch
- 0007-Trap-any-kind-of-exception-during-plugin-parsing-eg-.patch
- 0008-Fix-hdrmd5-check-of-downloaded-packages-from-DoD-rep.patch
)
sha256sums=('02bb2166fbda06babbcd60e67437ba83f9032c12c41529325e49d0663cb11aa5'
'2b045e03d2fdce12683ceb9792d491a32f00b256045456412e7bc18c8726218a'
- '4f9d5a4aa7d84e0237a3ba633004c7472d873450c769a666f6dde3b7929f3f88'
- 'c360ca8425f9c90d94f02914a561b7f7d85887bf935a5cfdcb868ee1a7d10f29'
- '7a9dfcec1ee495735188aadd8393e914783a0cc2bca095599e014c9e934954dc'
- '1e38593b0447bdaf1fae936d5bb8913f90352aa62ca5a3f3715600b20bba58ed'
- 'b8ae40c4babcbe9361c762df817021ab290d42d76faad822b7d45f8462f75654'
- '5564c4cdaed550ddfe05ce74e96448c9232181b4f6fc637c933642eb221461f2'
- '59eb84c63d3f847cc54dffa98855ce4737959edb908f84b7fedc559d60df0196'
- 'a4b0aa983eba58e7239f057368cab39b4468da6dd475f3f8e6243f656492289c')
+ '7478f2297ac87090979d19fd55d539aa1000792a8858796ba7c7f239b45d9ef6'
+ 'de9cd536d5b294b5ec702d6e57f014928e67f3678c1dd9ea2a7d986c2506469b'
+ '0ac6241d05061e85f4b7d38472180c138e266bf968d6c074105d7e528f44e336'
+ '1573dd86844d1eebeb93ff092f6345928fad4611f7634dadb17fcc579de4dc32'
+ '8ac9d5760333f76428f85ff6ee8cffabc12678be703ba285f708015d95039eb4'
+ 'eae5f978b8385db3acae46df96fc4973f306c4a640389165a8ac54469d370e5b')
prepare() {
# Add 'Arch_Core' and 'Arch_Extra' as osc build targets