summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--0001-Add-sb2install-support-to-osc.patch4
-rw-r--r--0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch8
-rw-r--r--0003-Support-synchronous-copyproj.patch12
-rw-r--r--0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch12
-rw-r--r--0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch8
-rw-r--r--0006-Add-architecture-and-scheduler-maps.patch2
-rw-r--r--0007-Trap-any-kind-of-exception-during-plugin-parsing-eg-.patch4
-rw-r--r--PKGBUILD18
9 files changed, 45 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c13ce325688..4bfe67958b5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun May 15 09:28:12 UTC 2022
+# Tue May 24 21:18:22 UTC 2022
pkgbase = osc
pkgdesc = Command line client for the openSUSE Build Service
- pkgver = 0.177.0
+ pkgver = 0.178.0
pkgrel = 1
url = https://github.com/openSUSE/osc
arch = any
@@ -21,7 +21,7 @@ pkgbase = osc
conflicts = zsh-completion-osc
replaces = osc-bash-completion
replaces = zsh-completion-osc
- source = https://github.com/openSUSE/osc/archive/0.177.0.tar.gz
+ source = https://github.com/openSUSE/osc/archive/0.178.0.tar.gz
source = _osc
source = 0001-Add-sb2install-support-to-osc.patch
source = 0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch
@@ -30,15 +30,15 @@ pkgbase = osc
source = 0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch
source = 0006-Add-architecture-and-scheduler-maps.patch
source = 0007-Trap-any-kind-of-exception-during-plugin-parsing-eg-.patch
- sha256sums = 3dfeb9944f78f17a509966dd1dd89d177dd0d87856a6c8f7556d68e07521d1d4
+ sha256sums = c616bf2824422c0a04f9bce0f53f34ffbbcf192e185b85c09767c59389befce9
sha256sums = 2b045e03d2fdce12683ceb9792d491a32f00b256045456412e7bc18c8726218a
- sha256sums = ed6607e642695028740efb53bfa1cb3e2efd97f1694e4a8efacf224b949d0962
- sha256sums = d09810c556e3170fdd0a058d090a6c3261af4e2032b6cf96fe63cef12c1e10e2
- sha256sums = 1d3b37f662a74a1d070beb1cfe4cb0c1f2b1bf78503a6d7b69e2a3d46e516a4e
- sha256sums = 7a68dc9b077523679b96b2a0520efb67d71fdcbf1d94ed6be3e06c2bfb768604
- sha256sums = 8843a1c96702d18da0a029504990493d3a4417663916e83f21d96b2cee871c81
- sha256sums = 68ecfb6f85bf34730191ef658f91cc29c2d2872ed0b0d2f814b3673e0841527d
- sha256sums = 361bf935f382cf9ab34bd8e29c4f090c457293f97b705509997e2916aa17713b
+ sha256sums = 8e1b7add8e1ac281c4d4064cb76f33a23e1d0b5b1302e837d8e63fbfa76688ef
+ sha256sums = 3b4bed449e93d65f1d9bf8bd679f6d64951cfbd1f635cd839898606e212f3b64
+ sha256sums = 33eb52d9b2c05c028f5f721ebcde47f49debd7af2623a60391f525ba96716b20
+ sha256sums = f49428718c638d6b04ed09d01f87b16c562a9d72eea9c58dd763ac5a9b8bd3e4
+ sha256sums = bc7fa0af1c354ba090f550b9a29bde799e398cb523db321844e7338e185c4294
+ sha256sums = 007616a35f4ed9ac1f2414cd46fff64961c8ec81ad7987d464656e4a0f426686
+ sha256sums = dfd28310db92c17440a8987322651dfb9cfd29de04ce398f856ee634eebaa5ec
pkgname = osc
diff --git a/0001-Add-sb2install-support-to-osc.patch b/0001-Add-sb2install-support-to-osc.patch
index c87daa07bfc1..a2bd1b4c9c15 100644
--- a/0001-Add-sb2install-support-to-osc.patch
+++ b/0001-Add-sb2install-support-to-osc.patch
@@ -8,7 +8,7 @@ Subject: [PATCH] Add sb2install support to osc
1 file changed, 3 insertions(+)
diff --git a/osc/build.py b/osc/build.py
-index c47f6b2c..d2bdb888 100644
+index 4f248b6ff025eaee63bbc95a2b60fc07dee4812c..2aa09b84a6e6cc9744125a0f3e0cad505152a022 100644
--- a/osc/build.py
+++ b/osc/build.py
@@ -197,6 +197,7 @@ class Buildinfo:
@@ -27,7 +27,7 @@ index c47f6b2c..d2bdb888 100644
]:
self.mp[i] = node.get(i)
-@@ -1357,6 +1359,7 @@ def main(apiurl, opts, argv):
+@@ -1381,6 +1383,7 @@ def main(apiurl, opts, argv):
rpmlist.append('preinstall: ' + ' '.join(bi.preinstall_list) + '\n')
rpmlist.append('vminstall: ' + ' '.join(bi.vminstall_list) + '\n')
diff --git a/0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch b/0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch
index 317202178e3e..6eb12d5db5fb 100644
--- a/0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch
+++ b/0002-Support-osc-copyprj-in-api-by-Islam-Amer-usage-osc-c.patch
@@ -13,10 +13,10 @@ Subject: [PATCH] Support 'osc copyprj' in api by Islam Amer usage: osc copyprj
2 files changed, 81 insertions(+)
diff --git a/osc/commandline.py b/osc/commandline.py
-index bb0528a9..eb04d59d 100644
+index 9180f9256b9351e24667be7b51c115085272a859..b5ce2169e384c6203583e960a20b660be199fa6c 100644
--- a/osc/commandline.py
+++ b/osc/commandline.py
-@@ -3170,6 +3170,59 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -3203,6 +3203,59 @@ Please submit there instead, or use --nodevelproject to force direct submission.
break
sys.stdout.write(decode_it(buf))
@@ -77,10 +77,10 @@ index bb0528a9..eb04d59d 100644
@cmdln.option('-m', '--message', metavar='TEXT',
help='specify message TEXT')
diff --git a/osc/core.py b/osc/core.py
-index 5e1d3196..0e6d90e6 100644
+index 2d07c7f7d54ea32a2b9219efa0137fb978c365be..93aa7dd20f6dd71f7e934534896d3330fffab4fc 100644
--- a/osc/core.py
+++ b/osc/core.py
-@@ -5560,6 +5560,34 @@ def copy_pac(src_apiurl, src_project, src_package,
+@@ -5620,6 +5620,34 @@ def copy_pac(src_apiurl, src_project, src_package,
raise oscerr.APIError('failed to copy: %s' % ', '.join(todo))
return 'Done.'
diff --git a/0003-Support-synchronous-copyproj.patch b/0003-Support-synchronous-copyproj.patch
index 27099da9c086..c148ca4870ca 100644
--- a/0003-Support-synchronous-copyproj.patch
+++ b/0003-Support-synchronous-copyproj.patch
@@ -9,10 +9,10 @@ Subject: [PATCH] Support synchronous copyproj
2 files changed, 7 insertions(+)
diff --git a/osc/commandline.py b/osc/commandline.py
-index eb04d59d..2063bfe5 100644
+index b5ce2169e384c6203583e960a20b660be199fa6c..53d5235e63424cfe6302a554027f2656199c70a2 100644
--- a/osc/commandline.py
+++ b/osc/commandline.py
-@@ -3172,6 +3172,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -3205,6 +3205,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
@cmdln.option('-b', '--with-binaries', action='store_true',
help='copy the built binaries over to avoid a rebuild')
@@ -21,7 +21,7 @@ index eb04d59d..2063bfe5 100644
@cmdln.option('-H', '--with-history', action='store_true',
help='replicate the history of each package.')
@cmdln.option('-o', '--make-older', action='store_true',
-@@ -3189,6 +3191,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -3222,6 +3224,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
The user must be able to create DESTPRJ
@@ -30,7 +30,7 @@ index eb04d59d..2063bfe5 100644
usage:
osc copyprj SOURCEPRJ DESTPRJ
${cmd_option_list}
-@@ -3219,6 +3223,7 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -3252,6 +3256,7 @@ Please submit there instead, or use --nodevelproject to force direct submission.
withhistory = opts.with_history,
makeolder = opts.make_older,
resign = opts.re_sign,
@@ -39,10 +39,10 @@ index eb04d59d..2063bfe5 100644
print("done cp")
print(r)
diff --git a/osc/core.py b/osc/core.py
-index 0e6d90e6..42923737 100644
+index 93aa7dd20f6dd71f7e934534896d3330fffab4fc..3bc09fb096eebe391831ffaf9db2b1ddbde031ff 100644
--- a/osc/core.py
+++ b/osc/core.py
-@@ -5584,6 +5584,8 @@ def copy_prj(src_apiurl, src_project, dst_project,
+@@ -5644,6 +5644,8 @@ def copy_prj(src_apiurl, src_project, dst_project,
query['resign'] = '1'
if comment:
query['comment'] = comment
diff --git a/0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch b/0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch
index 547acc6da228..1fdc03ef1f7f 100644
--- a/0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch
+++ b/0004-Add-p-to-copyprj-to-enable-copying-of-prjconf.patch
@@ -9,10 +9,10 @@ Subject: [PATCH] Add -p to copyprj to enable copying of prjconf
2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/osc/commandline.py b/osc/commandline.py
-index 2063bfe5..bde97403 100644
+index 53d5235e63424cfe6302a554027f2656199c70a2..6cb15c71731ea233607a373a109d2f5770aa96d0 100644
--- a/osc/commandline.py
+++ b/osc/commandline.py
-@@ -3178,6 +3178,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -3211,6 +3211,8 @@ Please submit there instead, or use --nodevelproject to force direct submission.
help='replicate the history of each package.')
@cmdln.option('-o', '--make-older', action='store_true',
help='No idea')
@@ -21,7 +21,7 @@ index 2063bfe5..bde97403 100644
@cmdln.option('-r', '--re-sign', action='store_true',
help='re-sign the binaries')
@cmdln.option('-m', '--message', metavar='TEXT',
-@@ -3223,7 +3225,7 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -3256,7 +3258,7 @@ Please submit there instead, or use --nodevelproject to force direct submission.
withhistory = opts.with_history,
makeolder = opts.make_older,
resign = opts.re_sign,
@@ -31,10 +31,10 @@ index 2063bfe5..bde97403 100644
print("done cp")
print(r)
diff --git a/osc/core.py b/osc/core.py
-index 42923737..84ef3b79 100644
+index 3bc09fb096eebe391831ffaf9db2b1ddbde031ff..a114309faa43a8024c3987e5642d7c9ecdc423c9 100644
--- a/osc/core.py
+++ b/osc/core.py
-@@ -5565,6 +5565,8 @@ def copy_prj(src_apiurl, src_project, dst_project,
+@@ -5625,6 +5625,8 @@ def copy_prj(src_apiurl, src_project, dst_project,
withhistory = False,
makeolder = False,
resign = False,
@@ -43,7 +43,7 @@ index 42923737..84ef3b79 100644
comment = None):
"""
Create a copy of a project.
-@@ -5586,6 +5588,9 @@ def copy_prj(src_apiurl, src_project, dst_project,
+@@ -5646,6 +5648,9 @@ def copy_prj(src_apiurl, src_project, dst_project,
query['comment'] = comment
if now:
query['nodelay'] = '1'
diff --git a/0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch b/0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch
index 7f6824dd4179..ac2c9b5f389b 100644
--- a/0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch
+++ b/0005-Add-support-for-rebuild-and-chroot-only-in-build.-re.patch
@@ -14,10 +14,10 @@ Subject: [PATCH] Add support for --rebuild and --chroot-only in build.
2 files changed, 10 insertions(+)
diff --git a/osc/build.py b/osc/build.py
-index d2bdb888..8931d8a8 100644
+index 2aa09b84a6e6cc9744125a0f3e0cad505152a022..10fa9d7660e94cb99983651e871711c3bcf55f3c 100644
--- a/osc/build.py
+++ b/osc/build.py
-@@ -667,6 +667,12 @@ def main(apiurl, opts, argv):
+@@ -687,6 +687,12 @@ def main(apiurl, opts, argv):
buildargs.append('--norootforbuild')
if opts.clean:
buildargs.append('--clean')
@@ -31,10 +31,10 @@ index d2bdb888..8931d8a8 100644
buildargs.append('--no-checks')
if not opts.no_changelog:
diff --git a/osc/commandline.py b/osc/commandline.py
-index bde97403..d72467f2 100644
+index 6cb15c71731ea233607a373a109d2f5770aa96d0..8600914f08641941c18ecf49565a5ee04ee28b90 100644
--- a/osc/commandline.py
+++ b/osc/commandline.py
-@@ -6533,6 +6533,10 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -6581,6 +6581,10 @@ Please submit there instead, or use --nodevelproject to force direct submission.
help='Copy overlay filesystem to buildroot after installing all RPMs .')
@cmdln.option('--noinit', '--no-init', action='store_true',
help='Skip initialization of build root and start with build immediately.')
diff --git a/0006-Add-architecture-and-scheduler-maps.patch b/0006-Add-architecture-and-scheduler-maps.patch
index 017f32eb57f3..130c097e3a2e 100644
--- a/0006-Add-architecture-and-scheduler-maps.patch
+++ b/0006-Add-architecture-and-scheduler-maps.patch
@@ -13,7 +13,7 @@ command.
1 file changed, 4 insertions(+)
diff --git a/osc/util/packagequery.py b/osc/util/packagequery.py
-index 93a439b5..c3aa2c0d 100644
+index 93a439b5da17c718ff664a37e7b6c4d03082532c..c3aa2c0dec5377be4edf00fab6e481b1272fbbc5 100644
--- a/osc/util/packagequery.py
+++ b/osc/util/packagequery.py
@@ -18,6 +18,10 @@ class PackageQueries(dict):
diff --git a/0007-Trap-any-kind-of-exception-during-plugin-parsing-eg-.patch b/0007-Trap-any-kind-of-exception-during-plugin-parsing-eg-.patch
index 1581b07c65b7..b7f1ede729b9 100644
--- a/0007-Trap-any-kind-of-exception-during-plugin-parsing-eg-.patch
+++ b/0007-Trap-any-kind-of-exception-during-plugin-parsing-eg-.patch
@@ -9,10 +9,10 @@ Subject: [PATCH] Trap any kind of exception during plugin parsing (eg IOError
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/osc/commandline.py b/osc/commandline.py
-index d72467f2..7c919616 100644
+index 8600914f08641941c18ecf49565a5ee04ee28b90..3e10f0e2f74a42b7cf0580836a1892d6d6c126a7 100644
--- a/osc/commandline.py
+++ b/osc/commandline.py
-@@ -9617,7 +9617,7 @@ Please submit there instead, or use --nodevelproject to force direct submission.
+@@ -9666,7 +9666,7 @@ Please submit there instead, or use --nodevelproject to force direct submission.
if (inspect.isfunction(data) and inspect.getmodule(data) == mod
or inspect.ismodule(data)):
setattr(self.__class__, name, data)
diff --git a/PKGBUILD b/PKGBUILD
index 9265301bb15b..811dbe840156 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor : Patrick McCarty <pnorcks at gmail dot com>
pkgname=osc
-pkgver=0.177.0
+pkgver=0.178.0
pkgrel=1
pkgdesc="Command line client for the openSUSE Build Service"
arch=(any)
@@ -34,15 +34,15 @@ source=("https://github.com/openSUSE/${pkgname}/archive/${pkgver}.tar.gz"
0006-Add-architecture-and-scheduler-maps.patch
0007-Trap-any-kind-of-exception-during-plugin-parsing-eg-.patch
)
-sha256sums=('3dfeb9944f78f17a509966dd1dd89d177dd0d87856a6c8f7556d68e07521d1d4'
+sha256sums=('c616bf2824422c0a04f9bce0f53f34ffbbcf192e185b85c09767c59389befce9'
'2b045e03d2fdce12683ceb9792d491a32f00b256045456412e7bc18c8726218a'
- 'ed6607e642695028740efb53bfa1cb3e2efd97f1694e4a8efacf224b949d0962'
- 'd09810c556e3170fdd0a058d090a6c3261af4e2032b6cf96fe63cef12c1e10e2'
- '1d3b37f662a74a1d070beb1cfe4cb0c1f2b1bf78503a6d7b69e2a3d46e516a4e'
- '7a68dc9b077523679b96b2a0520efb67d71fdcbf1d94ed6be3e06c2bfb768604'
- '8843a1c96702d18da0a029504990493d3a4417663916e83f21d96b2cee871c81'
- '68ecfb6f85bf34730191ef658f91cc29c2d2872ed0b0d2f814b3673e0841527d'
- '361bf935f382cf9ab34bd8e29c4f090c457293f97b705509997e2916aa17713b')
+ '8e1b7add8e1ac281c4d4064cb76f33a23e1d0b5b1302e837d8e63fbfa76688ef'
+ '3b4bed449e93d65f1d9bf8bd679f6d64951cfbd1f635cd839898606e212f3b64'
+ '33eb52d9b2c05c028f5f721ebcde47f49debd7af2623a60391f525ba96716b20'
+ 'f49428718c638d6b04ed09d01f87b16c562a9d72eea9c58dd763ac5a9b8bd3e4'
+ 'bc7fa0af1c354ba090f550b9a29bde799e398cb523db321844e7338e185c4294'
+ '007616a35f4ed9ac1f2414cd46fff64961c8ec81ad7987d464656e4a0f426686'
+ 'dfd28310db92c17440a8987322651dfb9cfd29de04ce398f856ee634eebaa5ec')
prepare() {
# Add 'Arch_Core' and 'Arch_Extra' as osc build targets