summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66e70d0e7505..170ab9c7995e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oscar-git
pkgdesc = Open-source, cross platform, sleep tracking software with a focus on monitoring CPAP treatment. Fork of the sleepyhead project.
- pkgver = ..r3245.aaaaef0d
+ pkgver = ..r3560.d88084a3
pkgrel = 1
url = https://gitlab.com/pholy/OSCAR-code
arch = i686
@@ -10,6 +10,7 @@ pkgbase = oscar-git
makedepends = glu
depends = qt5-tools
depends = qt5-serialport
+ optdepends = qt5-wayland
provides = oscar
source = git+https://gitlab.com/pholy/OSCAR-code.git
source = oscar.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 5094df49756d..aa1023fc33a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Jason Lenz <Jason@Lenzplace.org>
_pkgname=oscar
pkgname=oscar-git
-pkgver=..r3245.aaaaef0d
+pkgver=..r3761.aec02b14
pkgrel=1
pkgdesc="Open-source, cross platform, sleep tracking software with a focus on monitoring CPAP treatment. Fork of the sleepyhead project."
arch=('i686' 'x86_64')
@@ -13,6 +13,9 @@ depends=(
'qt5-tools'
'qt5-serialport'
)
+optdepends=(
+ 'qt5-wayland'
+)
makedepends=(
'git'
'glu'
@@ -44,17 +47,8 @@ package() {
install -Dm644 $srcdir/OSCAR-code/oscar/icons/logo-lg.png $pkgdir/usr/share/oscar/icon.png
install -Dm644 $srcdir/oscar.desktop $pkgdir/usr/share/applications/oscar.desktop
-cp -dpr --no-preserve=ownership $srcdir/OSCAR-code/oscar/Html $pkgdir/usr/share/oscar
-cp -dpr --no-preserve=ownership $srcdir/OSCAR-code/oscar/Translations $pkgdir/usr/share/oscar
-
-# find $srcdir/OSCAR-code/oscar/Html -type d -exec install -d {,$pkgdir/usr/share/oscar/Html/}{} \;
-# find $srcdir/OSCAR-code/oscar/Html -type f -exec install -D -m 644 {,$pkgdir/usr/share/oscar/Html/}{} \;
-
-# find $srcdir/OSCAR-code/oscar/Help -type d -exec install -d {,$pkgdir/usr/share/oscar/Help/}{} \;
-# find $srcdir/OSCAR-code/oscar/Help -type f -exec install -D -m 644 {,$pkgdir/usr/share/oscar/Help/}{} \;
-#
-# find $srcdir/OSCAR-code/oscar/Translations -type d -exec install -d {,$pkgdir/usr/share/oscar/Translations/}{} \;
-# find $srcdir/OSCAR-code/oscar/Translations -type f -exec install -D -m 644 {,$pkgdir/usr/share/oscar/Translations/}{} \;
+ cp -dpr --no-preserve=ownership $srcdir/OSCAR-code/oscar/Html $pkgdir/usr/share/oscar
+ cp -dpr --no-preserve=ownership $srcdir/OSCAR-code/oscar/Translations $pkgdir/usr/share/oscar
}
# vim:set ts=2 sw=2 et: