summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a561be8a7de..2c3b32e647bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osmo-hlr-git
- pkgdesc = Subscriber database and authentication key store of an Osmocom 2G/3G network
- pkgver = 1.0.0.r6.gf9cf180
+ pkgdesc = Osmocom HLR for GSUP protocol towards OsmoSGSN and OsmoCSCN
+ pkgver = 1.7.0.r8.gac1365fd
pkgrel = 1
url = https://osmocom.org/projects/osmo-hlr
arch = i686
@@ -13,13 +13,11 @@ pkgbase = osmo-hlr-git
depends = libosmo-abis
depends = talloc
depends = sqlite
- depends = libdbi
- depends = libdbi-drivers
- provides = osmo-hlr
+ provides = libosmo-gsup-client.so=0-64
+ provides = libosmo-mslookup.so=1-64
conflicts = osmo-hlr
backup = etc/osmocom/osmo-hlr.cfg
- source = git+https://git.osmocom.org/osmo-hlr
+ source = git+https://gitea.osmocom.org/cellular-infrastructure/osmo-hlr.git
sha256sums = SKIP
pkgname = osmo-hlr-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 6ffbf8bfbbe3..cdc3506e1557 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
-# Maintainer: Josef Miegl <josef@miegl.cz>
+# Maintainer: Vadim Yanitskiy <fixeria@osmocom.org>
+# Contributor: Josef Miegl <josef@miegl.cz>
pkgname=osmo-hlr-git
-pkgver=1.0.0.r6.gf9cf180
+pkgver=1.7.0.r8.gac1365fd
pkgrel=1
-pkgdesc="Subscriber database and authentication key store of an Osmocom 2G/3G network"
+pkgdesc="Osmocom HLR for GSUP protocol towards OsmoSGSN and OsmoCSCN"
url="https://osmocom.org/projects/osmo-hlr"
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=(GPL)
-depends=('libosmocore' 'libosmo-abis' 'talloc' 'sqlite' 'libdbi' 'libdbi-drivers')
+depends=('libosmocore' 'libosmo-abis' 'talloc' 'sqlite')
makedepends=('git')
-provides=("${pkgname%-git}")
+provides=('libosmo-gsup-client.so=0-64'
+ 'libosmo-mslookup.so=1-64')
conflicts=("${pkgname%-git}")
backup=('etc/osmocom/osmo-hlr.cfg')
-source=("git+https://git.osmocom.org/${pkgname%-git}")
+source=("git+https://gitea.osmocom.org/cellular-infrastructure/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
@@ -27,7 +29,9 @@ prepare() {
build() {
cd "${pkgname%-git}"
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var
make
}