summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 24 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9090368de9e..d2c8d170f3b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Jun 25 18:39:04 UTC 2017
pkgbase = osmupdate
- pkgdesc = a tool to download and cumulate .osc OsmChange files of different categories (minutely, hourly, daily)
- pkgver = 0.4.1
+ pkgdesc = Download, manipulate and apply OpenStreetMap changefiles
+ pkgver = 0.4.4
pkgrel = 1
url = http://wiki.openstreetmap.org/wiki/Osmupdate
arch = i686
arch = x86_64
- license = gpl
- depends = glibc
+ license = AGPL3
+ depends = osmconvert
+ depends = wget
+ optdepends = gzip: to write gzip compressed files
source = http://m.m.i24.cc/osmupdate.c
- md5sums = 740162c2400a5e8c78a1bd9a79993242
+ sha256sums = 54760538cd325efa763a7445d15b4dde140aeafed612f626b31f52a510d6e14c
pkgname = osmupdate
diff --git a/PKGBUILD b/PKGBUILD
index 4f9b3d2553b5..f31cb105c191 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
-# Maintainer: Jose Riha <jose1711 [at] gmail (dot) com>
+# Maintainer: Jeremy "Ichimonji10" Audet <ichimonji10 at gmail dot com>
+# Contributor: Jose Riha <jose1711 [at] gmail (dot) com>
pkgname=osmupdate
-pkgver=0.4.1
+pkgver=0.4.4
pkgrel=1
-pkgdesc="a tool to download and cumulate .osc OsmChange files of different categories (minutely, hourly, daily)"
-arch=('i686' 'x86_64')
-url="http://wiki.openstreetmap.org/wiki/Osmupdate"
-license=("gpl")
-depends=('glibc')
-source=("http://m.m.i24.cc/osmupdate.c")
-md5sums=('740162c2400a5e8c78a1bd9a79993242')
+pkgdesc='Download, manipulate and apply OpenStreetMap changefiles'
+url='http://wiki.openstreetmap.org/wiki/Osmupdate'
+license=(AGPL3)
+arch=(i686 x86_64)
+depends=(osmconvert wget)
+optdepends=('gzip: to write gzip compressed files')
+source=('http://m.m.i24.cc/osmupdate.c')
+sha256sums=('54760538cd325efa763a7445d15b4dde140aeafed612f626b31f52a510d6e14c')
build() {
-cd $srcdir
-gcc -oosmupdate osmupdate.c
+ gcc -O3 -oosmupdate osmupdate.c
}
package() {
-install -Dm755 $srcdir/osmupdate $pkgdir/usr/bin/osmupdate
+ install -Dm755 osmupdate "${pkgdir}/usr/bin/osmupdate"
}
+
+# vim:set ts=2 sw=2 et: