summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
-rw-r--r--osticket.install39
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a733d6101fd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = osticket
+ pkgdesc = A widely-used open source support ticket system.
+ pkgver = 1.9.8.1
+ pkgrel = 1
+ url = http://www.osticket.com/
+ install = osticket.install
+ arch = any
+ license = GPL
+ makedepends = unzip
+ depends = php>=4.3.10
+ depends = php-apache>=4.3.10
+ depends = mysql>=4.4.0
+ source = http://osticket.com/sites/default/files/download/osTicket-v1.9.8.1.zip
+ md5sums = 35ae9eebd702833e67cab06f77723ece
+
+pkgname = osticket
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aebb24e86b8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+## PKGBUILD
+# Maintainer: Sigmund Vestergaard <sigmundv at gmail dot com>
+# Contributor: Mark Doe <mark.doe.priv@gmail.com>
+##
+#
+pkgname=osticket
+pkgver=1.9.8.1
+pkgrel=1
+pkgdesc='A widely-used open source support ticket system.'
+arch=('any')
+url='http://www.osticket.com/'
+license=('GPL')
+depends=('php>=4.3.10' 'php-apache>=4.3.10' 'mysql>=4.4.0')
+makedepends=('unzip')
+install="${pkgname}.install"
+source=("http://osticket.com/sites/default/files/download/osTicket-v$pkgver.zip")
+md5sums=('35ae9eebd702833e67cab06f77723ece')
+
+package() {
+ install -d ${pkgdir}/srv/http/osticket
+ sleep 1
+ echo "Extracting files"
+ sleep 1
+ unzip -d ${pkgdir}/srv/http/osticket "osTicket-v$pkgver"
+
+ # fix permissions (probably needs to get included upstream)
+ find ${pkgdir}/srv/http/$pkgname -type f -exec chmod 0664 {} \;
+ find ${pkgdir}/srv/http/$pkgname -type d -exec chmod 0775 {} \;
+}
diff --git a/osticket.install b/osticket.install
new file mode 100644
index 000000000000..e8edb9c40d87
--- /dev/null
+++ b/osticket.install
@@ -0,0 +1,39 @@
+post_install() {
+ echo -n "adding http system group... "
+ groupadd http
+ echo "done."
+ chgrp -R http /srv/http/osticket
+ post_upgrade
+ cat << 'EOM'
+
+==> NOTES:
+
+ -> In order to use osticket, you have to be in the 'http' group
+
+ -> Setup Apache, MySQL and PHP, following 'http://wiki.archlinux.org/index.php/LAMP'
+
+ -> To finish the installation process, navigate to 'http://localhost/osticket'
+ with your web browser.
+
+==> Need help installing osTicket?
+
+ -> Read Documentation at 'http://osticket.com/wiki/Main_Page'
+
+EOM
+}
+
+post_upgrade() {
+ true
+}
+
+pre_remove() {
+ true
+}
+
+post_remove() {
+ true
+}
+
+op=$1
+shift
+$op $*