summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 24 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a08775c663bc..63cff9048cb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = osx-el-capitan-theme-git
- pkgdesc = Theme mimics OS X 10.11 El Capitan for GTK3 and some DEs (GNOME Shell, Xfce, Cinnamon)
- pkgver = v2.0
- pkgrel = 0
- url = https://github.com/Elbullazul/OS-X-El-Capitan
+ pkgdesc = Theme mimics OS X 10.12 macOS Sierra, formaly osx-el-capitan-theme, for GTK3 and some DEs (GNOME Shell, Xfce, Cinnamon)
+ pkgver = 10.9.r8.g3dff454
+ pkgrel = 1
+ url = https://github.com/Elbullazul/macOS-Sierra
arch = any
license = GPL3
+ makedepends = git
depends = gtk3>=3.18
depends = gtk-engine-murrine
depends = gtk-engines
optdepends = gnome-themes-standard: Required for the GTK3 theme
conflicts = gnome-shell-theme-osx-el-capitan
- source = https://github.com/B00merang-Project/macOS-Sierra/archive/master.zip
- sha256sums = f1f673a515442a114236479fb6463859c1b6b4e8dc8da6e4cfbd91453bd57443
+ source = git+https://github.com/B00merang-Project/macOS-Sierra
+ sha256sums = SKIP
pkgname = osx-el-capitan-theme-git
diff --git a/PKGBUILD b/PKGBUILD
index b1ae1912b80b..f2fd8dd3b607 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,31 @@
# Maintainer: joel <aullidolunar at gmai1 d0t c0m>
# Maintainer: orumin <dev@orum.in>
-_gitname=OS-X-El-Capitan
+_gitname=macOS-Sierra
+
pkgname=osx-el-capitan-theme-git
-pkgdesc="Theme mimics OS X 10.11 El Capitan for GTK3 and some DEs (GNOME Shell, Xfce, Cinnamon)"
-pkgver=v2.0
-pkgrel=0
+pkgdesc="Theme mimics OS X 10.12 macOS Sierra, formaly osx-el-capitan-theme, for GTK3 and some DEs (GNOME Shell, Xfce, Cinnamon)"
+pkgver=10.9.r8.g3dff454
+pkgrel=1
arch=('any')
url="https://github.com/Elbullazul/${_gitname}"
-source=('https://github.com/B00merang-Project/macOS-Sierra/archive/master.zip')
+source=(git+https://github.com/B00merang-Project/${_gitname})
+makedepends=('git')
depends=('gtk3>=3.18' 'gtk-engine-murrine' 'gtk-engines')
optdepends=('gnome-themes-standard: Required for the GTK3 theme')
license=('GPL3')
conflicts=('gnome-shell-theme-osx-el-capitan')
-sha256sums=('f1f673a515442a114236479fb6463859c1b6b4e8dc8da6e4cfbd91453bd57443')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
package() {
mkdir -p "$pkgdir/usr/share/backgrounds"
- cd "$srcdir/macOS-Sierra-master"
- mv 'Wallpaper.jpg' "$pkgdir/usr/share/backgrounds"
- find . -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/themes/OS-X-El-Capitan/{}" \;
+ cd "$srcdir/$_gitname"
+ mv 'Wallpaper.jpg' "$pkgdir/usr/share/backgrounds"
+ # Keep compatibility with old name
+ find . -type f -not -path './.git/*' -exec install -Dm644 '{}' "$pkgdir/usr/share/themes/OS-X-El-Capitan/{}" \;
}