summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD38
-rw-r--r--otf.install16
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ecb08b3542e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = otf-fira-code-onum-patch
+ pkgdesc = Fira Code: monospaced font with programming ligatures fork to have ligatures with old-style num activated as well.
+ pkgver = 1.206.r13.gbfe9f38
+ pkgrel = 1
+ url = https://github.com/paradoxxxzero/FiraCode.git
+ install = otf.install
+ arch = any
+ license = custom:OFL
+ makedepends = git
+ depends = fontconfig
+ depends = xorg-font-utils
+ provides = otf-fira-code=1.206
+ conflicts = otf-fira-code
+ source = git+https://github.com/paradoxxxzero/FiraCode.git
+ source = otf.install
+ md5sums = SKIP
+ md5sums = 9b9dbd9712ac6fefe896f704609b659c
+
+pkgname = otf-fira-code-onum-patch
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..518cc24b87d0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+# Ignore packages, build directories
+*.tar.xz
+FiraCode/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..798e38cde4ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Mounier Florian <paradoxxx.zero@gmail.com>
+# Forked from otf-fira-code-git from James Zhu <james.zhu.engineer@gmail.com>
+
+pkgname=otf-fira-code-onum-patch
+pkgver=1.206.r13.gbfe9f38
+pkgrel=1
+pkgdesc="Fira Code: monospaced font with programming ligatures fork to have ligatures with old-style num activated as well."
+arch=('any')
+url='https://github.com/paradoxxxzero/FiraCode.git'
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-font-utils')
+provides=('otf-fira-code=1.206')
+conflicts=('otf-fira-code')
+makedepends=('git')
+install=otf.install
+source=('git+https://github.com/paradoxxxzero/FiraCode.git' 'otf.install')
+md5sums=('SKIP'
+ '9b9dbd9712ac6fefe896f704609b659c')
+
+_gitname=FiraCode
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+
+ local weights=('Regular' 'Bold' 'Light' 'Medium' 'Retina')
+ local font='FiraCode'
+
+ for weight in ${weights[*]}; do
+ local name="${font}-${weight}.otf"
+ install -Dm644 "distr/otf/$name" "$pkgdir/usr/share/fonts/OTF/$name"
+ done
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/otf.install b/otf.install
new file mode 100644
index 000000000000..487a592a9ad4
--- /dev/null
+++ b/otf.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -s
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+