summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD43
-rw-r--r--fonts.install11
-rw-r--r--use-python2.patch9
4 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85176d68e72e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = otf-hasklig-git
+ pkgdesc = A code font with monospaced ligatures
+ pkgver = 1.0.beta.r13.a2367c1
+ pkgrel = 1
+ url = https://github.com/i-tu/Hasklig
+ install = fonts.install
+ arch = any
+ license = custom:SIL Open Font License
+ makedepends = git
+ makedepends = afdko
+ makedepends = python2
+ makedepends = python2-fonttools
+ depends = fontconfig
+ depends = xorg-font-utils
+ provides = otf-hasklig
+ conflicts = otf-hasklig
+ source = git+https://github.com/i-tu/Hasklig.git
+ source = https://raw.githubusercontent.com/adobe-fonts/source-code-pro/master/LICENSE.txt
+ source = use-python2.patch
+ sha256sums = SKIP
+ sha256sums = cb30d3086a8b3ce0b9e3690bf48d6620402b61160bc658076f95180ccd9e9dae
+ sha256sums = 948abd484e9d0c404c62af183a521003cde172ed34f5d96b8025e4f075c01f3f
+
+pkgname = otf-hasklig-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b22f57f654b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: William Turner <willtur.will@gmail.com>
+pkgname=otf-hasklig-git
+_pkgname=Hasklig
+pkgver=1.0.beta.r13.a2367c1
+pkgrel=1
+pkgdesc='A code font with monospaced ligatures'
+arch=('any')
+url='https://github.com/i-tu/Hasklig'
+license=('custom:SIL Open Font License')
+depends=('fontconfig' 'xorg-font-utils')
+makedepends=('git' 'afdko' 'python2' 'python2-fonttools')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=fonts.install
+source=("git+https://github.com/i-tu/${_pkgname}.git"
+ 'https://raw.githubusercontent.com/adobe-fonts/source-code-pro/master/LICENSE.txt'
+ 'use-python2.patch')
+sha256sums=('SKIP'
+ 'cb30d3086a8b3ce0b9e3690bf48d6620402b61160bc658076f95180ccd9e9dae'
+ '948abd484e9d0c404c62af183a521003cde172ed34f5d96b8025e4f075c01f3f')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ patch -p1 -i "${srcdir}/use-python2.patch"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ ./buildInstances.sh
+ ./build.sh
+}
+
+package() {
+ cd "${srcdir}"
+ install -d "${pkgdir}/usr/share/fonts/OTF/"
+ install -m644 "${_pkgname}/target/"*.otf "${pkgdir}/usr/share/fonts/OTF/"
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/fonts.install b/fonts.install
new file mode 100644
index 000000000000..ac6cb5b6f4ac
--- /dev/null
+++ b/fonts.install
@@ -0,0 +1,11 @@
+post_install() {
+ fc-cache -s
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/use-python2.patch b/use-python2.patch
new file mode 100644
index 000000000000..f225a9d18079
--- /dev/null
+++ b/use-python2.patch
@@ -0,0 +1,9 @@
+diff -Nur A/addSVGtable.py B/addSVGtable.py
+--- A/addSVGtable.py 2017-01-04 16:58:35.176381805 -0500
++++ B/addSVGtable.py 2017-01-04 22:05:15.567590234 -0500
+@@ -1,4 +1,4 @@
+-#! /usr/bin/env python
++#! /usr/bin/env python2
+
+ """
+ Adds an SVG table to a TTF or OTF font.