summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
l---------.gitignore1
-rw-r--r--PKGBUILD27
-rw-r--r--otf.install16
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d7dab6df79f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu May 2 06:22:43 UTC 2019
+pkgbase = otf-punk-git
+ pkgdesc = Punk Nova - an OpenType implementation of Donald Knuth's Punk font
+ pkgver = 1.003.r7.g7274715
+ pkgrel = 1
+ url = https://github.com/khaledhosny/punk-otf
+ arch = any
+ license = OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ provides = otf-punk
+ conflicts = otf-punk
+ source = otf-punk-git::git+https://github.com/khaledhosny/punk-otf
+ md5sums = SKIP
+
+pkgname = otf-punk-git
+
diff --git a/.gitignore b/.gitignore
new file mode 120000
index 000000000000..25c0564928e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/home/aksr/arch/pkg/.gitignore \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc56bffb8a67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=otf-punk-git
+pkgver=1.003.r7.g7274715
+pkgrel=1
+pkgdesc="Punk Nova - an OpenType implementation of Donald Knuth's Punk font"
+arch=('any')
+url='https://github.com/khaledhosny/punk-otf'
+license=('OFL')
+depends=('fontconfig' 'xorg-font-utils')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ for f in *.otf; do
+ install -D -m644 $f "$pkgdir/usr/share/fonts/OTF/$f"
+ done
+ install -D -m644 OFL.txt "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
+}
+
diff --git a/otf.install b/otf.install
new file mode 100644
index 000000000000..b0935f6fd98d
--- /dev/null
+++ b/otf.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+