summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD67
3 files changed, 68 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6648895ecfe9..9cbaf5e0342e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
pkgbase = otf-stix
- pkgdesc = An OpenType font with math support, designed for scientific and engineering printing
- pkgver = 2.13
+ pkgdesc = OpenType Unicode fonts for Scientific, Technical, and Mathematical texts
+ pkgver = 2.13.b171
pkgrel = 1
- url = http://www.stixfonts.org
+ url = https://github.com/stipub/stixfonts
arch = any
- license = custom:OFL
- source = static_otf-2.13.zip::https://github.com/stipub/stixfonts/raw/v2.13/zipfiles/static_otf.zip
- source = OFL-2.13.txt::https://github.com/stipub/stixfonts/raw/v2.13/OFL.txt
- sha256sums = 58f759a766ba4fa3d4d112b190e8119afd64984aaa31d5dc273a8ce46223cc29
- sha256sums = bec17cee6412788db45fd2644b301afbc99cc5d372ddd3345dc4a7bfdefb9f04
+ license = OFL-1.1-RFN
+ source = stix-otf-static-2.13.b171.zip::https://github.com/stipub/stixfonts/raw/v2.13b171/zipfiles/static_otf.zip
+ source = stix-ttf-variable-2.13.b171.zip::https://github.com/stipub/stixfonts/raw/v2.13b171/zipfiles/variable_ttf.zip
+ source = stix-license-2.13.b171.txt::https://github.com/stipub/stixfonts/raw/v2.13b171/OFL.txt
+ sha256sums = b5ec34636e117ec97e71e6b89ad2718618184329bbb3d3be5d1e3b0f8ed52789
+ sha256sums = d567c6c9a899665744e08391daeee1adbf039e109b10309855321b6c1a8f8acd
+ sha256sums = 0c8825913b60d858aacdb33c4ca6660a7d64b0d6464702efbb19313f5765861a
pkgname = otf-stix
+
+pkgname = ttf-stix-variable
diff --git a/.gitignore b/.gitignore
index 9c92ffdaa46f..018a3de08144 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,4 @@
-pkg/
-src/
-OFL-*.txt
-static_otf-*.zip
-otf-stix-*.zst
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 7e9015c9dc75..66934aca3c53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,56 @@
-pkgname=otf-stix
-pkgver=2.13
+# Maintainer:
+
+## useful links
+# http://www.stixfonts.org
+# https://github.com/stipub/stixfonts
+
+# basic info
+_fontname="stix"
+_pkgname="otf-$_fontname"
+pkgbase="$_pkgname"
+pkgname=(
+ otf-stix
+ ttf-stix-variable
+)
+pkgver=2.13.b171
pkgrel=1
-pkgdesc="An OpenType font with math support, designed for scientific and engineering printing"
+pkgdesc="OpenType Unicode fonts for Scientific, Technical, and Mathematical texts"
+url="https://github.com/stipub/stixfonts"
+license=('OFL-1.1-RFN')
arch=('any')
-url="http://www.stixfonts.org"
-license=('custom:OFL')
-source=(
- "static_otf-$pkgver.zip::https://github.com/stipub/stixfonts/raw/v$pkgver/zipfiles/static_otf.zip"
- "OFL-$pkgver.txt::https://github.com/stipub/stixfonts/raw/v$pkgver/OFL.txt"
-)
-sha256sums=('58f759a766ba4fa3d4d112b190e8119afd64984aaa31d5dc273a8ce46223cc29'
- 'bec17cee6412788db45fd2644b301afbc99cc5d372ddd3345dc4a7bfdefb9f04')
-package() {
- install -d "$pkgdir/usr/share/fonts/OTF"
- install -m644 static_otf/*.otf "$pkgdir/usr/share/fonts/OTF/"
- install -Dm644 "OFL-$pkgver.txt" "$pkgdir/usr/share/licenses/$pkgname/OFL.txt"
+# main package
+_main_package() {
+ _pkgsrc=""
+ _tag="v2.13b171"
+ _pkgver=$(pkgver)
+ source=(
+ "$_fontname-otf-static-$_pkgver.zip"::"$url/raw/$_tag/zipfiles/static_otf.zip"
+ "$_fontname-ttf-variable-$_pkgver.zip"::"$url/raw/$_tag/zipfiles/variable_ttf.zip"
+ "$_fontname-license-$_pkgver.txt"::"$url/raw/$_tag/OFL.txt"
+ )
+ sha256sums=(
+ 'b5ec34636e117ec97e71e6b89ad2718618184329bbb3d3be5d1e3b0f8ed52789'
+ 'd567c6c9a899665744e08391daeee1adbf039e109b10309855321b6c1a8f8acd'
+ '0c8825913b60d858aacdb33c4ca6660a7d64b0d6464702efbb19313f5765861a'
+ )
+}
+
+# common functions
+pkgver() {
+ local _pkgver=$(sed -E 's&^[^0-9]+&&; s&([a-z])&.\1&' <<< $_tag)
+ echo "${_pkgver:?}"
}
+
+package_otf-stix() {
+ install -Dm644 static_otf/*.otf -t "$pkgdir/usr/share/fonts/${pkgname%-git}/"
+ install -Dm644 "$_fontname-license-$_pkgver.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_ttf-stix-variable() {
+ install -Dm644 variable_ttf/*.ttf -t "$pkgdir/usr/share/fonts/${pkgname%-git}/"
+ install -Dm644 "$_fontname-license-$_pkgver.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# execute
+_main_package