summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19f8221db89d..d991bddf3da6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = otfcc
pkgdesc = A C library and utility for parsing and writing OpenType font files.
- pkgver = 0.9.6
+ pkgver = 0.10.3.alpha
pkgrel = 1
url = https://github.com/caryll/otfcc
arch = i686
arch = x86_64
license = APACHE
makedepends = premake-git
- source = https://github.com/caryll/otfcc/archive/v0.9.6.tar.gz
- md5sums = 4a1f654612a72f936337f5ec82dcaa46
+ source = https://github.com/caryll/otfcc/archive/v0.10.3-alpha.tar.gz
+ md5sums = e396c8a1c8feaef5d6757c7244c3c884
pkgname = otfcc
diff --git a/PKGBUILD b/PKGBUILD
index 611c24a4fca8..d1a619f5e1d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: Pau Ruiz Safont <unduthegun@gmail.com>
pkgname=otfcc
pkgver=0.9.6
-pkgrel=1
+pkgrel=2
+tgzver=0.9.6
+foldname="${pkgname}-${tgzver}"
pkgdesc='A C library and utility for parsing and writing OpenType font files.'
arch=('i686' 'x86_64')
url='https://github.com/caryll/otfcc'
license=('APACHE')
makedepends=('premake-git') # premake5
-source=("https://github.com/caryll/${pkgname}/archive/v${pkgver}.tar.gz")
+source=("https://github.com/caryll/${pkgname}/archive/v${tgzver}.tar.gz")
md5sums=('4a1f654612a72f936337f5ec82dcaa46')
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${foldname}"
premake5 gmake
cd build/gmake
if [ "${CARCH}" = "x86_64" ]; then
@@ -24,5 +26,5 @@ build() {
package() {
install -d "${pkgdir}/usr/bin"
- install ${pkgname}-${pkgver}/bin/release-x*/otfcc* "${pkgdir}/usr/bin/"
+ install ${foldname}/bin/release-x*/otfcc* "${pkgdir}/usr/bin/"
}