summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1c4d41e91a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = otfcc
+ pkgdesc = A C library and utility for parsing and writing OpenType font files.
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://github.com/caryll/otfcc
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ makedepends = premake5
+ source = https://github.com/caryll/otfcc/archive/v0.2.3.tar.gz
+ md5sums = e3694cb5fea99488bba4de1ae40cc79b
+
+pkgname = otfcc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65d748a1563b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Andy Kluger <AndyKluger@gmail.com>
+pkgname=otfcc
+pkgver=0.2.3
+pkgrel=1
+pkgdesc='A C library and utility for parsing and writing OpenType font files.'
+arch=('i686' 'x86_64')
+url='https://github.com/caryll/otfcc'
+license=('APACHE')
+makedepends=('premake5')
+source=("https://github.com/caryll/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('e3694cb5fea99488bba4de1ae40cc79b')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ premake5 gmake
+ cd build/gmake
+ if [ "${CARCH}" = "x86_64" ]; then
+ make config=release_x64
+ fi
+ if [ "${CARCH}" = "i686" ]; then
+ make config=release_x86
+ fi
+}
+
+package() {
+ install -d "${pkgdir}/usr/bin"
+ if [ "${CARCH}" = "x86_64" ]; then
+ install "${pkgname}-${pkgver}/bin/Release-x64/otfccbuild" "${pkgdir}/usr/bin/"
+ install "${pkgname}-${pkgver}/bin/Release-x64/otfccdump" "${pkgdir}/usr/bin/"
+ fi
+ if [ "${CARCH}" = "i686" ]; then
+ install "${pkgname}-${pkgver}/bin/Release-x86/otfccbuild" "${pkgdir}/usr/bin/"
+ install "${pkgname}-${pkgver}/bin/Release-x86/otfccdump" "${pkgdir}/usr/bin/"
+ fi
+}