summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD33
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f1ec1b8c6ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = otr-verwaltung3p-dev
+ pkgdesc = Manage your onlinetvrecorder.com files: cut, preview cuts, rate cutlists etc.
+ pkgver = 1.0.0beta002
+ pkgrel = 1
+ url = https://github.com/EinApfelBaum/otr-verwaltung3p
+ arch = any
+ license = GPL3
+ makedepends = python-distutils-extra
+ depends = gtk3
+ depends = python
+ depends = python-gobject
+ depends = gst-python
+ depends = python-xdg
+ depends = python-dbus
+ depends = python-cairo
+ depends = python-requests
+ depends = python-keyring
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = gst-plugins-bad
+ depends = gst-plugins-ugly
+ depends = gst-libav
+ depends = mpv
+ depends = ffmpeg
+ depends = ffms2
+ depends = mediainfo
+ depends = mkvtoolnix-cli
+ optdepends = gnome-keyring: To store the password in keyring
+ optdepends = kwallet: To store the password in wallet
+ optdepends = mediainfo-gui: For plugin Mediainfo
+ optdepends = otr-verwaltung3p-vdub: For cutting old OTR files
+ provides = otr-verwaltung3p
+ conflicts = otr-verwaltung3p
+ conflicts = otr-verwaltung3p-dev-git
+ options = !strip
+ source = https://github.com/EinApfelBaum/otr-verwaltung3p/archive/1.0.0-beta002.tar.gz
+ sha256sums = 11c28866d445fda7ac255e3e850d9d63c44991fd42abf8749b2fd108fc13d3d4
+
+pkgname = otr-verwaltung3p-dev
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fc442c77897
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: gCurse <gcurse at web de>
+
+pkgname=otr-verwaltung3p-dev
+pkgver=1.0.0beta002
+pkgrel=1
+pkgdesc='Manage your onlinetvrecorder.com files: cut, preview cuts, rate cutlists etc.'
+arch=('any')
+url='https://github.com/EinApfelBaum/otr-verwaltung3p'
+license=('GPL3')
+depends=('gtk3' 'python' 'python-gobject' 'gst-python' 'python-xdg' 'python-dbus' 'python-cairo'
+ 'python-requests' 'python-keyring' 'gst-plugins-base' 'gst-plugins-good'
+ 'gst-plugins-bad' 'gst-plugins-ugly' 'gst-libav' 'mpv' 'ffmpeg' 'ffms2' 'mediainfo'
+ 'mkvtoolnix-cli')
+optdepends=('gnome-keyring: To store the password in keyring'
+ 'kwallet: To store the password in wallet'
+ 'mediainfo-gui: For plugin Mediainfo'
+ 'otr-verwaltung3p-vdub: For cutting old OTR files')
+makedepends=('python-distutils-extra')
+conflicts=('otr-verwaltung3p' 'otr-verwaltung3p-dev-git')
+provides=('otr-verwaltung3p')
+
+_pkgname='otr-verwaltung3p'
+_pkgver=1.0.0-beta002
+
+source=("https://github.com/EinApfelBaum/otr-verwaltung3p/archive/${_pkgver}.tar.gz")
+sha256sums=('11c28866d445fda7ac255e3e850d9d63c44991fd42abf8749b2fd108fc13d3d4')
+options=('!strip')
+
+
+package() {
+ cd "${srcdir}/${_pkgname}-${_pkgver}"
+ python setup.py install --prefix=/usr --root=${pkgdir} --optimize=1
+}