summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--bin.otrverwaltung3p.diff58
-rw-r--r--otrverwaltung3p_actions_cutvirtualdub.diff28
4 files changed, 40 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 620eda98793b..265fabda77ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = otr-verwaltung3p-dev
pkgdesc = Manage your onlinetvrecorder.com files: cut, preview cuts, rate cutlists etc.
- pkgver = 1.0.0b8
- pkgrel = 9
+ pkgver = 1.0.0b8.post1
+ pkgrel = 10
url = https://github.com/EinApfelBaum/otr-verwaltung3p
arch = any
license = GPL3
@@ -34,10 +34,10 @@ pkgbase = otr-verwaltung3p-dev
conflicts = otr-verwaltung3p
conflicts = otr-verwaltung3p-dev-git
options = !strip
- source = https://github.com/EinApfelBaum/otr-verwaltung3p/archive/1.0.0b8.tar.gz
- source = bin.otrverwaltung3p.diff
- sha256sums = 60d20095048b4a215be3fdab89742a8c0abf2114150b61a2b8de8e4fd68df780
- sha256sums = 52125d7957be3b42f14d63b9526d3e66751cbb9cfa29de2a329a63df57d6a0a0
+ source = https://github.com/EinApfelBaum/otr-verwaltung3p/archive/1.0.0b8.post1.tar.gz
+ source = otrverwaltung3p_actions_cutvirtualdub.diff
+ sha256sums = 62dba87eaca54b546126e09be94bca2c555acf9eebb3fce11657efb9dc708a84
+ sha256sums = 5f3b58ee6f2259a8e5f25420f561c64beb2fb915ac537bc585d768416ad44ee8
pkgname = otr-verwaltung3p-dev
diff --git a/PKGBUILD b/PKGBUILD
index 6154aaf65f4a..8e2e897da4c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: gCurse <gcurse at web de>
pkgname=otr-verwaltung3p-dev
-pkgver=1.0.0b8
-pkgrel=9
+pkgver=1.0.0b8.post1
+pkgrel=10
pkgdesc='Manage your onlinetvrecorder.com files: cut, preview cuts, rate cutlists etc.'
arch=('any')
url='https://github.com/EinApfelBaum/otr-verwaltung3p'
@@ -21,16 +21,14 @@ provides=('otr-verwaltung3p')
_pkgname='otr-verwaltung3p'
source=("https://github.com/EinApfelBaum/otr-verwaltung3p/archive/${pkgver}.tar.gz"
- "bin.otrverwaltung3p.diff")
-sha256sums=('60d20095048b4a215be3fdab89742a8c0abf2114150b61a2b8de8e4fd68df780'
- '52125d7957be3b42f14d63b9526d3e66751cbb9cfa29de2a329a63df57d6a0a0')
+ "otrverwaltung3p_actions_cutvirtualdub.diff")
+sha256sums=('62dba87eaca54b546126e09be94bca2c555acf9eebb3fce11657efb9dc708a84'
+ '5f3b58ee6f2259a8e5f25420f561c64beb2fb915ac537bc585d768416ad44ee8')
options=('!strip')
prepare() {
# hotfix
- sed -i "s/self\(.*\)disconnect(self.row_activate_id)/# self\1disconnect(self.row_activate_id)/" \
- "${srcdir}/${_pkgname}-${pkgver}/data/plugins/Play.py"
- patch "${srcdir}/${_pkgname}-${pkgver}/bin/otrverwaltung3p" bin.otrverwaltung3p.diff
+ patch "${srcdir}/${_pkgname}-${pkgver}/otrverwaltung3p/actions/cutvirtualdub.py" otrverwaltung3p_actions_cutvirtualdub.diff
}
package() {
diff --git a/bin.otrverwaltung3p.diff b/bin.otrverwaltung3p.diff
deleted file mode 100644
index ffd4c582fce1..000000000000
--- a/bin.otrverwaltung3p.diff
+++ /dev/null
@@ -1,58 +0,0 @@
-diff --git a/bin/otrverwaltung3p b/bin/otrverwaltung3p
-index 7da0c16..c003edb 100755
---- a/bin/otrverwaltung3p
-+++ b/bin/otrverwaltung3p
-@@ -32,7 +32,6 @@ from pathlib import Path
-
- try:
- from gi import require_version
--
- require_version("Gtk", "3.0")
- from gi.repository import Gtk, Gdk
- except Exception as e:
-@@ -473,6 +472,9 @@ class App:
- def __section_otrkey(self):
- fpath = self.config.get("general", "folder_new_otrkeys")
- files = []
-+ if fpath == "":
-+ return files
-+
- if Path(fpath).is_dir():
- files += [
- join(fpath, file_)
-@@ -484,6 +486,8 @@ class App:
- def __section_video_uncut(self):
- fpath = self.config.get("general", "folder_uncut_avis")
- files = []
-+ if fpath == "":
-+ return files
- if Path(fpath).is_dir():
- files += [
- join(fpath, file_)
-@@ -495,6 +499,8 @@ class App:
- def __section_video_cut(self):
- fpath = self.config.get("general", "folder_cut_avis")
- files = []
-+ if fpath == "":
-+ return files
- if Path(fpath).is_dir():
- for file_ in os.listdir(fpath):
- if not self.regex_uncut_video.match(file_):
-@@ -512,6 +518,8 @@ class App:
- def __section_trash_avi(self):
- fpath = self.config.get("general", "folder_trash_avis")
- files = []
-+ if fpath == "":
-+ return files
- if Path(fpath).is_dir():
- files += [
- join(fpath, file_)
-@@ -523,6 +531,8 @@ class App:
- def __section_trash_otrkey(self):
- fpath = self.config.get("general", "folder_trash_otrkeys")
- files = []
-+ if fpath == "":
-+ return files
- if Path(fpath).is_dir():
- files += [
- join(fpath, file_)
diff --git a/otrverwaltung3p_actions_cutvirtualdub.diff b/otrverwaltung3p_actions_cutvirtualdub.diff
new file mode 100644
index 000000000000..951e2b4b7355
--- /dev/null
+++ b/otrverwaltung3p_actions_cutvirtualdub.diff
@@ -0,0 +1,28 @@
+--- otr-verwaltung3p-1.0.0b8.post1/otrverwaltung3p/actions/cutvirtualdub.py 2020-07-23 08:03:38.000000000 +0200
++++ otr-verwaltung3p-1.0.0b8.post1/otrverwaltung3p/actions/cutvirtualdub_b.py 2020-07-23 11:03:57.181021042 +0200
+@@ -16,6 +16,7 @@
+ # END LICENSE
+
+ import os
++import shutil
+ import subprocess
+ import time
+
+@@ -64,13 +65,10 @@
+ return None, error
+
+ # find wine
+- def cmd_exists(x):
+- any(os.access(os.path.join(pathx, x), os.X_OK) for pathx in os.environ["PATH"].split(os.pathsep))
+-
+- if cmd_exists("wineconsole"):
+- winecommand = "wineconsole"
+- elif cmd_exists("wine"):
+- winecommand = "wine"
++ if shutil.which("wineconsole"):
++ winecommand = shutil.which("wineconsole")
++ elif shutil.which("wine"):
++ winecommand = shutil.which("wine")
+ else:
+ return None, "Wine konnte nicht aufgerufen werden."
+