summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--bin.otrverwaltung3p.diff58
3 files changed, 67 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3852cb263d7c..620eda98793b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = otr-verwaltung3p-dev
pkgdesc = Manage your onlinetvrecorder.com files: cut, preview cuts, rate cutlists etc.
pkgver = 1.0.0b8
- pkgrel = 8
+ pkgrel = 9
url = https://github.com/EinApfelBaum/otr-verwaltung3p
arch = any
license = GPL3
@@ -35,7 +35,9 @@ pkgbase = otr-verwaltung3p-dev
conflicts = otr-verwaltung3p-dev-git
options = !strip
source = https://github.com/EinApfelBaum/otr-verwaltung3p/archive/1.0.0b8.tar.gz
+ source = bin.otrverwaltung3p.diff
sha256sums = 60d20095048b4a215be3fdab89742a8c0abf2114150b61a2b8de8e4fd68df780
+ sha256sums = 52125d7957be3b42f14d63b9526d3e66751cbb9cfa29de2a329a63df57d6a0a0
pkgname = otr-verwaltung3p-dev
diff --git a/PKGBUILD b/PKGBUILD
index c2c2fc5dd51c..6154aaf65f4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=otr-verwaltung3p-dev
pkgver=1.0.0b8
-pkgrel=8
+pkgrel=9
pkgdesc='Manage your onlinetvrecorder.com files: cut, preview cuts, rate cutlists etc.'
arch=('any')
url='https://github.com/EinApfelBaum/otr-verwaltung3p'
@@ -20,14 +20,17 @@ provides=('otr-verwaltung3p')
_pkgname='otr-verwaltung3p'
-source=("https://github.com/EinApfelBaum/otr-verwaltung3p/archive/${pkgver}.tar.gz")
-sha256sums=('60d20095048b4a215be3fdab89742a8c0abf2114150b61a2b8de8e4fd68df780')
+source=("https://github.com/EinApfelBaum/otr-verwaltung3p/archive/${pkgver}.tar.gz"
+ "bin.otrverwaltung3p.diff")
+sha256sums=('60d20095048b4a215be3fdab89742a8c0abf2114150b61a2b8de8e4fd68df780'
+ '52125d7957be3b42f14d63b9526d3e66751cbb9cfa29de2a329a63df57d6a0a0')
options=('!strip')
prepare() {
# hotfix
sed -i "s/self\(.*\)disconnect(self.row_activate_id)/# self\1disconnect(self.row_activate_id)/" \
"${srcdir}/${_pkgname}-${pkgver}/data/plugins/Play.py"
+ patch "${srcdir}/${_pkgname}-${pkgver}/bin/otrverwaltung3p" bin.otrverwaltung3p.diff
}
package() {
diff --git a/bin.otrverwaltung3p.diff b/bin.otrverwaltung3p.diff
new file mode 100644
index 000000000000..ffd4c582fce1
--- /dev/null
+++ b/bin.otrverwaltung3p.diff
@@ -0,0 +1,58 @@
+diff --git a/bin/otrverwaltung3p b/bin/otrverwaltung3p
+index 7da0c16..c003edb 100755
+--- a/bin/otrverwaltung3p
++++ b/bin/otrverwaltung3p
+@@ -32,7 +32,6 @@ from pathlib import Path
+
+ try:
+ from gi import require_version
+-
+ require_version("Gtk", "3.0")
+ from gi.repository import Gtk, Gdk
+ except Exception as e:
+@@ -473,6 +472,9 @@ class App:
+ def __section_otrkey(self):
+ fpath = self.config.get("general", "folder_new_otrkeys")
+ files = []
++ if fpath == "":
++ return files
++
+ if Path(fpath).is_dir():
+ files += [
+ join(fpath, file_)
+@@ -484,6 +486,8 @@ class App:
+ def __section_video_uncut(self):
+ fpath = self.config.get("general", "folder_uncut_avis")
+ files = []
++ if fpath == "":
++ return files
+ if Path(fpath).is_dir():
+ files += [
+ join(fpath, file_)
+@@ -495,6 +499,8 @@ class App:
+ def __section_video_cut(self):
+ fpath = self.config.get("general", "folder_cut_avis")
+ files = []
++ if fpath == "":
++ return files
+ if Path(fpath).is_dir():
+ for file_ in os.listdir(fpath):
+ if not self.regex_uncut_video.match(file_):
+@@ -512,6 +518,8 @@ class App:
+ def __section_trash_avi(self):
+ fpath = self.config.get("general", "folder_trash_avis")
+ files = []
++ if fpath == "":
++ return files
+ if Path(fpath).is_dir():
+ files += [
+ join(fpath, file_)
+@@ -523,6 +531,8 @@ class App:
+ def __section_trash_otrkey(self):
+ fpath = self.config.get("general", "folder_trash_otrkeys")
+ files = []
++ if fpath == "":
++ return files
+ if Path(fpath).is_dir():
+ files += [
+ join(fpath, file_)