aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD8
3 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bec7cf368c97..600d9e3c071a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
pkgbase = overgrive
pkgdesc = A complete Google Drive™ desktop client solution for Linux
- pkgver = 3.3.7
+ pkgver = 3.5.0
pkgrel = 0
url = https://www.thefanclub.co.za/overgrive
install = overgrive.install
arch = x86_64
license = unknown
+ depends = gobject-introspection
depends = libappindicator-gtk3
depends = libnotify
depends = python
depends = python-gobject
+ depends = python-google-auth-oauthlib
depends = python-oauth2client
+ depends = python-pip
depends = python-pyinotify
provides = overgrive
conflicts = overgrive
- source = overgrive.tar.xz::https://www.thefanclub.co.za/sites/default/files/public/overgrive/overgrive-3.3.7-0-any.pkg.tar.xz
- md5sums = 31f44a4b705a58be1b94a22b73ad7c56
+ source = https://www.thefanclub.co.za/sites/default/files/public/overgrive/overgrive-3.5.0-0-any.pkg.tar.xz
+ md5sums = 1f0fd32be8507b5ece38af99a75db498
pkgname = overgrive
-
diff --git a/.gitignore b/.gitignore
index d3731f1422ec..687df5dd7ae7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
pkg/
src/
-overgrive*.pkg.tar.xz \ No newline at end of file
+overgrive*.pkg.tar.zst
+overgrive*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 3135f0f9e69b..4c81df558ded 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Pedro Henrique <pedro00dk@gmail.com>
pkgname=overgrive
-pkgver=3.3.10
+pkgver=3.5.0
pkgrel=0
pkgdesc='A complete Google Drive™ desktop client solution for Linux'
arch=('x86_64')
@@ -9,15 +9,15 @@ license=('unknown')
# original overgrive dependencies
# libnotify python python-oauth2client python-pyinotify python-pip python-gobject libappindicator-gtk3
-depends=(libappindicator-gtk3 libnotify python python-gobject python-oauth2client python-pyinotify)
+depends=(gobject-introspection libappindicator-gtk3 libnotify python python-gobject python-google-auth-oauthlib python-oauth2client python-pip python-pyinotify)
provides=('overgrive')
conflicts=('overgrive')
install='overgrive.install'
changelog=
-source=('overgrive.tar.xz::https://www.thefanclub.co.za/sites/default/files/public/overgrive/overgrive-3.3.10-0-any.pkg.tar.xz')
-md5sums=('98c00bfe11373f196db70407a126ecaa')
+source=("https://www.thefanclub.co.za/sites/default/files/public/overgrive/overgrive-$pkgver-0-any.pkg.tar.xz")
+md5sums=('1f0fd32be8507b5ece38af99a75db498')
prepare() {
# chmod 0755 ./opt/thefanclub/overgrive/__pycache__/overgrive.cpython-38.pyc