aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD30
-rw-r--r--build.sh4
-rw-r--r--overgrive.install44
4 files changed, 40 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9189478d73f3..59eb71d1f305 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = overgrive
pkgdesc = A complete Google Drive™ desktop client solution for Linux
- pkgver = 3.3.2
- pkgrel = 1
+ pkgver = 3.3.3
+ pkgrel = 0
url = https://www.thefanclub.co.za/overgrive
install = overgrive.install
arch = x86_64
@@ -14,9 +14,9 @@ pkgbase = overgrive
depends = python-pyinotify
provides = overgrive
conflicts = overgrive
- noextract = overgrive-3.3.2-0-any.pkg.tar.xz
- source = https://www.thefanclub.co.za/sites/default/files/public/overgrive/overgrive-3.3.2-0-any.pkg.tar.xz
- md5sums = e33e8990b637ecbacea36f5a8ea23b7c
+ noextract = overgrive-3.3.3-0-any.pkg.tar.xz
+ source = https://www.thefanclub.co.za/sites/default/files/public/overgrive/overgrive-3.3.3-0-any.pkg.tar.xz
+ md5sums = 09b65ef826d11f5b82400683cf35e3f2
pkgname = overgrive
diff --git a/PKGBUILD b/PKGBUILD
index 950968e9cb62..cedb4a7b7742 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Pedro Henrique <pedro00dk@gmail.com>
pkgname=overgrive
-pkgver=3.3.2
-pkgrel=1
+pkgver=3.3.3
+pkgrel=0
pkgdesc='A complete Google Drive™ desktop client solution for Linux'
arch=('x86_64')
url='https://www.thefanclub.co.za/overgrive'
@@ -16,19 +16,27 @@ conflicts=('overgrive')
install='overgrive.install'
changelog=
-source=('https://www.thefanclub.co.za/sites/default/files/public/overgrive/overgrive-3.3.2-0-any.pkg.tar.xz')
-noextract=('overgrive-3.3.2-0-any.pkg.tar.xz')
-md5sums=('e33e8990b637ecbacea36f5a8ea23b7c')
+source=('https://www.thefanclub.co.za/sites/default/files/public/overgrive/overgrive-3.3.3-0-any.pkg.tar.xz')
+noextract=('overgrive-3.3.3-0-any.pkg.tar.xz')
+md5sums=('09b65ef826d11f5b82400683cf35e3f2')
prepare() {
- tar --extract --file='./overgrive-3.3.2-0-any.pkg.tar.xz'
- rm -- './overgrive-3.3.2-0-any.pkg.tar.xz'
+ tar --extract --file=./overgrive-3.3.3-0-any.pkg.tar.xz
+ rm -- ./overgrive-3.3.3-0-any.pkg.tar.xz
+ # chmod 0755 ./opt/thefanclub/overgrive/__pycache__/overgrive.cpython-38.pyc
+
+ # script to execute through terminal
+ mkdir --parents ./usr/bin/
+ echo -e '/opt/thefanclub/overgrive/venv/bin/python /opt/thefanclub/overgrive/__pycache__/overgrive.cpython-38.pyc' \
+ > ./usr/bin/overgrive
+
+ # update .desktop files
sed --in-place -- \
- 's+Exec=python3+Exec=/opt/thefanclub/overgrive/venv/bin/python3+g' \
- './usr/share/applications/overgrive.desktop' \
- './opt/thefanclub/overgrive/overgrive-autostart.desktop'
+ 's+Exec=.*+Exec=sh /usr/bin/overgrive+g' \
+ ./usr/share/applications/overgrive.desktop \
+ ./opt/thefanclub/overgrive/overgrive-autostart.desktop
}
package() {
- cp --recursive -- './opt/' './usr/' "${pkgdir}/"
+ cp --recursive -- ./opt/ ./usr/ "${pkgdir}/"
}
diff --git a/build.sh b/build.sh
index 104c279563bc..45dc7fe3b923 100644
--- a/build.sh
+++ b/build.sh
@@ -1,2 +1,2 @@
-makepkg -fs
-makepkg --printsrcinfo > .SRCINFO \ No newline at end of file
+makepkg --printsrcinfo > .SRCINFO
+makepkg --force --syncdeps --install --clean \ No newline at end of file
diff --git a/overgrive.install b/overgrive.install
index dd39a8ca0e46..ef84865edd16 100644
--- a/overgrive.install
+++ b/overgrive.install
@@ -1,23 +1,13 @@
post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-
# virtual environement to avoid pip changing system packages
- python3 -m venv --system-site-packages /opt/thefanclub/overgrive/venv
- /opt/thefanclub/overgrive/venv/bin/pip3 install --upgrade google-api-python-client
+ /usr/bin/python -m venv --system-site-packages /opt/thefanclub/overgrive/venv
+ /opt/thefanclub/overgrive/venv/bin/pip install --upgrade google-api-python-client
- # Recomplie Schemas for good measure
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
if [ -f /usr/bin/glib-compile-schemas ]
then
/usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
fi
-
- # Choose cpython interpreter for overgrive and copy correct compiled version and remove folder
- if [ -d /opt/thefanclub/overgrive/__pycache__ ]
- then
- cp /opt/thefanclub/overgrive/__pycache__/$(ls /opt/thefanclub/overgrive/__pycache__ | grep $(python3 -V | cut -d' ' -f2 | cut -d'.' -f1-2 | sed 's/\.//g')) /opt/thefanclub/overgrive/overgrive
- rm -R /opt/thefanclub/overgrive/__pycache__
- chmod 0755 /opt/thefanclub/overgrive/overgrive
- fi
}
post_upgrade() {
@@ -49,29 +39,23 @@ pre_remove() {
fi
fi
- if [ -f "$userHome/.config/autostart/overgrive-autostart.desktop" ]
- then
- rm "$userHome/.config/autostart/overgrive-autostart.desktop"
- fi
+ # if [ -f "$userHome/.config/autostart/overgrive-autostart.desktop" ]
+ # then
+ # rm "$userHome/.config/autostart/overgrive-autostart.desktop"
+ # fi
- if [ -f "$userHome/.config/autostart/overgrive.desktop" ]
- then
- rm "$userHome/.config/autostart/overgrive.desktop"
- fi
-
-
- if [ -f "/opt/thefanclub/overgrive/overgrive" ]
- then
- rm "/opt/thefanclub/overgrive/overgrive"
- fi
+ # if [ -f "$userHome/.config/autostart/overgrive.desktop" ]
+ # then
+ # rm "$userHome/.config/autostart/overgrive.desktop"
+ # fi
+
}
post_remove() {
- sudo rm -rf /opt/thefanclub/overgrive/
-
+ rm -rf /opt/thefanclub/overgrive/
if [ -z "$(ls -A /opt/thefanclub/)" ]
then
- sudo rmdir /opt/thefanclub/
+ rmdir /opt/thefanclub/
fi
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor