summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 22 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9405bdc7dc54..56641aca5319 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = overmind
pkgdesc = Process manager for Procfile-based applications and tmux
- pkgver = 2.2.0
+ pkgver = 2.5.1
pkgrel = 1
url = https://github.com/DarthSim/overmind
arch = x86_64
license = MIT
- makedepends = go-pie
+ makedepends = go
+ depends = glibc
depends = tmux
conflicts = overmind-bin
conflicts = overmind-git
- source = overmind-2.2.0.tar.gz::https://github.com/DarthSim/overmind/archive/v2.2.0.tar.gz
- sha512sums = 2a3619af7f64108b207fc8d28244765febaa28e1acab3e427d19ea6024408aeb0623c0e22c551b8a998a1c66ee71b9e21472e16211243310687b0a3b3e3c647f
- b2sums = a141746ca097abbc3b5bc22d62747c3a9ddad82c67571f0f149e0ffa1a5a171455e64cb53ee716be82b4656eb852ecdcace2c4767be1d33e38453e0a2e26fbf4
+ source = overmind-2.5.1.tar.gz::https://github.com/DarthSim/overmind/archive/v2.5.1.tar.gz
+ sha256sums = d616b89465d488878ed2e1f79e66f8af5b5c2f1d3cf75c2b08e04fb04752d187
+ b2sums = da49f9b8764f80ec55b4d4af7376615a165e058078194c9befe08e5afe5c3e81f315f339166caad009fcc0aa1f335fb58c0025d833bd4034398dbb1396890330
pkgname = overmind
-
diff --git a/PKGBUILD b/PKGBUILD
index 1a276904f01c..9a03735d29e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,34 @@
-# Maintainer: Adrien Smith <adrien at bouldersmiths dot com>
+#!/hint/bash -e
+# Maintainer: Adrien Smith <adrien@panissupraomnia.dev>
+
pkgname=overmind
-pkgver=2.2.0
+pkgver=2.5.1
pkgrel=1
pkgdesc="Process manager for Procfile-based applications and tmux"
arch=("x86_64")
url="https://github.com/DarthSim/$pkgname"
license=("MIT")
-depends=('tmux')
-makedepends=("go-pie")
+depends=('glibc' 'tmux')
+makedepends=("go")
conflicts=("$pkgname-bin" "$pkgname-git")
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha512sums=('2a3619af7f64108b207fc8d28244765febaa28e1acab3e427d19ea6024408aeb0623c0e22c551b8a998a1c66ee71b9e21472e16211243310687b0a3b3e3c647f')
-b2sums=('a141746ca097abbc3b5bc22d62747c3a9ddad82c67571f0f149e0ffa1a5a171455e64cb53ee716be82b4656eb852ecdcace2c4767be1d33e38453e0a2e26fbf4')
+sha256sums=('d616b89465d488878ed2e1f79e66f8af5b5c2f1d3cf75c2b08e04fb04752d187')
+b2sums=('da49f9b8764f80ec55b4d4af7376615a165e058078194c9befe08e5afe5c3e81f315f339166caad009fcc0aa1f335fb58c0025d833bd4034398dbb1396890330')
build() {
cd "$pkgname-$pkgver"
- go build \
- -gcflags "all=-trimpath=$PWD" \
- -asmflags "all=-trimpath=$PWD" \
- -ldflags "-s -w -extldflags $LDFLAGS" \
- -o $pkgname .
+
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o $pkgname .
}
package() {
cd "$pkgname-$pkgver"
+
install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}