summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
-rw-r--r--linux.conf1
-rw-r--r--refind-x86_64.install35
4 files changed, 42 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6957636b5a51..f3d5b17aed33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = refind-x86_64
pkgdesc = Rod Smith's fork of rEFIt (U)EFI Boot Manager
pkgver = 0.2.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.rodsbooks.com/refind/index.html
+ install = refind-x86_64.install
arch = any
license = GPL3
license = custom
@@ -17,7 +18,7 @@ pkgbase = refind-x86_64
source = http://downloads.sourceforge.net/refind/refind-src-0.2.2.zip
source = linux.conf
sha256sums = 45071370d083f3eb46add92c45463d42e444d07d85e320bb675bae04d1ccb0e6
- sha256sums = 7ca14bd8cca670201ce3f5e9bb5d1a8610a9d8f05c2260eb29aaad08e652e5c8
+ sha256sums = 9aac6e65018965ba182ec2d246d37fc5f9269ae96504956d8a51355c3ba1b62f
pkgname = refind-x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 748ef56bd84f..a1074fda2f72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _pkgname="${_actualname}-x86_64"
pkgname="${_pkgname}"
pkgver="0.2.2"
-pkgrel="1"
+pkgrel="2"
pkgdesc="Rod Smith's fork of rEFIt (U)EFI Boot Manager"
url="http://www.rodsbooks.com/refind/index.html"
arch=('any')
@@ -21,12 +21,13 @@ backup=('boot/efi/efi/arch_refind/refind.conf'
'boot/efi/efi/arch_refind/linux.conf')
options=('!strip' 'docs')
+install="${_pkgname}.install"
source=("http://downloads.sourceforge.net/refind/refind-src-${pkgver}.zip"
'linux.conf')
sha256sums=('45071370d083f3eb46add92c45463d42e444d07d85e320bb675bae04d1ccb0e6'
- '7ca14bd8cca670201ce3f5e9bb5d1a8610a9d8f05c2260eb29aaad08e652e5c8')
+ '9aac6e65018965ba182ec2d246d37fc5f9269ae96504956d8a51355c3ba1b62f')
build() {
diff --git a/linux.conf b/linux.conf
index ba52a466d094..614ebda93381 100644
--- a/linux.conf
+++ b/linux.conf
@@ -1,3 +1,4 @@
+## This file should be present in the same directory as the kernel file(s)
## More info at http://www.rodsbooks.com/refind/linux.html , http://www.rodsbooks.com/efi-bootloaders/efistub.html
"Boot with defaults" "root=/dev/disk/by-uuid/XXXXXXXXXXXXXXXXX ro rootfstype=ext4 add_efi_memmap"
diff --git a/refind-x86_64.install b/refind-x86_64.install
new file mode 100644
index 000000000000..170e9f06107c
--- /dev/null
+++ b/refind-x86_64.install
@@ -0,0 +1,35 @@
+post_install() {
+
+ cat << EOF
+
+rEFInd is installed at /boot/efi/efi/arch_refind/refindx64.efi
+
+Usage instructions at /usr/share/refind/docs/html/index.html
+refind.conf info at /usr/share/refind/docs/html/configfile.html
+
+Linux Kernel specific instructions at /usr/share/refind/docs/html/linux.html
+and http://www.rodsbooks.com/efi-bootloaders/efistub.html
+
+Eg:- Kernel file [UEFISYS]/efi/linux_kernels/vmlinuz-linux.efi
+ Initramfs file [UEFISYS]/efi/linux_kernels/initramfs-linux.img
+
+ Then copy /boot/efi/efi/arch_refind/linux.conf to [UEFISYS]/efi/linux_kernels/linux.conf ,
+ and modify the kernel parameters according to your requirements.
+
+In any case "boot/efi/efi/arch_refind/linux.conf" is always backed-up (pacnew or pacsave).
+
+NOTE: rEFInd requires the kernel file(s) to be present as [UEFISYS]/efi/[SOME_DIRECTORY]/[FILENAME].efi
+ and the initramfs file in the same directory, for autodetection to work.
+
+NOTE: linux.conf should be in the same directory as the kernel file(s), not the directory where refind.efi or refindx64.efi resides.
+
+EOF
+
+}
+
+post_upgrade() {
+
+ post_install
+
+}
+