summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD35
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb3c955e0580
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = oxefmsynth
+ pkgdesc = An 8-OP FM synthesizer VST plug-in
+ pkgver = 1.3.3
+ pkgrel = 1
+ url = http://www.oxesoft.com/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = libx11
+ source = https://github.com/oxesoft/oxefmsynth/archive/v1.3.3.zip
+ source = http://www.steinberg.net/sdk_downloads/vstsdk360_22_11_2013_build_100.zip
+ md5sums = e61c6fa2a80b2bf65d1dae9c6ad3e670
+ md5sums = 1ac422ebb4aa2e86061278412c347b55
+
+pkgname = oxefmsynth
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..486d200a85e7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src/
+pkg/
+oxefmsynth-*.tar.xz
+oxefmsynth-*.src.tar.gz
+v*.zip
+.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..665a8c8c4d31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+pkgname=oxefmsynth
+pkgver=1.3.3
+pkgrel=1
+pkgdesc="An 8-OP FM synthesizer VST plug-in"
+arch=('i686' 'x86_64')
+url="http://www.oxesoft.com/"
+license=('GPL3')
+depends=('libx11')
+source=("https://github.com/oxesoft/oxefmsynth/archive/v${pkgver}.zip"
+ 'http://www.steinberg.net/sdk_downloads/vstsdk360_22_11_2013_build_100.zip')
+md5sums=('e61c6fa2a80b2bf65d1dae9c6ad3e670'
+ '1ac422ebb4aa2e86061278412c347b55')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ export VSTSDK_PATH="$srcdir/VST3\\ SDK"
+ # See: http://stackoverflow.com/questions/10789012/g-cdecl-calling-convention-with-steinberg-vst-sdk
+ export CFLAGS='-D__cdecl=""'
+ make -f Makefile.vstlinux
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ if [[ $CARCH == 'i686' ]]; then
+ _arch=32
+ elif [[ $CARCH == 'x86_64' ]]; then
+ _arch=64
+ fi
+
+ install -D oxevst${_arch}.so "$pkgdir/usr/lib/vst/oxevst${_arch}.so"
+}