aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xpac7
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e910de1ba05b..be35b38f72b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Jan 15 02:37:11 UTC 2017
+# Wed Jan 18 13:30:29 UTC 2017
pkgbase = pac
pkgdesc = Small wrapper around pacaur to mimic yaourts search feature
- pkgver = 1.1.0
+ pkgver = 1.1.1
pkgrel = 1
epoch = 1
url = https://github.com/XenGi/pac
diff --git a/PKGBUILD b/PKGBUILD
index 0017c7a9abb8..6d84adeb9e0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Ricardo Band <email@ricardo.band>
pkgname=pac
-pkgver=1.1.0
+pkgver=1.1.1
pkgrel=1
epoch=1
pkgdesc="Small wrapper around pacaur to mimic yaourts search feature"
@@ -10,7 +10,7 @@ license=('MIT')
depends=('python>=3.6.0')
source=('pac')
noextract=('pac')
-sha256sums=('74f077c4cdd95e8e8c691f10a06d8c11c4fda4e793a45243a84e703ee3937374')
+sha256sums=('666ba165dbf4c4b15a19f3f6cf701068055905f8f5e72e00d4b122e849ac351c')
package() {
install -dm 755 "$pkgdir"/usr/bin/
diff --git a/pac b/pac
index c45a0d82a9a6..150a776fb0d5 100755
--- a/pac
+++ b/pac
@@ -17,7 +17,7 @@ __maintainer__ = 'Ricardo Band'
__email__ = 'email@ricardo.band'
import sys
-from subprocess import check_output, call
+from subprocess import call, run, PIPE
def search(search_term: str) -> list:
@@ -51,7 +51,8 @@ def search(search_term: str) -> list:
"""
result: List[dict] = []
- out: str = check_output(['pacaur', '-Ss', search_term])
+ p = run(['pacaur', '-Ss', search_term], stdout=PIPE)
+ out: str = p.stdout.decode()
entry: dict = {}
for line in out.decode().split('\n'):
@@ -148,7 +149,7 @@ def install(numbers: list, packages: list):
Gets the chosen packages and concatinates them. Then executes the pacaur command with the packages to install them.
"""
names = [packages[i]['package'] for i in numbers]
- call('pacaur -S %s' % ' '.join(names), shell=True)
+ call(f"pacaur -S {' '.join(names)}", shell=True)
if __name__ == '__main__':