summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--LICENSE29
-rw-r--r--PKGBUILD9
3 files changed, 38 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 710260ba0114..ea0e018631d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = paccache-hook
pkgdesc = A configurable hook to cleanup the pacman package cache using paccache
pkgver = 1.1.1
- pkgrel = 1
+ pkgrel = 2
arch = any
license = BSD
depends = pacman-contrib
@@ -10,8 +10,10 @@ pkgbase = paccache-hook
source = paccache-hook.conf
source = paccache-hook.sh
source = paccache-hook.hook
+ source = LICENSE
b2sums = c1d92590b4426c52a22152ca4901126ba2622e78ec14eba9be2a9e41f909ddceee01beb8fc4e95a12cd8ed78cb31a12118b0c16ea1498718397f04862c613408
b2sums = b58919eff78e6b63ce0cd724a49c4d39fb2ab37920e14173560485f0d434a6a96b065f9342fa162e8f7a346bd22522fc7b80f7991d2f4ab9df3815f813160aa7
b2sums = ebc6394bd960fd6f2bb26593be20461adf8e251124787e98664343426c9cdec04bfff7677aba0e78d6f43b885f40e415243b683473eaecd082e5f3ef83cc53ab
+ b2sums = 9ec9da9d10bb6bc940a83bb087d04154e41920fe78723d3e746e632a04c50c40bb5bbc807b955f8b81b78a225297c099f7b4077881f8c506b13285a41b65a552
pkgname = paccache-hook
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..696b41dafd4d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,29 @@
+BSD 3-Clause License
+
+Copyright (c) 2023, Felix Barz
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+3. Neither the name of the copyright holder nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index 87d5bf8b550b..1e8d86e448fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Felix Barz <skycoder42.de@gmx.de>
pkgname=paccache-hook
pkgver=1.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="A configurable hook to cleanup the pacman package cache using paccache"
arch=('any')
license=('BSD')
@@ -9,14 +9,17 @@ depends=('pacman-contrib')
conflicts=('pacman-cleanup-hook')
source=("$pkgname.conf"
"$pkgname.sh"
- "$pkgname.hook")
+ "$pkgname.hook"
+ "LICENSE")
b2sums=('c1d92590b4426c52a22152ca4901126ba2622e78ec14eba9be2a9e41f909ddceee01beb8fc4e95a12cd8ed78cb31a12118b0c16ea1498718397f04862c613408'
'b58919eff78e6b63ce0cd724a49c4d39fb2ab37920e14173560485f0d434a6a96b065f9342fa162e8f7a346bd22522fc7b80f7991d2f4ab9df3815f813160aa7'
- 'ebc6394bd960fd6f2bb26593be20461adf8e251124787e98664343426c9cdec04bfff7677aba0e78d6f43b885f40e415243b683473eaecd082e5f3ef83cc53ab')
+ 'ebc6394bd960fd6f2bb26593be20461adf8e251124787e98664343426c9cdec04bfff7677aba0e78d6f43b885f40e415243b683473eaecd082e5f3ef83cc53ab'
+ '9ec9da9d10bb6bc940a83bb087d04154e41920fe78723d3e746e632a04c50c40bb5bbc807b955f8b81b78a225297c099f7b4077881f8c506b13285a41b65a552')
backup=("etc/$pkgname.conf")
package() {
install -D -m644 "${srcdir}/$pkgname.hook" "${pkgdir}/usr/share/libalpm/hooks/$pkgname.hook"
install -D -m755 "${srcdir}/$pkgname.sh" "${pkgdir}/usr/share/libalpm/scripts/$pkgname.sh"
install -D -m644 "${srcdir}/$pkgname.conf" "${pkgdir}/etc/$pkgname.conf"
+ install -D -m644 "${srcdir}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}