summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD75
-rw-r--r--crm_report.in24
-rw-r--r--pacemaker.sysusers3
-rw-r--r--pacemaker.tmpfiles5
5 files changed, 91 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffcf232aba00..7b4c02a88974 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = pacemaker
pkgdesc = advanced, scalable high-availability cluster resource manager
pkgver = 1.1.16
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ClusterLabs/pacemaker/
arch = i686
arch = x86_64
license = GPL2
makedepends = libxml2
makedepends = inkscape
- makedepends = libqb
depends = gnutls
depends = glib2
depends = pam
@@ -17,8 +16,15 @@ pkgbase = pacemaker
depends = libxslt
depends = corosync
depends = libesmtp
+ depends = libqb
source = https://github.com/ClusterLabs/pacemaker/archive/Pacemaker-1.1.16.tar.gz
+ source = pacemaker.sysusers
+ source = pacemaker.tmpfiles
+ source = crm_report.in
md5sums = a3b9d075bc9114ff698966e57e50bb12
+ md5sums = f21b93a2bb62d54b69b9bd4427201707
+ md5sums = 3339ef9d5124e722800b0aeda16f464c
+ md5sums = 07f26ba3fff0749cc5bc5b4da154611d
pkgname = pacemaker
diff --git a/PKGBUILD b/PKGBUILD
index aaeb72741d81..ed141c7381f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,47 +5,74 @@
pkgname=pacemaker
pkgver=1.1.16
-pkgrel=2
+pkgrel=3
pkgdesc="advanced, scalable high-availability cluster resource manager"
arch=('i686' 'x86_64')
url="https://github.com/ClusterLabs/${pkgname}/"
license=('GPL2')
-makedepends=('libxml2' 'inkscape' 'libqb')
-depends=('gnutls' 'glib2' 'pam' 'libtool' 'python' 'libxslt' 'corosync' 'libesmtp')
-source=("https://github.com/ClusterLabs/$pkgname/archive/Pacemaker-$pkgver.tar.gz")
-md5sums=('a3b9d075bc9114ff698966e57e50bb12')
+makedepends=('libxml2' 'inkscape')
+depends=('gnutls' 'glib2' 'pam' 'libtool' 'python' 'libxslt' 'corosync' 'libesmtp' 'libqb')
+source=("https://github.com/ClusterLabs/$pkgname/archive/Pacemaker-$pkgver.tar.gz"
+ 'pacemaker.sysusers'
+ 'pacemaker.tmpfiles'
+ 'crm_report.in')
+md5sums=('a3b9d075bc9114ff698966e57e50bb12'
+ 'f21b93a2bb62d54b69b9bd4427201707'
+ '3339ef9d5124e722800b0aeda16f464c'
+ '07f26ba3fff0749cc5bc5b4da154611d')
prepare() {
cd ${pkgname}-Pacemaker-${pkgver}
- ./autogen.sh
+ autoreconf -fiv
+# ./autogen.sh
}
build() {
cd ${pkgname}-Pacemaker-${pkgver}
- CPPFLAGS=-D_FORTIFY_SOURCE=0 \
- ./configure --sbindir=/usr/bin \
- --sysconfdir=/etc \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --enable-systemd \
- --disable-upstart \
- --with-ais \
- --with-corosync \
- --with-cman \
- --with-cs-quorum \
- --with-nagios \
- --with-snmp \
- --with-esmtp \
- --with-acl
-# --with-nagios-plugin-dir=DIR
-# --with-nagios-metadata-dir=DIR
+ ./configure \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-fatal-warnings \
+ --with-version=$pkgver-$pkgrel \
+ --enable-systemd \
+ --disable-upstart \
+ --with-ais \
+ --with-corosync \
+ --without-heartbeat \
+ --without-cman \
+ --with-cs-quorum \
+ --with-nagios \
+ --with-snmp \
+ --with-esmtp \
+ --with-acl \
+ --with-cibsecrets \
+ --without-profiling \
+ --without-coverage \
+ --with-configdir=/etc/pacemaker
+# --with-nagios-plugin-dir=DIR
+# --with-nagios-metadata-dir=DIR
make V=0
}
package() {
cd ${pkgname}-Pacemaker-${pkgver}
make DESTDIR="${pkgdir}" install
+ cd "$srcdir"
+ install -dm755 "$pkgdir"/usr/lib/{tmpfiles.d,sysusers.d}
+ install -Dm644 $pkgname.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
+ install -Dm644 $pkgname.sysusers "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
+ rm -fr "$pkgdir/var"
+ chmod a+x "$pkgdir/usr/share/pacemaker/tests/cts/CTSlab.py"
+ find "$pkgdir" -name '*.xml' -type f -print0 | xargs -0 chmod a-x
+ find "$pkgdir" -type f -name '*.la' -delete -print
+ rm -fr "$pkgdir/etc/init.d"
+ rm -f "$pkgdir/usr/bin/fence_pcmk"
+ mv "$pkgdir/usr/bin/crm_report" "$pkgdir/usr/bin/crm_report.pacemaker"
+ install -Dm755 crm_report.in "$pkgdir/usr/bin/crm_report"
}
# vim: set sw=2 et:
diff --git a/crm_report.in b/crm_report.in
new file mode 100644
index 000000000000..c5dff3bdd4ae
--- /dev/null
+++ b/crm_report.in
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# Copyright (C) 2007 Dejan Muhamedagic <dmuhamedagic@suse.com>
+# Copyright (C) 2015 Kristoffer Gronlund <kgronlund@suse.com>
+# Copyright (C) 2015 Gao,Yan <ygao@suse.com>
+#
+# Replaced with crm report
+PARENT_COMMAND="$(ps -o comm= $PPID)"
+PROG="$(basename "$0")"
+
+die() {
+ echo "$PROG: $*"
+ exit 1
+}
+[ "$(basename "$PARENT_COMMAND")" = "crm" ] && die "called itself in a loop, aborting"
+if which crm > /dev/null 2>&1; then
+ crm report "$@"
+elif [ -x /usr/sbin/crm ]; then
+ /usr/sbin/crm report "$@"
+else
+ #die "crm_report has been deprecated: Please install crmsh, which replaces it"
+ /usr/sbin/crm_report.pacemaker "$@"
+fi
+
diff --git a/pacemaker.sysusers b/pacemaker.sysusers
new file mode 100644
index 000000000000..7ef9892f4309
--- /dev/null
+++ b/pacemaker.sysusers
@@ -0,0 +1,3 @@
+u hacluster - "Cluster User"
+g haclient - -
+m hacluster haclient
diff --git a/pacemaker.tmpfiles b/pacemaker.tmpfiles
new file mode 100644
index 000000000000..d3c062831b26
--- /dev/null
+++ b/pacemaker.tmpfiles
@@ -0,0 +1,5 @@
+d /var/lib/pacemaker 0750 hacluster haclient
+d /var/lib/pacemaker/blackbox 0750 hacluster haclient
+d /var/lib/pacemaker/cib 0750 hacluster haclient
+d /var/lib/pacemaker/cores 0750 hacluster haclient
+d /var/lib/pacemaker/pengine 0750 hacluster haclient