summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD38
-rw-r--r--pacemaker.install14
3 files changed, 20 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93e6e183a35e..550f5bee5f2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = pacemaker-git
pkgdesc = advanced, scalable high-availability cluster resource manager
- pkgver = 2.0.0.rc4.r10.g922564d4a
+ pkgver = 2.1.2.r0.gada5c3b36
pkgrel = 1
url = https://github.com/ClusterLabs/pacemaker/
- install = pacemaker.install
arch = i686
arch = x86_64
license = GPL2
@@ -28,12 +27,11 @@ pkgbase = pacemaker-git
optdepends = pdsh: for use with some tools
optdepends = crmsh-git: for use with crm_report
optdepends = booth-git: for geo-clustering
- provides = pacemaker
+ provides = pacemaker=2.1.2-1
conflicts = pacemaker
- source = pacemaker-git::git+https://github.com/ClusterLabs/pacemaker.git
+ source = pacemaker-git::git+https://github.com/ClusterLabs/pacemaker.git#branch=2.1
source = crm_report.in
md5sums = SKIP
md5sums = 07f26ba3fff0749cc5bc5b4da154611d
pkgname = pacemaker-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f0a5601dc2d5..b67a06d71453 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=pacemaker-git
_pkgname=pacemaker
-pkgver=2.0.0.rc4.r10.g922564d4a
+pkgver=2.1.2.r0.gada5c3b36
pkgrel=1
pkgdesc="advanced, scalable high-availability cluster resource manager"
arch=('i686' 'x86_64')
@@ -19,10 +19,9 @@ optdepends=('pssh: for use with some tools'
'pdsh: for use with some tools'
'crmsh-git: for use with crm_report'
'booth-git: for geo-clustering')
-provides=(${_pkgname})
-conflicts=(${_pkgname})
-install=${_pkgname}.install
-source=("$pkgname::git+https://github.com/ClusterLabs/${_pkgname}.git"
+provides=("${_pkgname}=${pkgver%%.r*}-${pkgrel}")
+conflicts=("${_pkgname}")
+source=("$pkgname::git+https://github.com/ClusterLabs/${_pkgname}.git#branch=2.1"
'crm_report.in')
md5sums=('SKIP'
'07f26ba3fff0749cc5bc5b4da154611d')
@@ -34,8 +33,7 @@ pkgver() {
prepare() {
cd $pkgname
- autoreconf -fiv
-# ./autogen.sh
+ ./autogen.sh
}
build() {
@@ -52,30 +50,30 @@ build() {
--with-version=$pkgver-$pkgrel \
--enable-systemd \
--disable-upstart \
- --with-ais \
--with-corosync \
- --without-heartbeat \
- --without-cman \
- --with-cs-quorum \
--with-nagios \
- --with-snmp \
- --with-esmtp \
--with-acl \
--with-cibsecrets \
--without-profiling \
--without-coverage \
- --with-configdir=/etc/pacemaker
+ --with-configdir=/etc/pacemaker \
+ --with-initdir=/etc/init.d
# --with-nagios-plugin-dir=DIR
# --with-nagios-metadata-dir=DIR
+ # Fight unused direct deps
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
make V=0
}
package() {
cd $pkgname
make DESTDIR="${pkgdir}" install
+ chown root.root "${pkgdir}"/etc/pacemaker
+ chmod 0755 "${pkgdir}"/etc/pacemaker
cd "$srcdir"
install -Dm644 /dev/null "$pkgdir/usr/lib/tmpfiles.d/$_pkgname.conf"
cat>"$pkgdir/usr/lib/tmpfiles.d/$_pkgname.conf"<<-EOF
+ d /etc/pacemaker 0750 root haclient
d /var/log/pacemaker 0755 hacluster haclient
d /var/lib/pacemaker 0770 hacluster haclient
d /var/lib/pacemaker/blackbox 0770 hacluster haclient
@@ -83,16 +81,14 @@ package() {
d /var/lib/pacemaker/cores 0770 hacluster haclient
d /var/lib/pacemaker/pengine 0770 hacluster haclient
EOF
-# install -Dm644 /dev/null "$pkgdir/usr/lib/sysusers.d/$_pkgname.conf"
-# cat>"$pkgdir/usr/lib/sysusers.d/$_pkgname.conf"<<-EOF
-# u hacluster 189 "Cluster User"
-# g haclient 189 -
-# m hacluster haclient
-# EOF
+ install -Dm644 /dev/null "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
+ cat>"$pkgdir/usr/lib/sysusers.d/$pkgname.conf"<<-EOF
+ g haclient 189
+ u hacluster 189:189 "cluster user" / /sbin/nologin
+ EOF
rm -fr "$pkgdir/var"
chmod a+x "$pkgdir/usr/share/pacemaker/tests/cts/CTSlab.py"
find "$pkgdir" -name '*.xml' -type f -print0 | xargs -0 chmod a-x
- find "$pkgdir" -type f -name '*.la' -delete -print
rm -fr "$pkgdir/etc/init.d"
rm -f "$pkgdir/usr/bin/fence_pcmk"
mv "$pkgdir/usr/bin/crm_report" "$pkgdir/usr/bin/crm_report.pacemaker"
diff --git a/pacemaker.install b/pacemaker.install
deleted file mode 100644
index adf039e5698d..000000000000
--- a/pacemaker.install
+++ /dev/null
@@ -1,14 +0,0 @@
-post_install(){ :
- usr/bin/getent group haclient >/dev/null || usr/bin/groupadd -r haclient -g 189
- usr/bin/getent passwd hacluster >/dev/null || usr/bin/useradd -r -g 189 -u 189 -s /sbin/nologin -c "cluster user" -d / hacluster
-}
-
-post_upgrade(){ :
-}
-
-post_remove(){ :
- usr/bin/getent group haclient >/dev/null && usr/bin/groupdel -f haclient
- usr/bin/getent passwd hacluster >/dev/null && usr/bin/userdel hacluster
-# usr/bin/rm -fr var/lib/pacemaker
-}
-